29 lines
948 B
Diff
29 lines
948 B
Diff
From fd28ef5af20028f233b2fd6de68f4ba7e4992da1 Mon Sep 17 00:00:00 2001
|
|
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
|
Date: Fri, 17 Feb 2023 19:13:35 -0300
|
|
Subject: [PATCH] Changes the path to gtest
|
|
|
|
---
|
|
mlir/CMakeLists.txt | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/mlir/CMakeLists.txt b/mlir/CMakeLists.txt
|
|
index c9b0d53bc3e9..af83f8132405 100644
|
|
--- a/mlir/CMakeLists.txt
|
|
+++ b/mlir/CMakeLists.txt
|
|
@@ -184,7 +184,10 @@ add_subdirectory(lib/CAPI)
|
|
if (MLIR_INCLUDE_TESTS)
|
|
add_definitions(-DMLIR_INCLUDE_TESTS)
|
|
add_custom_target(MLIRUnitTests)
|
|
- if (EXISTS ${LLVM_THIRD_PARTY_DIR}/unittest/googletest/include/gtest/gtest.h)
|
|
+
|
|
+ # Check for gtest
|
|
+ set(UNITTEST_DIR ${LLVM_THIRD_PARTY_DIR}/utils/unittest)
|
|
+ if(EXISTS ${UNITTEST_DIR}/googletest/include/gtest/gtest.h)
|
|
add_subdirectory(unittests)
|
|
else()
|
|
message(WARNING "gtest not found, unittests will not be available")
|
|
--
|
|
2.39.1
|
|
|