18.1.0-rc4 Release
This commit is contained in:
parent
01867b26d4
commit
f82feb738d
@ -1,7 +1,7 @@
|
|||||||
From d8d712c632e925139a6e5e53ee64749301358b25 Mon Sep 17 00:00:00 2001
|
From 1d043550c7601ca776b0318b9b913e5ecf325baf Mon Sep 17 00:00:00 2001
|
||||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||||
Date: Tue, 5 Sep 2023 10:35:37 -0300
|
Date: Tue, 5 Sep 2023 10:35:37 -0300
|
||||||
Subject: [PATCH] [mlir][python] Reuse the library directory
|
Subject: [PATCH] Reuse the library directory
|
||||||
|
|
||||||
Prefer to get the path to the shared libraries from config.llvm_shlib_dir.
|
Prefer to get the path to the shared libraries from config.llvm_shlib_dir.
|
||||||
Fallback to the previous path only if config.llvm_shlib_dir is not
|
Fallback to the previous path only if config.llvm_shlib_dir is not
|
||||||
@ -15,19 +15,19 @@ used downstream.
|
|||||||
2 files changed, 8 insertions(+), 5 deletions(-)
|
2 files changed, 8 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
diff --git a/mlir/test/lit.cfg.py b/mlir/test/lit.cfg.py
|
diff --git a/mlir/test/lit.cfg.py b/mlir/test/lit.cfg.py
|
||||||
index 3a8bdbfcec28..eb8e66a2491c 100644
|
index 38e65e4549c5..4ea1ec922bff 100644
|
||||||
--- a/mlir/test/lit.cfg.py
|
--- a/mlir/test/lit.cfg.py
|
||||||
+++ b/mlir/test/lit.cfg.py
|
+++ b/mlir/test/lit.cfg.py
|
||||||
@@ -130,6 +130,7 @@ tools.extend(
|
@@ -160,6 +160,7 @@ tools.extend(
|
||||||
ToolSubst("toyc-ch7", unresolved="ignore"),
|
ToolSubst("transform-opt-ch2", unresolved="ignore"),
|
||||||
ToolSubst('transform-opt-ch2', unresolved='ignore'),
|
ToolSubst("transform-opt-ch3", unresolved="ignore"),
|
||||||
ToolSubst('transform-opt-ch3', unresolved='ignore'),
|
ToolSubst("transform-opt-ch4", unresolved="ignore"),
|
||||||
+ ToolSubst("%llvm_shlib_dir", config.llvm_shlib_dir, unresolved="ignore"),
|
+ ToolSubst("%llvm_shlib_dir", config.llvm_shlib_dir, unresolved="ignore"),
|
||||||
ToolSubst("%mlir_lib_dir", config.mlir_lib_dir, unresolved="ignore"),
|
ToolSubst("%mlir_lib_dir", config.mlir_lib_dir, unresolved="ignore"),
|
||||||
ToolSubst("%mlir_src_dir", config.mlir_src_root, unresolved="ignore"),
|
ToolSubst("%mlir_src_dir", config.mlir_src_root, unresolved="ignore"),
|
||||||
]
|
]
|
||||||
diff --git a/mlir/test/python/execution_engine.py b/mlir/test/python/execution_engine.py
|
diff --git a/mlir/test/python/execution_engine.py b/mlir/test/python/execution_engine.py
|
||||||
index e8b47007a890..0cb78dd0bac6 100644
|
index e8b47007a890..a7d41eac0080 100644
|
||||||
--- a/mlir/test/python/execution_engine.py
|
--- a/mlir/test/python/execution_engine.py
|
||||||
+++ b/mlir/test/python/execution_engine.py
|
+++ b/mlir/test/python/execution_engine.py
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
@ -45,7 +45,7 @@ index e8b47007a890..0cb78dd0bac6 100644
|
|||||||
|
|
||||||
# Log everything to stderr and flush so that we have a unified stream to match
|
# Log everything to stderr and flush so that we have a unified stream to match
|
||||||
# errors/info emitted by MLIR to stderr.
|
# errors/info emitted by MLIR to stderr.
|
||||||
@@ -540,8 +542,8 @@ def testSharedLibLoad():
|
@@ -621,8 +623,8 @@ def testSharedLibLoad():
|
||||||
]
|
]
|
||||||
else:
|
else:
|
||||||
shared_libs = [
|
shared_libs = [
|
||||||
@ -56,7 +56,7 @@ index e8b47007a890..0cb78dd0bac6 100644
|
|||||||
]
|
]
|
||||||
|
|
||||||
execution_engine = ExecutionEngine(
|
execution_engine = ExecutionEngine(
|
||||||
@@ -583,8 +585,8 @@ def testNanoTime():
|
@@ -664,8 +666,8 @@ def testNanoTime():
|
||||||
]
|
]
|
||||||
else:
|
else:
|
||||||
shared_libs = [
|
shared_libs = [
|
||||||
|
27
mlir.spec
27
mlir.spec
@ -1,8 +1,8 @@
|
|||||||
%global toolchain clang
|
%global toolchain clang
|
||||||
%global maj_ver 17
|
%global maj_ver 18
|
||||||
%global min_ver 0
|
%global min_ver 1
|
||||||
%global patch_ver 6
|
%global patch_ver 0
|
||||||
#global rc_ver 4
|
%global rc_ver 4
|
||||||
%global mlir_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
%global mlir_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||||
%global mlir_srcdir mlir-%{mlir_version}%{?rc_ver:rc%{rc_ver}}.src
|
%global mlir_srcdir mlir-%{mlir_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Name: mlir
|
Name: mlir
|
||||||
Version: %{mlir_version}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{mlir_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Multi-Level Intermediate Representation Overview
|
Summary: Multi-Level Intermediate Representation Overview
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception
|
License: Apache-2.0 WITH LLVM-exception
|
||||||
@ -190,6 +190,14 @@ rm -rf test/mlir-tblgen
|
|||||||
%ifarch s390x
|
%ifarch s390x
|
||||||
# s390x does not support half-float
|
# s390x does not support half-float
|
||||||
rm test/python/execution_engine.py
|
rm test/python/execution_engine.py
|
||||||
|
|
||||||
|
# https://discourse.llvm.org/t/mlir-s390x-linux-failure/76695/25
|
||||||
|
rm test/Target/LLVMIR/llvmir.mlir
|
||||||
|
rm test/python/ir/array_attributes.py
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%ifarch ppc64le
|
||||||
|
rm test/python/execution_engine.py
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
@ -239,6 +247,8 @@ export PYTHONPATH=%{buildroot}/%{python3_sitearch}
|
|||||||
%files
|
%files
|
||||||
%license LICENSE.TXT
|
%license LICENSE.TXT
|
||||||
%{_libdir}/libMLIR*.so.%{maj_ver}*
|
%{_libdir}/libMLIR*.so.%{maj_ver}*
|
||||||
|
%{_libdir}/libmlir_arm_runner_utils.so.%{maj_ver}*
|
||||||
|
%{_libdir}/libmlir_arm_sme_abi_stubs.so.%{maj_ver}*
|
||||||
%{_libdir}/libmlir_async_runtime.so.%{maj_ver}*
|
%{_libdir}/libmlir_async_runtime.so.%{maj_ver}*
|
||||||
%{_libdir}/libmlir_c_runner_utils.so.%{maj_ver}*
|
%{_libdir}/libmlir_c_runner_utils.so.%{maj_ver}*
|
||||||
%{_libdir}/libmlir_float16_utils.so.%{maj_ver}*
|
%{_libdir}/libmlir_float16_utils.so.%{maj_ver}*
|
||||||
@ -257,8 +267,12 @@ export PYTHONPATH=%{buildroot}/%{python3_sitearch}
|
|||||||
%{_bindir}/mlir-reduce
|
%{_bindir}/mlir-reduce
|
||||||
%{_bindir}/mlir-tblgen
|
%{_bindir}/mlir-tblgen
|
||||||
%{_bindir}/mlir-translate
|
%{_bindir}/mlir-translate
|
||||||
|
%{_bindir}/mlir-query
|
||||||
%{_bindir}/tblgen-lsp-server
|
%{_bindir}/tblgen-lsp-server
|
||||||
|
%{_bindir}/tblgen-to-irdl
|
||||||
%{_libdir}/libMLIR*.so
|
%{_libdir}/libMLIR*.so
|
||||||
|
%{_libdir}/libmlir_arm_runner_utils.so
|
||||||
|
%{_libdir}/libmlir_arm_sme_abi_stubs.so
|
||||||
%{_libdir}/libmlir_async_runtime.so
|
%{_libdir}/libmlir_async_runtime.so
|
||||||
%{_libdir}/libmlir_c_runner_utils.so
|
%{_libdir}/libmlir_c_runner_utils.so
|
||||||
%{_libdir}/libmlir_float16_utils.so
|
%{_libdir}/libmlir_float16_utils.so
|
||||||
@ -271,6 +285,9 @@ export PYTHONPATH=%{buildroot}/%{python3_sitearch}
|
|||||||
%{python3_sitearch}/mlir/
|
%{python3_sitearch}/mlir/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 28 2024 Tom Stellard <tstellar@redhat.com> - 18.1.0~rc4-1
|
||||||
|
- 18.1.0-rc4 Release
|
||||||
|
|
||||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 17.0.6-3
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 17.0.6-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (mlir-17.0.6.src.tar.xz) = 40e5310d1ee613d38d2fc1f72cd4902c402e72e18fc44c275bbd7605e86934093a9b1e64329e91a5e99adb7e95c5cede550dd8c500bf505f037ad264ecba268a
|
SHA512 (mlir-18.1.0rc4.src.tar.xz) = be2ed63ac58329e047ab7c537c7f11be10d409e0de8f42d4cfeea3172757486079d28d07f1fc2bb98e97b96ebcfc59381474877bcd6ce4a34eabd530da4facec
|
||||||
SHA512 (mlir-17.0.6.src.tar.xz.sig) = 7fd20f94cbc9c66d2296c70d776aa54cd05ec54e6c5ec2c38306467c9f9e5a12d9d8e4114687fe373da84b727433ec4291fb3523067babb8b07b3a2c4d7e2000
|
SHA512 (mlir-18.1.0rc4.src.tar.xz.sig) = 042b255e0e311037b3b8abb6e15a59f521e9f4dbf726f8195541cd1aac533e8dd0419cfd13531a949759a2eef662d2d8ce0f4f2be2e8534dbd87f07dae322297
|
||||||
|
Loading…
Reference in New Issue
Block a user