Cleanup, rename and normalize patch serie
This commit is contained in:
parent
35bb845814
commit
1f7f4b01ea
@ -1,7 +1,7 @@
|
|||||||
From 2aa1af9b1da0d832270d9b8afcba19a4aba2c366 Mon Sep 17 00:00:00 2001
|
From 9deba96d8f15d948e92c49e40a671fbedc328457 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@moritz.systems>
|
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@moritz.systems>
|
||||||
Date: Tue, 2 Feb 2021 13:09:45 -0600
|
Date: Tue, 2 Feb 2021 13:09:45 -0600
|
||||||
Subject: [PATCH] [MLIR] [CMake] Support building MLIR standalone
|
Subject: [PATCH 1/2] [PATCH][mlir] Support building MLIR standalone
|
||||||
|
|
||||||
Add the necessary bits to CMakeLists to make it possible to configure
|
Add the necessary bits to CMakeLists to make it possible to configure
|
||||||
MLIR against installed LLVM, and build it with minimal need for LLVM
|
MLIR against installed LLVM, and build it with minimal need for LLVM
|
||||||
@ -92,10 +92,10 @@ index 4cfd351..4a814ea 100644
|
|||||||
|
|
||||||
# Declare a dialect in the include directory
|
# Declare a dialect in the include directory
|
||||||
diff --git a/mlir/test/CMakeLists.txt b/mlir/test/CMakeLists.txt
|
diff --git a/mlir/test/CMakeLists.txt b/mlir/test/CMakeLists.txt
|
||||||
index 9ab9c09..999201e 100644
|
index 293d932..5feedd5 100644
|
||||||
--- a/mlir/test/CMakeLists.txt
|
--- a/mlir/test/CMakeLists.txt
|
||||||
+++ b/mlir/test/CMakeLists.txt
|
+++ b/mlir/test/CMakeLists.txt
|
||||||
@@ -42,7 +42,6 @@ configure_lit_site_cfg(
|
@@ -43,7 +43,6 @@ configure_lit_site_cfg(
|
||||||
|
|
||||||
set(MLIR_TEST_DEPENDS
|
set(MLIR_TEST_DEPENDS
|
||||||
FileCheck count not
|
FileCheck count not
|
||||||
@ -103,7 +103,7 @@ index 9ab9c09..999201e 100644
|
|||||||
mlir-capi-ir-test
|
mlir-capi-ir-test
|
||||||
mlir-capi-pass-test
|
mlir-capi-pass-test
|
||||||
mlir-cpu-runner
|
mlir-cpu-runner
|
||||||
@@ -58,6 +57,10 @@ set(MLIR_TEST_DEPENDS
|
@@ -61,6 +60,10 @@ set(MLIR_TEST_DEPENDS
|
||||||
mlir_async_runtime
|
mlir_async_runtime
|
||||||
)
|
)
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
From c95c0db2eb687edb91afa628655bb5025f7e863b Mon Sep 17 00:00:00 2001
|
From e09b298273994b20cc8747765a567d716e241fd2 Mon Sep 17 00:00:00 2001
|
||||||
From: Isuru Fernando <isuruf@gmail.com>
|
From: Isuru Fernando <isuruf@gmail.com>
|
||||||
Date: Thu, 4 Feb 2021 01:59:08 +0000
|
Date: Thu, 4 Feb 2021 01:59:08 +0000
|
||||||
Subject: [PATCH] [MLIR] Fix building unittests in in-tree build
|
Subject: [PATCH 2/2] [PATCH][mlir] Fix building unittests in in-tree build
|
||||||
|
|
||||||
Reviewed By: mehdi_amini
|
Reviewed By: mehdi_amini
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -ru llvm-project-11.0.0rc1.orig/mlir/docs/doxygen.cfg.in llvm-project-11.0.0rc1/mlir/docs/doxygen.cfg.in
|
|
||||||
--- llvm-project-11.0.0rc1.orig/mlir/docs/doxygen.cfg.in 2020-08-28 08:00:16.940946125 +0000
|
|
||||||
+++ llvm-project-11.0.0rc1/mlir/docs/doxygen.cfg.in 2020-08-28 08:05:40.672879026 +0000
|
|
||||||
@@ -1119,7 +1119,7 @@
|
|
||||||
# The default value is: YES.
|
|
||||||
# This tag requires that the tag GENERATE_HTML is set to YES.
|
|
||||||
|
|
||||||
-HTML_TIMESTAMP = YES
|
|
||||||
+HTML_TIMESTAMP = NO
|
|
||||||
|
|
||||||
# If the HTML_DYNAMIC_SECTIONS tag is set to YES then the generated HTML
|
|
||||||
# documentation will contain sections that can be hidden and shown after the
|
|
@ -16,8 +16,8 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{versio
|
|||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{mlir_srcdir}.tar.xz.sig
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{mlir_srcdir}.tar.xz.sig
|
||||||
Source2: tstellar-gpg-key.asc
|
Source2: tstellar-gpg-key.asc
|
||||||
|
|
||||||
Patch0: 0001-MLIR-CMake-Support-building-MLIR-standalone.patch
|
Patch0: 0001-PATCH-mlir-Support-building-MLIR-standalone.patch
|
||||||
Patch1: 0001-MLIR-Fix-building-unittests-in-in-tree-build.patch
|
Patch1: 0002-PATCH-mlir-Fix-building-unittests-in-in-tree-build.patch
|
||||||
|
|
||||||
# Unexpected linking error: neither -j1, disabling lto, LD_LIBRARY_PATH, rpath work
|
# Unexpected linking error: neither -j1, disabling lto, LD_LIBRARY_PATH, rpath work
|
||||||
ExcludeArch: armv7hl
|
ExcludeArch: armv7hl
|
||||||
|
Loading…
x
Reference in New Issue
Block a user