Update to 1.18.1

This commit is contained in:
Sandro Mani 2020-11-02 00:08:38 +01:00
parent abda0ff277
commit 8626f950d2
5 changed files with 33 additions and 138 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@
/gst-plugins-bad-free-1.14.1.tar.xz /gst-plugins-bad-free-1.14.1.tar.xz
/gst-plugins-bad-free-1.14.2.tar.xz /gst-plugins-bad-free-1.14.2.tar.xz
/gst-plugins-bad-free-1.16.2.tar.xz /gst-plugins-bad-free-1.16.2.tar.xz
/gst-plugins-bad-free-1.18.1.tar.xz

View File

@ -41,6 +41,7 @@ dataurisrc
dccp dccp
debugutils debugutils
dtmf dtmf
dvbsubenc
faceoverlay faceoverlay
festival festival
fieldanalysis fieldanalysis
@ -84,6 +85,8 @@ proxy
qtmux qtmux
rawparse rawparse
removesilence removesilence
rist
rtmp2
rtp rtp
rtpmux rtpmux
rtpvp8 rtpvp8
@ -96,7 +99,9 @@ smooth
speed speed
stereo stereo
subenc subenc
switchbin
timecode timecode
transcode
tta tta
valve valve
videofilters videofilters
@ -164,20 +169,6 @@ for subdir in gst ext sys; do
echo "**** Removing $MODULE ****" echo "**** Removing $MODULE ****"
echo "Removing directory $dir" echo "Removing directory $dir"
rm -r $dir || error "Cannot remove $dir" rm -r $dir || error "Cannot remove $dir"
if grep -q "AG_GST_CHECK_PLUGIN($MODULE)" configure.ac ; then
echo "Removing element check for $MODULE"
grep -v "AG_GST_CHECK_PLUGIN($MODULE)" configure.ac > configure.ac.new && mv configure.ac.new configure.ac
fi
echo "Removing Makefile generation for $MODULE"
grep -v "$dir/Makefile" configure.ac > configure.ac.new && mv configure.ac.new configure.ac
# Urgh
if test $MODULE = real ; then
grep -v "AG_GST_DISABLE_PLUGIN(real)" configure.ac > configure.ac.new && mv configure.ac.new configure.ac
fi
echo "Removing documentation for $MODULE"
if grep -q "$MODULE" docs/plugins/Makefile.am ; then
grep -v $dir docs/plugins/Makefile.am > docs/plugins/Makefile.am.new && mv docs/plugins/Makefile.am.new docs/plugins/Makefile.am
fi
echo echo
elif test $subdir = ext || test $subdir = sys; then elif test $subdir = ext || test $subdir = sys; then
# Ignore library or system non-blacklisted plugins # Ignore library or system non-blacklisted plugins
@ -197,8 +188,6 @@ if test "x$unknown" != "x"; then
exit 1 exit 1
fi fi
autoreconf
popd > /dev/null popd > /dev/null
tar cJf $NEW_SOURCE $DIRECTORY tar cJf $NEW_SOURCE $DIRECTORY

View File

@ -1,91 +0,0 @@
--- gst-plugins-bad-1.16.2/common/glib-gen.mak
+++ gst-plugins-bad-1.16.2/common/glib-gen.mak
@@ -1,11 +1,13 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_enum_prefix=gst_color_balance
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
%-marshal.h: %-marshal.list
--- gst-plugins-bad-1.16.2/common/gst-glib-gen.mak
+++ gst-plugins-bad-1.16.2/common/gst-glib-gen.mak
@@ -1,14 +1,16 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
#glib_gen_basename=colorbalance
#glib_gen_decl_banner=GST_EXPORT
-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
+#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
$(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
--- gst-plugins-bad-1.16.2/gst-libs/gst/interfaces/Makefile.am
+++ gst-plugins-bad-1.16.2/gst-libs/gst/interfaces/Makefile.am
@@ -5,13 +5,15 @@
headers_photography = \
photography.h
+H := \#
+
# variables used for enum/marshal generation
glib_enum_headers=$(headers_photography)
glib_enum_define=GST_PHOTOGRAPHY
glib_gen_prefix=gst_photography
glib_gen_basename=photography
glib_gen_decl_banner=GST_PHOTOGRAPHY_API
-glib_gen_decl_include=\#include <gst/interfaces/photography-prelude.h>
+glib_gen_decl_include=$(H)include <gst/interfaces/photography-prelude.h>
built_sources = \
photography-enumtypes.c
--- gst-plugins-bad-1.16.2/gst-libs/gst/mpegts/Makefile.am
+++ gst-plugins-bad-1.16.2/gst-libs/gst/mpegts/Makefile.am
@@ -47,11 +47,13 @@
gst-scte-section.h \
gst-dvb-descriptor.h
+H := \#
+
glib_enum_define=GST_MPEGTS
glib_gen_prefix=gst_mpegts
glib_gen_basename=gstmpegts
glib_gen_decl_banner=GST_MPEGTS_API
-glib_gen_decl_include=\#include <gst/mpegts/mpegts-prelude.h>
+glib_gen_decl_include=$(H)include <gst/mpegts/mpegts-prelude.h>
BUILT_SOURCES = gstmpegts-enumtypes.c gstmpegts-enumtypes.h
nodist_libgstmpegts_@GST_API_VERSION@_la_SOURCES = gstmpegts-enumtypes.c
--- gst-plugins-bad-1.16.2/gst-libs/gst/webrtc/Makefile.am
+++ gst-plugins-bad-1.16.2/gst-libs/gst/webrtc/Makefile.am
@@ -1,11 +1,13 @@
lib_LTLIBRARIES = libgstwebrtc-@GST_API_VERSION@.la
+H := \#
+
glib_enum_headers = dtlstransport.h icetransport.h rtptransceiver.h webrtc_fwd.h
glib_enum_define = GST_WEBRTC
glib_gen_prefix = gst_webrtc
glib_gen_basename = webrtc
glib_gen_decl_banner=GST_WEBRTC_API
-glib_gen_decl_include=\#include <gst/webrtc/webrtc_fwd.h>
+glib_gen_decl_include=$(H)include <gst/webrtc/webrtc_fwd.h>
built_sources = webrtc-enumtypes.c
built_headers = webrtc-enumtypes.h

View File

@ -3,8 +3,8 @@
%global api_version 1.0 %global api_version 1.0
Name: mingw-gstreamer1-plugins-bad-free Name: mingw-gstreamer1-plugins-bad-free
Version: 1.16.2 Version: 1.18.1
Release: 3%{?dist} Release: 1%{?dist}
Summary: Cross compiled GStreamer1 plug-ins "bad" Summary: Cross compiled GStreamer1 plug-ins "bad"
# The freeze and nfs plugins are LGPLv2 (only) # The freeze and nfs plugins are LGPLv2 (only)
@ -16,12 +16,12 @@ URL: http://gstreamer.freedesktop.org/
Source0: gst-plugins-bad-free-%{version}.tar.xz Source0: gst-plugins-bad-free-%{version}.tar.xz
Source1: gst-p-bad-cleanup.sh Source1: gst-p-bad-cleanup.sh
# Fix build with Make 4.3
Patch0: gst-plugins-bad-1.16.2-make43.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: autoconf automake libtool gettext-devel BuildRequires: gettext
BuildRequires: gcc-c++
BuildRequires: meson
BuildRequires: mingw32-filesystem >= 95 BuildRequires: mingw32-filesystem >= 95
BuildRequires: mingw64-filesystem >= 95 BuildRequires: mingw64-filesystem >= 95
BuildRequires: mingw32-gcc BuildRequires: mingw32-gcc
@ -113,41 +113,34 @@ well enough, or the code is not of good enough quality.
%build %build
autoreconf -i
# chromaprint was enabled in the !mingw package in 6eadf04 # chromaprint was enabled in the !mingw package in 6eadf04
# openal, openjpeg, ofa, webp were enabled in the !mingw package in c609b28 # openal, openjpeg, ofa, webp were enabled in the !mingw package in c609b28
# there are mingw-openjpeg and mingw-webp packages available # there are mingw-openjpeg and mingw-webp packages available
# uvch264 was enabled in the !mingw package in fcee991 # uvch264 was enabled in the !mingw package in fcee991
# curl and winks are disabled only in the mingw package # curl and winks are disabled only in the mingw package
%mingw_configure \ %mingw_meson \
--disable-silent-rules --disable-fatal-warnings \ -Dpackage-name="Fedora Mingw GStreamer-plugins-bad package" \
--with-package-name="Fedora Mingw GStreamer-plugins-bad package" \ -Dpackage-origin="http://download.fedoraproject.org" \
--with-package-origin="http://download.fedoraproject.org" \ -Dexamples=disabled \
--disable-examples \ -Ddts=disabled \
--enable-debug --disable-static --disable-gtk-doc --enable-experimental \ -Dfaac=disabled -Dfaad=disabled \
--disable-dts --disable-faac --disable-faad --disable-nas \ -Dlibmms=disabled -Dmpeg2enc=disabled -Dmplex=disabled \
--disable-mimic --disable-libmms --disable-mpeg2enc --disable-mplex \ -Dneon=disabled -Drtmp=disabled \
--disable-neon --disable-rtmp --disable-xvid \ -Dflite=disabled -Dsbc=disabled -Dopencv=disabled \
--disable-flite --disable-mpg123 --disable-sbc --disable-opencv \ -Dspandsp=disabled -Dvoamrwbenc=disabled -Dx265=disabled \
--disable-spandsp --disable-voamrwbenc --disable-x265 \ -Dchromaprint=disabled \
--disable-chromaprint \ -Dopenal=disabled -Dopenjpeg=disabled -Dofa=disabled -Dwebp=disabled \
--disable-openal --disable-openjpeg --disable-ofa --disable-webp \ -Duvch264=disabled -Dcurl=disabled -Dwinks=disabled -Ddvbsuboverlay=disabled
--disable-uvch264 \
--disable-curl \
--disable-winks
%mingw_make %{?_smp_mflags} %mingw_ninja
%install %install
%mingw_make install DESTDIR=%{buildroot} %mingw_ninja_install
# Clean out files that should not be part of the rpm. # Clean out files that should not be part of the rpm.
rm -f %{buildroot}%{mingw32_libdir}/gstreamer-%{api_version}/*.a rm -f %{buildroot}%{mingw32_libdir}/gstreamer-%{api_version}/*.dll.a
rm -f %{buildroot}%{mingw64_libdir}/gstreamer-%{api_version}/*.a rm -f %{buildroot}%{mingw64_libdir}/gstreamer-%{api_version}/*.dll.a
find %{buildroot} -name '*.la' -delete
%mingw_find_lang gstreamer1-plugins-bad-free --all-name %mingw_find_lang gstreamer1-plugins-bad-free --all-name
@ -421,6 +414,9 @@ find %{buildroot} -name '*.la' -delete
%changelog %changelog
* Mon Nov 02 2020 Sandro Mani <manisandro@gmail.com> - 1.18.1-1
- Update to 1.18.1
* Wed Aug 12 13:38:11 GMT 2020 Sandro Mani <manisandro@gmail.com> - 1.16.2-3 * Wed Aug 12 13:38:11 GMT 2020 Sandro Mani <manisandro@gmail.com> - 1.16.2-3
- Rebuild (mingw-gettext) - Rebuild (mingw-gettext)

View File

@ -1 +1 @@
SHA512 (gst-plugins-bad-free-1.16.2.tar.xz) = 6115773c1bb2a2689860fd153d5c84fee9337338d36076f44f772fd6017e04f5843d51e76db63d5517199dcb9310c0edb33eb65269a2962e292cc84d4fa560a7 SHA512 (gst-plugins-bad-free-1.18.1.tar.xz) = e0993729e9f1b1c3ceccc39de75162e7102fb961ba79e558e16c1ab14ff5fe830953eaf8c367f21368de9f0250147eabab3289f26a94e50ea9dace8c8f29e8b1