Add gst-ext-openexr-c++std.patch

This commit is contained in:
Sandro Mani 2019-11-13 19:17:28 +01:00
parent ccb23126e2
commit 76c3737469
2 changed files with 27 additions and 1 deletions

View File

@ -0,0 +1,24 @@
diff -rupN gst-plugins-bad-1.14.2/ext/openexr/Makefile.am gst-plugins-bad-1.14.2-new/ext/openexr/Makefile.am
--- gst-plugins-bad-1.14.2/ext/openexr/Makefile.am 2018-03-23 21:45:15.000000000 +0100
+++ gst-plugins-bad-1.14.2-new/ext/openexr/Makefile.am 2019-11-13 19:08:40.282922215 +0100
@@ -6,7 +6,7 @@ libgstopenexr_la_CFLAGS = \
$(OPENEXR_CFLAGS)
libgstopenexr_la_CXXFLAGS = \
$(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CXXFLAGS) \
- $(OPENEXR_CFLAGS) -std=c++98
+ $(OPENEXR_CFLAGS)
libgstopenexr_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_API_VERSION) \
$(GST_BASE_LIBS) $(GST_LIBS) $(OPENEXR_LIBS)
diff -rupN gst-plugins-bad-1.14.2/ext/openexr/Makefile.in gst-plugins-bad-1.14.2-new/ext/openexr/Makefile.in
--- gst-plugins-bad-1.14.2/ext/openexr/Makefile.in 2018-07-23 13:09:04.000000000 +0200
+++ gst-plugins-bad-1.14.2-new/ext/openexr/Makefile.in 2019-11-13 19:10:44.830707939 +0100
@@ -762,7 +762,7 @@ libgstopenexr_la_CFLAGS = \
libgstopenexr_la_CXXFLAGS = \
$(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CXXFLAGS) \
- $(OPENEXR_CFLAGS) -std=c++98
+ $(OPENEXR_CFLAGS)
libgstopenexr_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_API_VERSION) \

View File

@ -15,6 +15,8 @@ URL: http://gstreamer.freedesktop.org/
# modified with gst1-p-bad-cleanup.sh from SOURCE1
Source0: gst-plugins-bad-free-%{version}.tar.xz
Source1: gst-p-bad-cleanup.sh
# Drop -std=c++98 from the cflags when building openexr support
Patch0: gst-ext-openexr-c++std.patch
BuildArch: noarch
@ -106,7 +108,7 @@ well enough, or the code is not of good enough quality.
%prep
%setup -q -n gst-plugins-bad-%{version}
%autosetup -p1 -n gst-plugins-bad-%{version}
%build