mesa/mesa-6.5-dont-libglut-me-harder-ok-thx-bye.patch
mharris 883815c89f - Added mesa-6.5-dont-libglut-me-harder-ok-thx-bye.patch to prevent libglut
and other libs from being linked into glxgears/glxinfo even though they
    are not actually used. This was the final package linking to freeglut
    in Fedora Core, blocking freeglut from being moved to Extras.
2006-07-25 09:39:35 +00:00

18 lines
429 B
Diff

--- progs/xdemos/Makefile.dont-libglut-me-harder-ok-thx-bye 2006-07-25 05:27:36.000000000 -0400
+++ progs/xdemos/Makefile 2006-07-25 05:33:57.000000000 -0400
@@ -49,8 +49,13 @@
-rm -f $(PROGS)
-rm -f *.o *~
-
# special cases
+glxgears:
+ $(CC) $(CFLAGS) glxgears.c -lGL -o $@
+
+glxinfo:
+ $(CC) $(CFLAGS) glxinfo.c -lGL -lGLU -o $@
+
pbinfo: pbinfo.o pbutil.o
$(CC) $(CFLAGS) pbinfo.o pbutil.o $(APP_LIB_DEPS) -o $@