mesa/mesa-7.1-dri-drivers.patch
2008-02-21 17:46:00 +00:00

61 lines
2.2 KiB
Diff

diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
--- mesa-20080218/configure.ac.jx 2008-02-18 12:01:51.000000000 -0500
+++ mesa-20080218/configure.ac 2008-02-21 12:42:42.000000000 -0500
@@ -459,15 +459,10 @@ if test "$mesa_driver" = dri; then
PROGRAM_DIRS="egl"
fi
- # default drivers
- if test "x$DRI_DIRS" = x; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
- savage sis tdfx trident unichrome ffb"
- fi
-
# Platform specific settings and drivers to build
case "$host_os" in
linux*)
+ echo OMG LINUX
DEFINES="$DEFINES -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER"
DEFINES="$DEFINES -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS"
if test "x$driglx_direct" = xyes; then
@@ -475,7 +470,7 @@ if test "$mesa_driver" = dri; then
fi
case "$host_cpu" in
- x86_64)
+ x86_64*)
# ffb, gamma, and sis are missing because they have not be
# converted to use the new interface. i810 are missing
# because there is no x86-64 system where they could *ever*
@@ -484,13 +479,16 @@ if test "$mesa_driver" = dri; then
DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 radeon \
savage tdfx unichrome"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed 's/i810//g'`"
;;
powerpc*)
+ echo OMG PPC
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = x; then
- DRI_DIRS="mach64 r128 r200 r300 radeon tdfx"
+ DRI_DIRS="mach64 mga r128 r200 r300 radeon savage tdfx"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed s/i810//g | sed s/i9.5//`"
;;
esac
;;
@@ -513,6 +511,12 @@ if test "$mesa_driver" = dri; then
fi
;;
esac
+ # default drivers
+ if test "x$DRI_DIRS" = x; then
+ DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
+ savage sis tdfx trident unichrome ffb"
+ fi
+
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
# Check for expat