mesa/nouveau-legacy-enable.patch

30 lines
1.3 KiB
Diff

diff -up mesa-20100325/configure.ac.nouveau-legacy mesa-20100325/configure.ac
--- mesa-20100325/configure.ac.nouveau-legacy 2010-03-25 08:46:42.000000000 +1000
+++ mesa-20100325/configure.ac 2010-03-25 08:51:14.000000000 +1000
@@ -749,14 +749,14 @@ if test "$mesa_driver" = dri; then
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
- savage tdfx unichrome swrast"
+ savage tdfx unichrome swrast nouveau"
fi
;;
powerpc*)
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast nouveau"
fi
;;
sparc*)
@@ -799,7 +799,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
- savage sis tdfx unichrome swrast"
+ savage sis tdfx unichrome swrast nouveau"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`