0a3293d6d5
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
27 lines
929 B
Diff
27 lines
929 B
Diff
From c2b4d93a5e4796ca53361c61d7e31edc24241932 Mon Sep 17 00:00:00 2001
|
|
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
Date: Sun, 20 Mar 2016 13:26:25 +0100
|
|
Subject: [PATCH 1/4] llvm SONAME without version
|
|
|
|
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5f75c60..d77f907 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2387,7 +2387,7 @@ if test "x$MESA_LLVM" != x0; then
|
|
dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
|
|
if test "x$enable_llvm_shared_libs" = xyes; then
|
|
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
|
|
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
|
|
+ LLVM_SO_NAME=LLVM
|
|
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
|
|
|
|
if test "x$llvm_have_one_so" = xyes; then
|
|
--
|
|
2.7.4
|
|
|