Adam Jackson (1): Unbreak Linux builds with -fvisibility=hidden. Brian (64): added md5 sums fix even-sized point positioning (bug 11874) Merge branch 'mesa_7_0_branch' of git+ssh://brianp@git.freedesktop.org/git/mesa/mesa into mesa_7_0_branch fix bug 9962 (vbo splitting) as in trunk initial 7.0.2 notes fix swizzle error test (bug 11881) fix potential NULL dereference (bug 11880) remove SHELL line, replace -e test with new logic (Daniel Stone) fix potential NULL dereference (bug 11879) move free() after dereference (bug 11878) fix byte swap bug for GLuint stencil indexes (bug 11909) fix link to 7.0.1 relnotes Implement mutex/locking around texture object reference counting. free any render/framebuffers left in hash tables when freeing shared state Add PCI IDs for the G33, Q33, and Q35 chipsets. added more i915/945 chipsets fix blending/banding bug Fix a few more problems with freeing FBOs/textures during context destruction. added some temporary texobj ref counting debug output more tex obj ref count debugging (temporary) Added _mesa_free_attrib_data() to free anything left in the attribute stack upon context destruction. copy Target in _mesa_copy_texture_object() Rewrite quite a bit of the code for glPush/PopAttrib() for texture state. more debug output (context destroy, fb destroy) log deleting/binding of FBOs Remove recent texobj refcount debug/logging code. don't map buffer in _mesa_validate_DrawElements() unless needed refactor bounds checking code remove unneeded CallStack array remove CallDepth++/-- accidentally removed in prev commit new __gluInvertMatrix() function (Mesa bug 6748) Fixed bugs 6748, 12141 s/movaps/movups/ (see bug 12216) fix i965 bugs, x86-64 bugs sync with trunk, fixing bug 12239 Use temporary matrix in __gluInvertMatrixd() to fix aliasing problem (see bugs 12269, 6748) updated VC7 project files clean-up (see bug 12317) fix comment Update depth test state when binding new framebuffer object In _mesa_make_current(), don't unbind FBOs from the old context. fix indirect rendering crash updated with pkg-config info added DSTDIR, pkg-config items added .pc.in files to tarballs Fix state.texgen parsing error (bug 12313). added program_error2() function for better error reporting fix ARB fp/vp parsing bug 12313 fix copypixels overlap test bug (#12417) fix glCopyPixel/glPixelZoom bug 12417) updated link From trunk: mesa: bind VBO_ATTRIB_XXX to correct input array when executing a display list. fix #10604 fix bug 10604 Added bluegene-xlc-osmesa config (Alexander Neundorf) fixes for bluegene-xlc-osmesa config added bluegene-xlc-osmesa, fortran fixes fix for __IBMC__ fix -D_BSD_SOURC fix DrawRangeElements error msg Restore old _TriangleCaps code to fix Blender problem (bug 12164) fix blend bug 12164 bump versions to 7.0.2 for Miniglx, use git sources prep for 7.0.2 release Christoph Kubisch (1): updated VC7 project files Colin McDonald (1): fixed problem with big glDrawArrays (see bug 12141) Dan Nicholson (2): DESTDIR support. pkg-config support Dan Torop (1): fix spantmp2 READ_RGBA inline asm (#11931) Dave Airlie (1): i965: fix vblank on 965gm laptops by bringing in code from i915 Michel Dänzer (2): i915tex: Make sure pitch is aligned properly for render-to-texture. i915tex: Unreference texture buffers on context destruction. Roland Bär (1): [i965] Bug #11812: Fix fwrite return value checks in AUB file code. Roland Scheidegger (2): suppress warning about ncon visuals (bug #6689) fix another occurence of movaps which might not be aligned Wang Zhenyu (1): i915tex: Add support for 945GME Xiang, Haihao (13): i965: flush batch buffer when getting the maximum. This makes i965: samplers group in fours in WM_STATE. fix bug#9415 i965: check NULL pointer. fix bug#12193 i965: store read drawable info in intel_context. Some OpenGL i965: Take the upper limitation on LOD into account. fix bug#11009 i965: limit on LOD Bias, fix#11987 i965: take the secondary color into account when drawing i965: fix #11378 i965: fix bug#11925 i965: The cube map texture coordinates must be devided by the i965: handle all unfilled mode in clip stage. fix bug #12453 mesa: make sure the gotten value isn't greater than the Zou Nan hai (2): fix a bug in 965 ARB_occlusion_query, fix fd.o bug #12217, recalcuate urb when clip plane size change diff --git a/Makefile b/Makefile index 3cab262..e05e0e6 100644 --- a/Makefile +++ b/Makefile @@ -1,7 +1,5 @@ # Top-level Mesa makefile -SHELL = /bin/bash - TOP = . SUBDIRS = src progs @@ -70,6 +68,7 @@ aix-gcc \ aix-static \ beos \ bluegene-osmesa \ +bluegene-xlc-osmesa \ darwin \ darwin-static \ darwin-static-x86ppc \ @@ -156,7 +155,7 @@ sunos5-v9 \ sunos5-v9-static \ sunos5-v9-cc-g++ \ ultrix-gcc: - @ if [ -e configs/current ] ; then \ + @ if test -f configs/current || test -L configs/current ; then \ echo "Please run 'make realclean' before changing configs" ; \ exit 1 ; \ fi @@ -166,10 +165,10 @@ ultrix-gcc: # Rules for making release tarballs -DIRECTORY = Mesa-7.0.1 -LIB_NAME = MesaLib-7.0.1 -DEMO_NAME = MesaDemos-7.0.1 -GLUT_NAME = MesaGLUT-7.0.1 +DIRECTORY = Mesa-7.0.2-rc1 +LIB_NAME = MesaLib-7.0.2-rc1 +DEMO_NAME = MesaDemos-7.0.2-rc1 +GLUT_NAME = MesaGLUT-7.0.2-rc1 MAIN_FILES = \ $(DIRECTORY)/Makefile* \ @@ -213,6 +212,7 @@ MAIN_FILES = \ $(DIRECTORY)/src/mesa/Makefile* \ $(DIRECTORY)/src/mesa/sources \ $(DIRECTORY)/src/mesa/descrip.mms \ + $(DIRECTORY)/src/mesa/gl.pc.in \ $(DIRECTORY)/src/mesa/depend \ $(DIRECTORY)/src/mesa/main/*.[chS] \ $(DIRECTORY)/src/mesa/main/descrip.mms \ @@ -320,6 +320,7 @@ DRI_FILES = \ SGI_GLU_FILES = \ $(DIRECTORY)/src/glu/Makefile \ $(DIRECTORY)/src/glu/descrip.mms \ + $(DIRECTORY)/src/glu/glu.pc.in \ $(DIRECTORY)/src/glu/sgi/Makefile \ $(DIRECTORY)/src/glu/sgi/Makefile.mgw \ $(DIRECTORY)/src/glu/sgi/Makefile.win \ @@ -396,6 +397,7 @@ GLUT_FILES = \ $(DIRECTORY)/include/GL/glutf90.h \ $(DIRECTORY)/src/glut/glx/Makefile* \ $(DIRECTORY)/src/glut/glx/depend \ + $(DIRECTORY)/src/glut/glx/glut.pc.in \ $(DIRECTORY)/src/glut/glx/*def \ $(DIRECTORY)/src/glut/glx/descrip.mms \ $(DIRECTORY)/src/glut/glx/mms_depend \ @@ -418,6 +420,7 @@ DEPEND_FILES = \ $(TOP)/src/mesa/depend \ $(TOP)/src/glx/x11/depend \ $(TOP)/src/glw/depend \ + $(TOP)/src/glw/glw.pc.in \ $(TOP)/src/glut/glx/depend \ $(TOP)/src/glu/sgi/depend diff --git a/configs/bluegene-xlc-osmesa b/configs/bluegene-xlc-osmesa new file mode 100644 index 0000000..b0c762d --- /dev/null +++ b/configs/bluegene-xlc-osmesa @@ -0,0 +1,29 @@ +# Configuration for building only libOSMesa on BlueGene using the IBM xlc compiler +# This doesn't really have a lot of dependencies, so it should be usable +# on similar systems too. +# It uses static linking and disables multithreading. + +include $(TOP)/configs/default + +CONFIG_NAME = bluegene-osmesa + +# Compiler and flags +CC = /opt/ibmcmp/vacpp/bg/8.0/bin/blrts_xlc +CXX = /opt/ibmcmp/vacpp/bg/8.0/bin/blrts_xlC +CFLAGS = -O3 -pedantic -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE +CXXFLAGS = -O3 -pedantic -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE + +MKLIB_OPTIONS = -static + +OSMESA_LIB_NAME = libOSMesa.a + +# Directories +SRC_DIRS = mesa glu +DRIVER_DIRS = osmesa +PROGRAM_DIRS = osdemos + + +# Dependencies +OSMESA_LIB_DEPS = -lm +GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB) +APP_LIB_DEPS = -lOSMesa -lGLU -lm diff --git a/configs/default b/configs/default index 81f0338..275b060 100644 --- a/configs/default +++ b/configs/default @@ -10,7 +10,7 @@ CONFIG_NAME = default # Version info MESA_MAJOR=7 MESA_MINOR=0 -MESA_TINY=1 +MESA_TINY=2 # external projects. This should be useless now that we use libdrm. DRM_SOURCE_PATH=$(TOP)/../drm diff --git a/docs/download.html b/docs/download.html index 5c3989e..84451b8 100644 --- a/docs/download.html +++ b/docs/download.html @@ -9,7 +9,7 @@

Downloading

-Last stable release: 7.0.1 +Last stable release: 7.0.2

diff --git a/docs/fbdev-dri.html b/docs/fbdev-dri.html index c7f59bb..0d9e52c 100644 --- a/docs/fbdev-dri.html +++ b/docs/fbdev-dri.html @@ -28,6 +28,12 @@ Xlib interfaces allowing some degree of application portability between the X and X-less environments.

+

+Some of the files needed for building this configuration are not included +in the normal Mesa releases so you'll need to get the latest sources +sources from the git repository. +

+

2. Compilation

diff --git a/docs/install.html b/docs/install.html index 804dee5..041e27b 100644 --- a/docs/install.html +++ b/docs/install.html @@ -287,7 +287,15 @@ already installed, you'll have to choose different directories, like To install Mesa's headers and libraries, run make install. But first, check the Mesa/configs/default file and examine the values of the INSTALL_DIR and DRI_DRIVER_INSTALL_DIR variables. -Change them if needed, then run make install +Change them if needed, then run make install. +

+ +

+The variable +DESTDIR may also be used to install the contents to a temporary +staging directory. +This can be useful for package management. +For example: make install DESTDIR=/somepath/

@@ -298,6 +306,26 @@ This is a handy way to compare multiple OpenGL implementations.

+

1.5 pkg-config support

+ +

+Running make install will install package configuration files +for the pkg-config utility. +

+ +

+When compiling your OpenGL application you can use pkg-config to determine +the proper compiler and linker flags. +

+ +

+For example, compiling and linking a GLUT application can be done with: +

+
+   gcc `pkg-config --cflags --libs glut` mydemo.c -o mydemo
+
+ +

2. Windows Compilation and Installation

diff --git a/docs/modelers.html b/docs/modelers.html index b93f4d8..aae9686 100644 --- a/docs/modelers.html +++ b/docs/modelers.html @@ -28,7 +28,7 @@
  • Innovation3D - 3D modeling program
  • KWRL - VRML browser -
  • LibVRML97/Lookat +
  • LibVRML97/Lookat - VRML viewer
  • Maverik - VR graphics and interaction system diff --git a/docs/news.html b/docs/news.html index 1f66d4e..8694ce4 100644 --- a/docs/news.html +++ b/docs/news.html @@ -11,9 +11,16 @@

    News

    +

    September ??, 2007

    +

    +Mesa 7.0.2 is released. +This is a bug-fix release. +

    + +

    August 3, 2007

    -Mesa 7.0.1 is released. +Mesa 7.0.1 is released. This is a bug-fix release.

    diff --git a/docs/relnotes-7.0.1.html b/docs/relnotes-7.0.1.html index 47ee162..02713ad 100644 --- a/docs/relnotes-7.0.1.html +++ b/docs/relnotes-7.0.1.html @@ -17,6 +17,15 @@ Mesa 7.0.1 is a stable release with bug fixes since version 7.0.

    MD5 checksums

    +db55141a44b902fcc61d9265b7862c06  MesaLib-7.0.1.tar.gz
    +c056abd763e899114bf745c9eedbf9ad  MesaLib-7.0.1.tar.bz2
    +ecc2637547fae2b38271ae362d013afa  MesaLib-7.0.1.zip
    +b85a4a5be4e829f4a1165e4514b13183  MesaDemos-7.0.1.tar.gz
    +3b66b3268df12ca8a6c4e0c4c457912c  MesaDemos-7.0.1.tar.bz2
    +b1c18006f16e44e80fea66774c59b391  MesaDemos-7.0.1.zip
    +b87a69986839ae43ce12fc8e3dc1ebb4  MesaGLUT-7.0.1.tar.gz
    +25f30d0c1651997b4412366ba0572f7f  MesaGLUT-7.0.1.tar.bz2
    +676ee6682a6ce78a5540554fd975c03e  MesaGLUT-7.0.1.zip
     
    diff --git a/docs/relnotes-7.0.2.html b/docs/relnotes-7.0.2.html new file mode 100644 index 0000000..46040e1 --- /dev/null +++ b/docs/relnotes-7.0.2.html @@ -0,0 +1,84 @@ + + +Mesa Release Notes + + + + + + + +

    Mesa 7.0.2 Release Notes / (TBD) 2007

    + +

    +Mesa 7.0.2 is a stable release with bug fixes since version 7.0. +

    + + +

    MD5 checksums

    +
    +
    + + +

    New features

    + + +

    Bug fixes

    + + + +

    Changes

    + + + +

    To Do (someday) items

    + + + +

    Driver Status

    + +
    +Driver			Status
    +----------------------	----------------------
    +DRI drivers		varies with the driver
    +XMesa/GLX (on Xlib)	implements OpenGL 2.1
    +OSMesa (off-screen)	implements OpenGL 2.1
    +Windows/Win32		implements OpenGL 2.1
    +Glide (3dfx Voodoo1/2)	implements OpenGL 1.3
    +SVGA			unsupported
    +Wind River UGL		unsupported
    +DJGPP			unsupported
    +GGI			unsupported
    +BeOS			unsupported
    +Allegro			unsupported
    +D3D			unsupported
    +
    + + + diff --git a/docs/relnotes.html b/docs/relnotes.html index 9a978d9..7464f5c 100644 --- a/docs/relnotes.html +++ b/docs/relnotes.html @@ -20,6 +20,7 @@ The release notes summarize what's new or changed in each Mesa release.