- patch mesa to enable legacy nouveau driver build on i386

This commit is contained in:
Ben Skeggs 2010-02-08 06:14:40 +00:00
parent 30215b11a8
commit d45f95fceb
2 changed files with 14 additions and 11 deletions

View File

@ -21,7 +21,7 @@
Summary: Mesa graphics libraries
Name: mesa
Version: 7.8
Release: 0.15%{?dist}
Release: 0.16%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -404,6 +404,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
%changelog
* Mon Feb 08 2010 Ben Skeggs <bskeggs@redhat.com> 7.8-0.16
- patch mesa to enable legacy nouveau driver build on i386
* Mon Feb 08 2010 Ben Skeggs <bskeggs@redhat.com> 7.8-0.15
- rebase for legacy nouveau drivers

View File

@ -1,5 +1,5 @@
diff --git a/configure.ac b/configure.ac
index b6c6535..ec44d68 100644
index b6c6535..589b97c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -723,7 +723,7 @@ if test "$mesa_driver" = dri; then
@ -11,12 +11,12 @@ index b6c6535..ec44d68 100644
fi
;;
powerpc*)
@@ -756,7 +756,7 @@ if test "$mesa_driver" = dri; then
# to use the new interface.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
- unichrome savage sis swrast"
+ unichrome savage sis swrast nouveau"
fi
;;
gnu*)
@@ -775,7 +775,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
- savage sis tdfx unichrome ffb swrast"
+ savage sis tdfx unichrome ffb swrast nouveau"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`