Add brw_meta_fast_clear crash workaround patch (#1259443, fdo#86281)

This commit is contained in:
Rex Dieter 2015-09-10 12:09:16 -05:00
parent 58c58b5cf2
commit d386b25cc7
2 changed files with 41 additions and 1 deletions

View File

@ -0,0 +1,30 @@
From e2a696a4cd93c2dbe445243de48ed478fbdb8009 Mon Sep 17 00:00:00 2001
From: Chris Wilson <chris@chris-wilson.co.uk>
Date: Fri, 10 Jul 2015 10:41:35 +0100
Subject: i965: Remove early release of DRI2 miptree
intel_update_winsys_renderbuffer_miptree() will release the existing
miptree when wrapping a new DRI2 buffer, so we can remove the early
release and so prevent a NULL mt dereference should importing the new
DRI2 name fail for any reason. (Reusing the old DRI2 name will result
in the rendering going astray, to a stale buffer, and not shown on the
screen, but it allows us to issue a warning and not crash much later in
innocent code.)
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
diff --git a/src/mesa/drivers/dri/i965/brw_context.c b/src/mesa/drivers/dri/i965/brw_context.c
index e8d1396..72f3897 100644
--- a/src/mesa/drivers/dri/i965/brw_context.c
+++ b/src/mesa/drivers/dri/i965/brw_context.c
@@ -1388,7 +1388,6 @@ intel_process_dri2_buffer(struct brw_context *brw,
buffer->cpp, buffer->pitch);
}
- intel_miptree_release(&rb->mt);
bo = drm_intel_bo_gem_create_from_name(brw->bufmgr, buffer_name,
buffer->name);
if (!bo) {
--
cgit v0.10.2

View File

@ -55,7 +55,7 @@
Summary: Mesa graphics libraries
Name: mesa
Version: 10.6.3
Release: 1.%{git}%{?dist}
Release: 2.%{git}%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -80,6 +80,11 @@ Patch30: mesa-10.3-bigendian-assert.patch
# https://bugs.freedesktop.org/show_bug.cgi?id=73512
Patch99: 0001-opencl-use-versioned-.so-in-mesa.icd.patch
# upstream workaround for recent intel crasher regression
# https://bugzilla.redhat.com/show_bug.cgi?id=1259443
# http://bugs.freedesktop.org/show_bug.cgi?id=86281
Patch100: i965_Remove_early_release_of_DRI2_miptree.patch
# To have sha info in glxinfo
BuildRequires: git
@ -369,6 +374,8 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
%if 0%{?with_opencl}
%patch99 -p1 -b .icd
%endif
%patch100 -p1 -b .i965_Remove_early_release_of_DRI2_miptree
%if 0%{with_private_llvm}
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
@ -714,6 +721,9 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Thu Sep 10 2015 Rex Dieter <rdieter@fedoraproject.org> 10.6.3-2.20150729
- Add brw_meta_fast_clear crash workaround patch (#1259443, fdo#86281)
* Wed Jul 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.6.3-1.20150729
- 10.6.3