rebase for better nvc0 driver + radeon rv6xx flushing fixes.
This commit is contained in:
parent
b28ff10865
commit
d246d9d1dd
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ mesa-20100720.tar.bz2
|
||||
/mesa-20110330.tar.xz
|
||||
/mesa-20110401.tar.xz
|
||||
/mesa-20110412.tar.xz
|
||||
/mesa-20110506.tar.xz
|
||||
|
@ -1,96 +0,0 @@
|
||||
From 9882bff4ce5843b4122a0348acecc7523b9aee22 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Tue, 12 Apr 2011 21:20:48 +1000
|
||||
Subject: [PATCH] nouveau_vieux: fix build since sampler objects merge
|
||||
|
||||
---
|
||||
src/mesa/drivers/dri/nouveau/nv04_state_tex.c | 8 ++++----
|
||||
src/mesa/drivers/dri/nouveau/nv10_state_tex.c | 8 ++++----
|
||||
src/mesa/drivers/dri/nouveau/nv20_state_tex.c | 8 ++++----
|
||||
3 files changed, 12 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/nouveau/nv04_state_tex.c b/src/mesa/drivers/dri/nouveau/nv04_state_tex.c
|
||||
index 6c96e58..648d6b1 100644
|
||||
--- a/src/mesa/drivers/dri/nouveau/nv04_state_tex.c
|
||||
+++ b/src/mesa/drivers/dri/nouveau/nv04_state_tex.c
|
||||
@@ -82,11 +82,11 @@ nv04_emit_tex_obj(struct gl_context *ctx, int emit)
|
||||
|
||||
if (t->Sampler.MinFilter != GL_NEAREST &&
|
||||
t->Sampler.MinFilter != GL_LINEAR) {
|
||||
- lod_max = CLAMP(MIN2(t->MaxLod, t->_MaxLambda),
|
||||
+ lod_max = CLAMP(MIN2(t->Sampler.MaxLod, t->_MaxLambda),
|
||||
0, 15) + 1;
|
||||
|
||||
lod_bias = CLAMP(ctx->Texture.Unit[i].LodBias +
|
||||
- t->LodBias, -16, 15) * 8;
|
||||
+ t->Sampler.LodBias, -16, 15) * 8;
|
||||
}
|
||||
|
||||
format |= nvgl_wrap_mode(t->Sampler.WrapT) << 28 |
|
||||
@@ -96,9 +96,9 @@ nv04_emit_tex_obj(struct gl_context *ctx, int emit)
|
||||
lod_max << 12 |
|
||||
get_tex_format(ti);
|
||||
|
||||
- filter |= log2i(t->MaxAnisotropy) << 31 |
|
||||
+ filter |= log2i(t->Sampler.MaxAnisotropy) << 31 |
|
||||
nvgl_filter_mode(t->Sampler.MagFilter) << 28 |
|
||||
- log2i(t->MaxAnisotropy) << 27 |
|
||||
+ log2i(t->Sampler.MaxAnisotropy) << 27 |
|
||||
nvgl_filter_mode(t->Sampler.MinFilter) << 24 |
|
||||
(lod_bias & 0xff) << 16;
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/nouveau/nv10_state_tex.c b/src/mesa/drivers/dri/nouveau/nv10_state_tex.c
|
||||
index 1d98b19..620a686 100644
|
||||
--- a/src/mesa/drivers/dri/nouveau/nv10_state_tex.c
|
||||
+++ b/src/mesa/drivers/dri/nouveau/nv10_state_tex.c
|
||||
@@ -183,7 +183,7 @@ nv10_emit_tex_obj(struct gl_context *ctx, int emit)
|
||||
| nvgl_filter_mode(t->Sampler.MinFilter) << 24;
|
||||
|
||||
tx_enable = NV10_3D_TEX_ENABLE_ENABLE
|
||||
- | log2i(t->MaxAnisotropy) << 4;
|
||||
+ | log2i(t->Sampler.MaxAnisotropy) << 4;
|
||||
|
||||
if (t->Target == GL_TEXTURE_RECTANGLE) {
|
||||
BEGIN_RING(chan, celsius, NV10_3D_TEX_NPOT_PITCH(i), 1);
|
||||
@@ -198,9 +198,9 @@ nv10_emit_tex_obj(struct gl_context *ctx, int emit)
|
||||
|
||||
if (t->Sampler.MinFilter != GL_NEAREST &&
|
||||
t->Sampler.MinFilter != GL_LINEAR) {
|
||||
- int lod_min = t->MinLod;
|
||||
- int lod_max = MIN2(t->MaxLod, t->_MaxLambda);
|
||||
- int lod_bias = t->LodBias
|
||||
+ int lod_min = t->Sampler.MinLod;
|
||||
+ int lod_max = MIN2(t->Sampler.MaxLod, t->_MaxLambda);
|
||||
+ int lod_bias = t->Sampler.LodBias
|
||||
+ ctx->Texture.Unit[i].LodBias;
|
||||
|
||||
lod_max = CLAMP(lod_max, 0, 15);
|
||||
diff --git a/src/mesa/drivers/dri/nouveau/nv20_state_tex.c b/src/mesa/drivers/dri/nouveau/nv20_state_tex.c
|
||||
index fdbfdf4..eab74ae 100644
|
||||
--- a/src/mesa/drivers/dri/nouveau/nv20_state_tex.c
|
||||
+++ b/src/mesa/drivers/dri/nouveau/nv20_state_tex.c
|
||||
@@ -195,7 +195,7 @@ nv20_emit_tex_obj(struct gl_context *ctx, int emit)
|
||||
| 2 << 12;
|
||||
|
||||
tx_enable = NV20_3D_TEX_ENABLE_ENABLE
|
||||
- | log2i(t->MaxAnisotropy) << 4;
|
||||
+ | log2i(t->Sampler.MaxAnisotropy) << 4;
|
||||
|
||||
if (t->Target == GL_TEXTURE_RECTANGLE) {
|
||||
BEGIN_RING(chan, kelvin, NV20_3D_TEX_NPOT_PITCH(i), 1);
|
||||
@@ -210,9 +210,9 @@ nv20_emit_tex_obj(struct gl_context *ctx, int emit)
|
||||
|
||||
if (t->Sampler.MinFilter != GL_NEAREST &&
|
||||
t->Sampler.MinFilter != GL_LINEAR) {
|
||||
- int lod_min = t->MinLod;
|
||||
- int lod_max = MIN2(t->MaxLod, t->_MaxLambda);
|
||||
- int lod_bias = t->LodBias
|
||||
+ int lod_min = t->Sampler.MinLod;
|
||||
+ int lod_max = MIN2(t->Sampler.MaxLod, t->_MaxLambda);
|
||||
+ int lod_bias = t->Sampler.LodBias
|
||||
+ ctx->Texture.Unit[i].LodBias;
|
||||
|
||||
lod_max = CLAMP(lod_max, 0, 15);
|
||||
--
|
||||
1.7.4.2
|
||||
|
@ -12,13 +12,13 @@
|
||||
%define _default_patch_fuzz 2
|
||||
|
||||
%define manpages gl-manpages-1.0.1
|
||||
%define gitdate 20110412
|
||||
%define gitdate 20110506
|
||||
#% define snapshot
|
||||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 7.11
|
||||
Release: 0.7.%{gitdate}.0%{?dist}
|
||||
Release: 0.8.%{gitdate}.0%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
@ -31,7 +31,6 @@ Source2: %{manpages}.tar.bz2
|
||||
Source3: make-git-snapshot.sh
|
||||
Source4: llvmcore.mk
|
||||
|
||||
Patch1: mesa-nouveau-fix-build.patch
|
||||
Patch2: mesa-7.1-nukeglthread-debug.patch
|
||||
Patch3: mesa-no-mach64.patch
|
||||
Patch4: legacy-drivers.patch
|
||||
@ -215,7 +214,6 @@ Requires: Xorg %(xserver-sdk-abi-requires ansic) %(xserver-sdk-abi-requires vide
|
||||
%prep
|
||||
#setup -q -n Mesa-%{version}%{?snapshot} -b0 -b2
|
||||
%setup -q -n mesa-%{gitdate} -b2
|
||||
%patch1 -p1 -b .nv-fix
|
||||
%patch2 -p1 -b .intel-glthread
|
||||
%patch3 -p1 -b .no-mach64
|
||||
%patch4 -p1 -b .classic
|
||||
@ -488,6 +486,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/libOSMesa.so
|
||||
|
||||
%changelog
|
||||
* Fri May 06 2011 Dave Airlie <airlied@redhat.com> 7.11-0.8.20110506.0
|
||||
- rebase for better nvc0 driver + radeon rv6xx flushing fixes.
|
||||
|
||||
* Mon Apr 18 2011 Adam Jackson <ajax@redhat.com> 7.11-0.7.20110412.0
|
||||
- Fix intel driver exclusion to be better arched (#697555)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user