apply patch for virgl
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
c313ce47a7
commit
c697abeb26
27
0001-virgl-pipe_virgl_create_screen-is-not-static.patch
Normal file
27
0001-virgl-pipe_virgl_create_screen-is-not-static.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From d94d9236e40f8fdf93dd791c8ead803caeb0fbdc Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sun, 22 Nov 2015 10:10:01 +0100
|
||||
Subject: [PATCH] virgl: pipe_virgl_create_screen is not static
|
||||
|
||||
Reference: https://bugs.freedesktop.org/show_bug.cgi?id=93063
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
src/gallium/auxiliary/target-helpers/drm_helper.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gallium/auxiliary/target-helpers/drm_helper.h b/src/gallium/auxiliary/target-helpers/drm_helper.h
|
||||
index 73a80b6..332b1cb 100644
|
||||
--- a/src/gallium/auxiliary/target-helpers/drm_helper.h
|
||||
+++ b/src/gallium/auxiliary/target-helpers/drm_helper.h
|
||||
@@ -223,7 +223,7 @@ pipe_freedreno_create_screen(int fd)
|
||||
#include "virgl/drm/virgl_drm_public.h"
|
||||
#include "virgl/virgl_public.h"
|
||||
|
||||
-static struct pipe_screen *
|
||||
+struct pipe_screen *
|
||||
pipe_virgl_create_screen(int fd)
|
||||
{
|
||||
struct virgl_winsys *vws;
|
||||
--
|
||||
2.6.3
|
||||
|
@ -74,6 +74,9 @@ Patch15: mesa-9.2-hardware-float.patch
|
||||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||
Patch30: mesa-10.3-bigendian-assert.patch
|
||||
|
||||
# http://lists.freedesktop.org/archives/mesa-dev/2015-November/101074.html
|
||||
Patch99: 0001-virgl-pipe_virgl_create_screen-is-not-static.patch
|
||||
|
||||
# To have sha info in glxinfo
|
||||
BuildRequires: git-core
|
||||
|
||||
@ -349,6 +352,8 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
||||
%patch20 -p1 -b .egbe
|
||||
%patch30 -p1 -b .beassert
|
||||
|
||||
%patch99 -p1
|
||||
|
||||
%if 0%{with_private_llvm}
|
||||
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
||||
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
||||
|
Loading…
Reference in New Issue
Block a user