10.2-rc5 upstream release

Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
Igor Gnatenko 2014-05-31 12:37:55 +04:00
parent 3a75afe7c8
commit bcf19e400c
4 changed files with 7 additions and 53 deletions

1
.gitignore vendored
View File

@ -73,3 +73,4 @@ mesa-20100720.tar.bz2
/mesa-20140510.tar.xz
/mesa-20140517.tar.xz
/mesa-20140524.tar.xz
/mesa-20140531.tar.xz

View File

@ -1,44 +0,0 @@
From 34fa604acfa3d9d66524eacaa239c3251dc3237b Mon Sep 17 00:00:00 2001
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Wed, 28 May 2014 08:56:12 +0200
Subject: [PATCH] i915: add a missing NULL pointer check
mesaVisual can be NULL with configless context since this commit:
commit 551d459af421a2eb937e9e16301bb64da4624f89
Author: Neil Roberts <neil@linux.intel.com>
Date: Fri Mar 7 18:05:47 2014 +0000
Add the EGL_MESA_configless_context extension
...
Previously the i965 and i915 drivers were explicitly creating a zeroed visual
whenever 0 is passed for the EGLConfig.
We attempt to dereference the visual in i915 and now we don't create a
zeroed-out one one it crashes, breaking at least weston in an i915. There's
no point in doing so as it would be zero anyway.
Signed-off-by: Lubomir Rintel <lkundrak@v3.sk>
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1100967
Cc: "10.2" <mesa-stable@lists.freedesktop.org>
Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
---
src/mesa/drivers/dri/i915/intel_context.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/mesa/drivers/dri/i915/intel_context.c b/src/mesa/drivers/dri/i915/intel_context.c
index a6057d3..09fe371 100644
--- a/src/mesa/drivers/dri/i915/intel_context.c
+++ b/src/mesa/drivers/dri/i915/intel_context.c
@@ -507,7 +507,7 @@ intelInitContext(struct intel_context *intel,
_mesa_meta_init(ctx);
- intel->hw_stencil = mesaVis->stencilBits && mesaVis->depthBits == 24;
+ intel->hw_stencil = mesaVis && mesaVis->stencilBits && mesaVis->depthBits == 24;
intel->hw_stipple = 1;
intel->RenderIndex = ~0;
--
1.9.3

View File

@ -53,13 +53,13 @@
%define _default_patch_fuzz 2
%define gitdate 20140524
%define gitdate 20140531
#% define snapshot
Summary: Mesa graphics libraries
Name: mesa
Version: 10.2
Release: 0.8.rc4.%{gitdate}%{?dist}
Release: 0.9.rc5.%{gitdate}%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -89,10 +89,6 @@ Patch99: 0001-opencl-use-versioned-.so-in-mesa.icd.patch
Patch100: radeonsi-llvm-version-hack.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1100967
# http://lists.freedesktop.org/archives/mesa-dev/2014-May/060191.html
Patch101: 0001-i915-add-a-missing-NULL-pointer-check.patch
BuildRequires: pkgconfig autoconf automake libtool
%if %{with_hardware}
BuildRequires: kernel-headers
@ -363,8 +359,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
%patch100 -p1 -b .radeonsi_llvm_hack
%patch101 -p1 -b .old_intelInitContext
%if 0%{with_private_llvm}
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
@ -682,6 +676,9 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Sat May 31 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.2-0.9.rc5.20140531
- 10.2-rc5 upstream release
* Wed May 28 2014 Brent Baude <baude@us.ibm.com> - 10.2-0.8.rc4.20140524
- Removing ppc64le arch from with_llvm

View File

@ -1 +1 @@
54f729f3128ad0bcb26d942f97527447 mesa-20140524.tar.xz
57c3d501418276f9a5eb63a599e425fa mesa-20140531.tar.xz