hack llvm so name.

This commit is contained in:
Dave Airlie 2016-02-13 05:49:21 -05:00
parent 2aa1e52e83
commit a78cc1b3d1
2 changed files with 14 additions and 0 deletions

View File

@ -72,6 +72,7 @@ Source3: vl_mpeg12_decoder.c
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
Source4: Mesa-MLAA-License-Clarification-Email.txt
Patch10: mhack.patch
Patch15: mesa-9.2-hardware-float.patch
Patch20: mesa-10.2-evergreen-big-endian.patch
Patch30: mesa-10.3-bigendian-assert.patch
@ -347,6 +348,7 @@ Mesa Direct3D9 state tracker development package
%setup -q -n mesa-%{git}
grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
%patch10 -p1 -b .mhack
%patch15 -p1 -b .hwfloat
%patch20 -p1 -b .egbe
%patch30 -p1 -b .beassert

12
mhack.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up mesa-24ea81a/configure.ac.hack mesa-24ea81a/configure.ac
--- mesa-24ea81a/configure.ac.hack 2016-02-13 05:41:25.692812401 -0500
+++ mesa-24ea81a/configure.ac 2016-02-13 05:41:30.760953027 -0500
@@ -2304,7 +2304,7 @@ if test "x$MESA_LLVM" != x0; then
dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
if test "x$enable_llvm_shared_libs" = xyes; then
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
+ LLVM_SO_NAME=LLVM
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
if test "x$llvm_have_one_so" = xyes; then