- Build fbo files for r100

This commit is contained in:
Dave Airlie 2009-04-01 12:23:39 +00:00
parent 79ee323478
commit a495af1326
2 changed files with 19 additions and 1 deletions

View File

@ -20,7 +20,7 @@
Summary: Mesa graphics libraries
Name: mesa
Version: 7.5
Release: 0.5%{?dist}
Release: 0.6%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -46,6 +46,7 @@ Patch7: mesa-7.1-link-shared.patch
Patch9: intel-revert-vbl.patch
Patch12: mesa-7.1-disable-intel-classic-warn.patch
Patch13: radeon-fix-r100.patch
BuildRequires: pkgconfig autoconf automake
%if %{with_dri}
@ -173,6 +174,7 @@ This package provides some demo applications for testing Mesa.
%patch7 -p1 -b .dricore
%patch9 -p1 -b .intel-vbl
%patch12 -p1 -b .intel-nowarn
%patch13 -p1 -b .r100
# Hack the demos to use installed data files
sed -i 's,../images,%{_libdir}/mesa-demos-data,' progs/demos/*.c
@ -429,6 +431,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/mesa-demos-data
%changelog
* Wed Apr 01 2009 Dave Airlie <airlied@redhat.com> 7.5-0.6
- Build fbo files for r100
* Tue Mar 31 2009 Dave Airlie <airlied@redhat.com> 7.5-0.5
- radeon-rewrite.patch: misc radeon fixes with buffer readbacks

13
radeon-fix-r100.patch Normal file
View File

@ -0,0 +1,13 @@
diff -up mesa-20090322/src/mesa/drivers/dri/radeon/Makefile.dma mesa-20090322/src/mesa/drivers/dri/radeon/Makefile
--- mesa-20090322/src/mesa/drivers/dri/radeon/Makefile.dma 2009-04-01 22:18:56.000000000 +1000
+++ mesa-20090322/src/mesa/drivers/dri/radeon/Makefile 2009-04-01 22:19:05.000000000 +1000
@@ -19,7 +19,8 @@ RADEON_COMMON_SOURCES = \
radeon_bo_legacy.c \
radeon_cs_legacy.c \
radeon_mipmap_tree.c \
- radeon_span.c
+ radeon_span.c \
+ radeon_fbo.c
DRIVER_SOURCES = \
radeon_context.c \