- merged 7.1-0.29 ... 7.1-0.37 changes from F-9 branch

This commit is contained in:
Adam Tkac 2008-07-02 12:35:05 +00:00
parent 386144da3f
commit a2ea5378b5
9 changed files with 164 additions and 2419 deletions

View File

@ -1 +1,2 @@
mesa-20080415.tar.bz2
gl-manpages-1.0.1.tar.bz2
mesa-20080627.tar.bz2

View File

@ -0,0 +1,14 @@
diff -up mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c.nowarn mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c
--- mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c.nowarn 2008-05-07 10:11:10.000000000 +1000
+++ mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c 2008-05-07 10:11:21.000000000 +1000
@@ -479,8 +479,8 @@ intel_init_bufmgr(struct intel_context *
if (ttm_disable) {
fprintf(stderr, "TTM buffer manager disabled. Using classic.\n");
} else {
- fprintf(stderr, "Failed to initialize TTM buffer manager. "
- "Falling back to classic.\n");
+ //fprintf(stderr, "Failed to initialize TTM buffer manager. "
+ // "Falling back to classic.\n");
}
if (intelScreen->tex.size == 0) {

File diff suppressed because it is too large Load Diff

View File

@ -1,6 +1,72 @@
diff -up mesa-20080331/src/mesa/x86/read_rgba_span_x86.S.jx mesa-20080331/src/mesa/x86/read_rgba_span_x86.S
--- mesa-20080331/src/mesa/x86/read_rgba_span_x86.S.jx 2008-03-31 16:58:48.000000000 -0400
+++ mesa-20080331/src/mesa/x86/read_rgba_span_x86.S 2008-04-10 12:11:31.000000000 -0400
diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.dricore mesa-20080612/src/mesa/drivers/dri/Makefile
--- mesa-20080612/src/mesa/drivers/dri/Makefile.dricore 2008-06-12 12:06:50.000000000 +1000
+++ mesa-20080612/src/mesa/drivers/dri/Makefile 2008-06-12 13:25:58.000000000 +1000
@@ -6,12 +6,17 @@ include $(TOP)/configs/current
-default: $(TOP)/$(LIB_DIR) subdirs
+default: $(TOP)/$(LIB_DIR) $(TOP)/$(LIB_DIR)/libdricore.so subdirs
$(TOP)/$(LIB_DIR):
-mkdir $(TOP)/$(LIB_DIR)
+libdricore.so:
+ gcc -shared -o libdricore.so -Wl,--whole-archive ../../libmesa.a -Wl,--no-whole-archive -lm -lpthread -lc
+
+$(TOP)/$(LIB_DIR)/libdricore.so: $(TOP)/$(LIB_DIR) libdricore.so
+ $(INSTALL) libdricore.so $(TOP)/$(LIB_DIR)
subdirs:
@for dir in $(DRI_DIRS) ; do \
@@ -21,12 +26,14 @@ subdirs:
done
-install:
+install: $(TOP)/$(LIB_DIR)/libdricore.so
@for dir in $(DRI_DIRS) ; do \
if [ -d $$dir ] ; then \
(cd $$dir && $(MAKE) install) || exit 1 ; \
fi \
done
+ $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
+ $(INSTALL) -m 755 $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
$(INSTALL) -d $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_sarea.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
@@ -38,4 +45,5 @@ clean:
(cd $$dir && $(MAKE) clean) ; \
fi \
done
+ -rm -f libdricore.so $(TOP)/$(LIB_DIR)/libdricore.so
-rm -f common/*.o
diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080612/src/mesa/drivers/dri/Makefile.template
--- mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore 2008-06-12 12:06:50.000000000 +1000
+++ mesa-20080612/src/mesa/drivers/dri/Makefile.template 2008-06-12 13:15:34.000000000 +1000
@@ -1,6 +1,6 @@
# -*-makefile-*-
-MESA_MODULES = $(TOP)/src/mesa/libmesa.a
+MESA_MODULES = $(TOP)/$(LIB_DIR)/libdricore.so
COMMON_SOURCES = \
../common/utils.c \
@@ -69,7 +69,9 @@ default: symlinks depend $(LIBNAME) $(TO
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
$(TOP)/bin/mklib -ldflags '$(LDFLAGS)' -noprefix -o $@ \
- $(OBJECTS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
+ $(OBJECTS) $(WINOBJ) \
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \
+ $(DRI_LIB_DEPS)
$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)
diff -up mesa-20080612/src/mesa/x86/read_rgba_span_x86.S.dricore mesa-20080612/src/mesa/x86/read_rgba_span_x86.S
--- mesa-20080612/src/mesa/x86/read_rgba_span_x86.S.dricore 2008-06-12 12:06:50.000000000 +1000
+++ mesa-20080612/src/mesa/x86/read_rgba_span_x86.S 2008-06-12 13:15:34.000000000 +1000
@@ -77,7 +77,6 @@
*/
@ -25,7 +91,7 @@ diff -up mesa-20080331/src/mesa/x86/read_rgba_span_x86.S.jx mesa-20080331/src/me
.type _generic_read_RGBA_span_BGRA8888_REV_SSE2, @function
_generic_read_RGBA_span_BGRA8888_REV_SSE2:
pushl %esi
@@ -492,7 +489,6 @@ _generic_read_RGBA_span_BGRA8888_REV_SSE
@@ -494,7 +491,6 @@ _generic_read_RGBA_span_BGRA8888_REV_SSE
.text
.globl _generic_read_RGBA_span_RGB565_MMX
@ -33,69 +99,3 @@ diff -up mesa-20080331/src/mesa/x86/read_rgba_span_x86.S.jx mesa-20080331/src/me
.type _generic_read_RGBA_span_RGB565_MMX, @function
_generic_read_RGBA_span_RGB565_MMX:
diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.jx mesa-20080331/src/mesa/drivers/dri/Makefile
--- mesa-20080331/src/mesa/drivers/dri/Makefile.jx 2008-03-31 16:58:48.000000000 -0400
+++ mesa-20080331/src/mesa/drivers/dri/Makefile 2008-04-10 12:02:30.000000000 -0400
@@ -6,12 +6,17 @@ include $(TOP)/configs/current
-default: $(TOP)/$(LIB_DIR) subdirs
+default: $(TOP)/$(LIB_DIR) $(TOP)/$(LIB_DIR)/libdricore.so subdirs
$(TOP)/$(LIB_DIR):
-mkdir $(TOP)/$(LIB_DIR)
+libdricore.so:
+ ld -shared -o libdricore.so --whole-archive ../../libmesa.a --no-whole-archive -lm -lpthread -lc
+
+$(TOP)/$(LIB_DIR)/libdricore.so: $(TOP)/$(LIB_DIR) libdricore.so
+ $(INSTALL) libdricore.so $(TOP)/$(LIB_DIR)
subdirs:
@for dir in $(DRI_DIRS) ; do \
@@ -21,12 +26,14 @@ subdirs:
done
-install:
+install: $(TOP)/$(LIB_DIR)/libdricore.so
@for dir in $(DRI_DIRS) ; do \
if [ -d $$dir ] ; then \
(cd $$dir && $(MAKE) install) || exit 1 ; \
fi \
done
+ $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
+ $(INSTALL) -m 755 $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
$(TOP)/bin/minstall -d $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
$(TOP)/bin/minstall -m 0644 $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
$(TOP)/bin/minstall -m 0644 $(TOP)/include/GL/internal/dri_sarea.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
@@ -38,4 +45,5 @@ clean:
(cd $$dir && $(MAKE) clean) ; \
fi \
done
+ -rm -f libdricore.so $(TOP)/$(LIB_DIR)/libdricore.so
-rm -f common/*.o
diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.template.jx mesa-20080331/src/mesa/drivers/dri/Makefile.template
--- mesa-20080331/src/mesa/drivers/dri/Makefile.template.jx 2008-03-31 16:58:48.000000000 -0400
+++ mesa-20080331/src/mesa/drivers/dri/Makefile.template 2008-04-10 12:02:30.000000000 -0400
@@ -1,6 +1,6 @@
# -*-makefile-*-
-MESA_MODULES = $(TOP)/src/mesa/libmesa.a
+MESA_MODULES = $(TOP)/$(LIB_DIR)/libdricore.so
COMMON_SOURCES = \
../../common/driverfuncs.c \
@@ -70,7 +70,9 @@ default: symlinks depend $(LIBNAME) $(TO
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
$(TOP)/bin/mklib -ldflags '$(LDFLAGS)' -noprefix -o $@ \
- $(OBJECTS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
+ $(OBJECTS) $(WINOBJ) \
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \
+ $(DRI_LIB_DEPS)
$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)

View File

@ -1,15 +0,0 @@
--- mesa-20080331/configure.ac.BAD 2008-04-12 11:37:32.000000000 -0500
+++ mesa-20080331/configure.ac 2008-04-12 11:39:37.000000000 -0500
@@ -512,6 +512,12 @@
DRI_DIRS="mach64 r128 r200 r300 radeon tdfx"
fi
;;
+ sparc*)
+ # Build only the drivers for cards that exist on sparc`
+ if test "x$DRI_DIRS" = x; then
+ DRI_DIRS="mach64 r128 r200 r300 radeon ffb"
+ fi
+ ;;
esac
;;
freebsd*)

View File

@ -1,39 +1,21 @@
From 8a156f47fc6547d5ed0fb8031f332cbf9e16948d Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@redhat.com>
Date: Thu, 1 Nov 2007 16:16:52 +1000
Subject: [PATCH] mesa: keep OSMESA version at 6.5.3
---
src/mesa/Makefile | 9 +++++----
1 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/src/mesa/Makefile b/src/mesa/Makefile
index 77bb7be..e2a09ed 100644
--- a/src/mesa/Makefile
+++ b/src/mesa/Makefile
@@ -117,17 +117,18 @@ $(TOP)/$(LIB_DIR)/$(GL_LIB_NAME): $(STAND_ALONE_OBJECTS)
$(MKLIB_OPTIONS) $(GL_LIB_DEPS) $(STAND_ALONE_OBJECTS)
# Make the OSMesa library
+# Note: version is kept at 6.5.3 to simplify app/linking issues
$(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME): $(OSMESA_DRIVER_OBJECTS) $(OSMESA16_OBJECTS)
@ if [ "${DRIVER_DIRS}" = "osmesa" ] ; then \
$(TOP)/bin/mklib -o $(OSMESA_LIB) -linker '$(CC)' \
- -ldflags '$(LDFLAGS)' -major $(MESA_MAJOR) \
- -minor $(MESA_MINOR) -patch $(MESA_TINY) \
+ -ldflags '$(LDFLAGS)' -major 6 \
+ -minor 5 -patch 3 \
-install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
$(OSMESA_LIB_DEPS) $(OSMESA16_OBJECTS) ; \
else \
$(TOP)/bin/mklib -o $(OSMESA_LIB) -linker '$(CC)' \
- -ldflags '$(LDFLAGS)' -major $(MESA_MAJOR) \
- -minor $(MESA_MINOR) -patch $(GL_TINY) \
+ -ldflags '$(LDFLAGS)' -major 6 \
+ -minor 5 -patch 3 \
-install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
$(OSMESA_LIB_DEPS) $(OSMESA_DRIVER_OBJECTS) ; \
fi
--
1.5.3.4
diff -up mesa-20080612/src/mesa/drivers/osmesa/Makefile.osmesa mesa-20080612/src/mesa/drivers/osmesa/Makefile
--- mesa-20080612/src/mesa/drivers/osmesa/Makefile.osmesa 2008-06-12 12:17:27.000000000 +1000
+++ mesa-20080612/src/mesa/drivers/osmesa/Makefile 2008-06-12 13:14:24.000000000 +1000
@@ -47,7 +47,7 @@ osmesa8: $(TOP)/lib/$(OSMESA_LIB_NAME)
$(TOP)/lib/$(OSMESA_LIB_NAME): $(OBJECTS)
$(TOP)/bin/mklib -o $(OSMESA_LIB) \
-linker "$(CC)" \
- -major $(MESA_MAJOR) -minor $(MESA_MINOR) -patch $(MESA_TINY) \
+ -major 6 -minor 5 -patch 3 \
-install $(TOP)/$(LIB_DIR) \
$(MKLIB_OPTIONS) \
$(OSMESA_LIB_DEPS) $(OBJECTS)
@@ -60,7 +60,7 @@ $(TOP)/lib/$(OSMESA_LIB_NAME): $(OBJECTS
osmesa16: $(OBJECTS) $(CORE_MESA)
$(TOP)/bin/mklib -o $(OSMESA_LIB) \
-linker "$(CC)" \
- -major $(MESA_MAJOR) -minor $(MESA_MINOR) -patch $(MESA_TINY) \
+ -major 6 -minor 5 -patch 3 \
-install $(TOP)/$(LIB_DIR) \
$(MKLIB_OPTIONS) \
$(OSMESA_LIB_DEPS) $(OBJECTS) $(CORE_MESA)

View File

@ -1,25 +0,0 @@
From 27e06a52342b94b4fb1d60a57c3bdaa2b30607cf Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@panoply-rh.(none)>
Date: Fri, 18 Apr 2008 15:37:54 +1000
Subject: [PATCH] i965: fixup depth buffer check
---
src/mesa/drivers/dri/i965/brw_misc_state.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/mesa/drivers/dri/i965/brw_misc_state.c b/src/mesa/drivers/dri/i965/brw_misc_state.c
index ec0bd6b..26ec797 100644
--- a/src/mesa/drivers/dri/i965/brw_misc_state.c
+++ b/src/mesa/drivers/dri/i965/brw_misc_state.c
@@ -183,7 +183,7 @@ static int prepare_depthbuffer(struct brw_context *brw)
{
struct intel_region *region = brw->state.depth_region;
- if (region->buffer)
+ if (!region || !region->buffer)
return 0;
return dri_bufmgr_check_aperture_space(region->buffer);
}
--
1.5.4.5

View File

@ -10,12 +10,12 @@
%endif
%define manpages gl-manpages-1.0.1
%define gitdate 20080415
%define gitdate 20080627
Summary: Mesa graphics libraries
Name: mesa
Version: 7.1
Release: 0.28%{?dist}
Release: 0.37%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -29,24 +29,22 @@ Source3: make-git-snapshot.sh
Patch0: mesa-7.1pre-osmesa-version.patch
Patch2: mesa-7.1pre-nukeglthread-debug.patch
Patch3: mesa-7.1-fda4895d-update.patch
# This doesn't work, disable for now.
Patch4: disable-tex-offset.patch
Patch7: mesa-7.1-link-shared.patch
# lets only build drivers on sparc that are remotely useful
Patch8: mesa-7.1-sparc.patch
Patch9: mesa-fix-965-buffer-check.patch
Patch12: mesa-7.1-disable-intel-classic-warn.patch
BuildRequires: pkgconfig autoconf automake
%if %{with_dri}
BuildRequires: libdrm-devel >= 2.4.0-0.5
BuildRequires: libdrm-devel >= 2.4.0-0.12
%endif
BuildRequires: libXxf86vm-devel
BuildRequires: expat-devel >= 2.0
BuildRequires: xorg-x11-proto-devel >= 7.1-10
BuildRequires: dri2proto >= 1.1
BuildRequires: makedepend
BuildRequires: libselinux-devel
BuildRequires: libXext-devel
@ -69,11 +67,22 @@ Obsoletes: Mesa XFree86-libs XFree86-Mesa-libGL xorg-x11-Mesa-libGL
Obsoletes: xorg-x11-libs
%if %{with_dri}
Requires: libdrm >= 2.3.0
Requires: mesa-dri-drivers = %{version}-%{release}
Conflicts: xorg-x11-server-Xorg < 1.4.99.901-14
%endif
%description libGL
Mesa libGL runtime libraries and DRI drivers.
Mesa libGL runtime library.
%if %{with_dri}
%package dri-drivers
Summary: Mesa-based DRI drivers.
Group: User Interface/X Hardware Support
%description dri-drivers
Mesa-based DRI drivers.
%endif
%package libGL-devel
Summary: Mesa libGL development package
@ -133,15 +142,6 @@ Requires: mesa-libOSMesa = %{version}-%{release}
Mesa offscreen rendering development package
%package source
Summary: Mesa source code required to build X server
Group: Development/Libraries
%description source
The mesa-source package provides the minimal source code needed to
build DRI enabled X servers, etc.
%package -n glx-utils
Summary: GLX utilities
Group: Development/Libraries
@ -163,11 +163,9 @@ This package provides some demo applications for testing Mesa.
%setup -q -n mesa-%{gitdate} -b2
%patch0 -p1 -b .osmesa
%patch2 -p1 -b .intel-glthread
%patch3 -p1 -b .git-update-fix-intel
%patch4 -p1 -b .disable-tex-offset
%patch7 -p1 -b .dricore
%patch8 -p1
%patch9 -p1 -b .965-depth
%patch12 -p1 -b .intel-nowarn
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
# license and are not open source/free software, so we remove them.
@ -239,7 +237,7 @@ make install DESTDIR=$RPM_BUILD_ROOT DRI_DIRS=
%if %{with_dri}
install -d $RPM_BUILD_ROOT%{_libdir}/dri
install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri %{_lib}/libdricore.so >& /dev/null
for f in i810 i915 i965 mach64 mga r128 r200 r300 radeon savage sis tdfx unichrome; do
for f in i810 i915 i965 mach64 mga r128 r200 r300 radeon savage sis swrast tdfx unichrome; do
so=%{_lib}/${f}_dri.so
test -e $so && echo $so
done | xargs install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri >& /dev/null || :
@ -270,18 +268,6 @@ pushd ../%{manpages}
make %{?_smp_mflags} install DESTDIR=$RPM_BUILD_ROOT
popd
# Install the source needed to build the X server. The egreps are just
# stripping out unnecessary dirs; only tricky bit is the [^c] to make sure
# .../dri/common is included.
%define mesasourcedir %{_datadir}/mesa/source
mkdir -p $RPM_BUILD_ROOT/%{mesasourcedir}
( find src -name \*.[ch] ; find include -name \*.h ) |
egrep -v '^src/(glu|glw)' |
egrep -v '^src/mesa/drivers/(directfb|dos|fbdev|glide|ggi|osmesa)' |
egrep -v '^src/mesa/drivers/(windows|dri/[^c])' |
xargs tar cf - --mode a=r |
(cd $RPM_BUILD_ROOT/%{mesasourcedir} && tar xf -)
%clean
rm -rf $RPM_BUILD_ROOT
@ -298,7 +284,9 @@ rm -rf $RPM_BUILD_ROOT
%defattr(-,root,root,-)
%{_libdir}/libGL.so.1
%{_libdir}/libGL.so.1.2
%if %{with_dri}
%files dri-drivers
%dir %{_libdir}/dri
%{_libdir}/dri/libdricore.so
%{_libdir}/dri/*_dri.so
@ -349,11 +337,6 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libOSMesa16.so
%{_libdir}/libOSMesa32.so
# We constructed this dir carefully, so just slurp in the whole thing.
%files source
%defattr(-,root,root,-)
%{mesasourcedir}
%files -n glx-utils
%defattr(-,root,root,-)
%{_bindir}/glxgears
@ -416,6 +399,41 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/mesa-demos-data
%changelog
* Fri Jun 27 2008 Adam Jackson <ajax@redhat.com> 7.1-0.37
- Drop mesa-source subpackage. Man that feels good.
* Fri Jun 27 2008 Adam Jackson <ajax@redhat.com> 7.1-0.36
- Today's snapshot.
- Package swrast_dri for the new X world order.
- Split DRI drivers to their own subpackage.
* Thu Jun 12 2008 Dave Airlie <airlied@redhat.com> 7.1-0.35
- Update mesa to latest git snapshot - drop patches merged upstream
* Wed Jun 04 2008 Adam Jackson <ajax@redhat.com> 7.1-0.34
- Link libdricore with gcc instead of ld, so we automagically pick up the
ld --build-id flags.
* Wed May 28 2008 Dave Airlie <airlied@redhat.com> 7.1-0.33
- Add initial r500 3D driver
* Tue May 13 2008 Adam Jackson <ajax@redhat.com> 7.1-0.32
- Update dri2proto requirement. (#446166)
* Sat May 10 2008 Dave Airlie <airlied@redhat.com> 7.1-0.31
- Bring in a bunch of fixes from upstream, missing rs690 pci id,
- DRI2 + modeset + 965 + compiz + alt-tab fixed.
* Wed May 07 2008 Dave Airlie <airlied@redhat.com> 7.1-0.30
- fix googleearth on Intel 965 (#443930)
- disable classic warning to avoid people reporting it.
* Mon May 05 2008 Dave Airlie <airlied@redhat.com> 7.1-0.29
- mesa-7.1-f9-intel-and-radeon-fixes.patch - Update mesa
package with cherrypicked fixes from master.
- Fixes numerous i965 3D issues
- Fixes compiz on rs48x and rs690 radeon chipsets
* Fri Apr 18 2008 Dave Airlie <airlied@redhat.com> 7.1-0.28
- okay fire me now - I swear it runs compiz really well...
- fix more bugs on 965

View File

@ -1,2 +1,2 @@
4c32a78a28832fa34e0a5a04c6b9057c mesa-20080415.tar.bz2
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
a5f03ee286c07885c49d5f3d9cc896b3 mesa-20080627.tar.bz2