Merge branch 'f19' into f18

This commit is contained in:
Dave Airlie 2013-09-02 16:39:05 +10:00
commit 807d4c2ef1
8 changed files with 30 additions and 1784 deletions

2
.gitignore vendored
View File

@ -53,3 +53,5 @@ mesa-20100720.tar.bz2
/mesa-20130514.tar.xz
/mesa-20130528.tar.xz
/mesa-20130610.tar.xz
/mesa-20130723.tar.xz
/mesa-20130902.tar.xz

View File

@ -1,92 +0,0 @@
From 3dacb7d40b3a15be1133deaac55b993e8b7809dc Mon Sep 17 00:00:00 2001
From: Kenneth Graunke <kenneth@whitecape.org>
Date: Tue, 11 Jun 2013 10:31:39 -0700
Subject: [PATCH] Revert "i965: Disable unused pipeline stages once at startup
on Gen7+."
This reverts commit 6c966ccf07bcaf64fba1a9b699440c30dc96e732.
Apparently causes GPU hangs.
Conflicts:
src/mesa/drivers/dri/i965/brw_state.h
src/mesa/drivers/dri/i965/brw_state_upload.c
---
src/mesa/drivers/dri/i965/brw_state.h | 4 +---
src/mesa/drivers/dri/i965/brw_state_upload.c | 2 +-
src/mesa/drivers/dri/i965/gen7_disable.c | 13 +++++++++++--
3 files changed, 13 insertions(+), 6 deletions(-)
diff --git a/src/mesa/drivers/dri/i965/brw_state.h b/src/mesa/drivers/dri/i965/brw_state.h
index f14c44c..8af933e 100644
--- a/src/mesa/drivers/dri/i965/brw_state.h
+++ b/src/mesa/drivers/dri/i965/brw_state.h
@@ -111,6 +111,7 @@ extern const struct brw_tracked_state gen7_cc_state_pointer;
extern const struct brw_tracked_state gen7_cc_viewport_state_pointer;
extern const struct brw_tracked_state gen7_clip_state;
extern const struct brw_tracked_state gen7_depth_stencil_state_pointer;
+extern const struct brw_tracked_state gen7_disable_stages;
extern const struct brw_tracked_state gen7_ps_state;
extern const struct brw_tracked_state gen7_samplers;
extern const struct brw_tracked_state gen7_sbe_state;
@@ -213,9 +214,6 @@ uint32_t
get_attr_override(const struct brw_vue_map *vue_map, int urb_entry_read_offset,
int fs_attr, bool two_side_color, uint32_t *max_source_attr);
-/* gen7_disable.c */
-void gen7_disable_unused_stages(struct brw_context *brw);
-
/* gen7_urb.c */
void gen7_allocate_push_constants(struct brw_context *brw);
diff --git a/src/mesa/drivers/dri/i965/brw_state_upload.c b/src/mesa/drivers/dri/i965/brw_state_upload.c
index a9e269e..00aea41 100644
--- a/src/mesa/drivers/dri/i965/brw_state_upload.c
+++ b/src/mesa/drivers/dri/i965/brw_state_upload.c
@@ -210,6 +210,7 @@ static const struct brw_tracked_state *gen7_atoms[] =
&gen7_samplers,
&gen6_multisample_state,
+ &gen7_disable_stages,
&gen7_vs_state,
&gen7_sol_state,
&gen7_clip_state,
@@ -253,7 +254,6 @@ brw_upload_initial_gpu_state(struct brw_context *brw)
if (intel->gen >= 7) {
gen7_allocate_push_constants(brw);
- gen7_disable_unused_stages(brw);
}
}
diff --git a/src/mesa/drivers/dri/i965/gen7_disable.c b/src/mesa/drivers/dri/i965/gen7_disable.c
index c152d0a..aaf88a8 100644
--- a/src/mesa/drivers/dri/i965/gen7_disable.c
+++ b/src/mesa/drivers/dri/i965/gen7_disable.c
@@ -26,8 +26,8 @@
#include "brw_defines.h"
#include "intel_batchbuffer.h"
-void
-gen7_disable_unused_stages(struct brw_context *brw)
+static void
+disable_stages(struct brw_context *brw)
{
struct intel_context *intel = &brw->intel;
@@ -123,3 +123,12 @@ gen7_disable_unused_stages(struct brw_context *brw)
OUT_BATCH(0);
ADVANCE_BATCH();
}
+
+const struct brw_tracked_state gen7_disable_stages = {
+ .dirty = {
+ .mesa = 0,
+ .brw = BRW_NEW_CONTEXT,
+ .cache = 0,
+ },
+ .emit = disable_stages,
+};
--
1.8.2.1

View File

@ -15,11 +15,11 @@ DIRNAME=mesa-$( date +%Y%m%d )
echo REF ${REF:+--reference $REF}
echo DIRNAME $DIRNAME
echo HEAD ${1:-HEAD}
echo HEAD ${1:-9.2}
rm -rf $DIRNAME
git clone --depth 1 ${REF:+--reference $REF} \
git clone --depth 1 ${REF:+--reference $REF} --branch 9.2 \
git://git.freedesktop.org/git/mesa/mesa $DIRNAME
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \

View File

@ -0,0 +1,12 @@
diff -up mesa-20130610/src/gallium/drivers/r600/evergreen_state.c.jx mesa-20130610/src/gallium/drivers/r600/evergreen_state.c
--- mesa-20130610/src/gallium/drivers/r600/evergreen_state.c.jx 2013-06-10 13:58:51.000000000 -0400
+++ mesa-20130610/src/gallium/drivers/r600/evergreen_state.c 2013-06-17 10:24:14.687160428 -0400
@@ -615,7 +615,7 @@ static uint32_t r600_translate_colorform
static uint32_t r600_colorformat_endian_swap(uint32_t colorformat)
{
- if (R600_BIG_ENDIAN) {
+ if (0 && R600_BIG_ENDIAN) {
switch(colorformat) {
/* 8-bit buffers. */

File diff suppressed because it is too large Load Diff

View File

@ -1,29 +0,0 @@
diff -up mesa-20130514/configure.ac.jx mesa-20130514/configure.ac
--- mesa-20130514/configure.ac.jx 2013-05-17 13:51:14.000000000 -0400
+++ mesa-20130514/configure.ac 2013-05-17 13:53:02.288582625 -0400
@@ -763,11 +763,6 @@ if test "x$enable_dri" = xyes; then
GALLIUM_STATE_TRACKERS_DIRS="dri $GALLIUM_STATE_TRACKERS_DIRS"
fi
-if test "x$enable_osmesa" = xyes; then
- GALLIUM_STATE_TRACKERS_DIRS="osmesa $GALLIUM_STATE_TRACKERS_DIRS"
- GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS osmesa"
-fi
-
AC_SUBST([MESA_LLVM])
# Check for libdrm
diff -up mesa-20130514/src/gallium/targets/Makefile.am.jx mesa-20130514/src/gallium/targets/Makefile.am
--- mesa-20130514/src/gallium/targets/Makefile.am.jx 2013-05-17 13:51:14.000000000 -0400
+++ mesa-20130514/src/gallium/targets/Makefile.am 2013-05-17 14:30:33.091558931 -0400
@@ -26,10 +26,6 @@ if HAVE_X11_DRIVER
SUBDIRS += libgl-xlib
endif
-if HAVE_OSMESA
-SUBDIRS += osmesa
-endif
-
if HAVE_GALLIUM_GBM
SUBDIRS += gbm
endif

View File

@ -48,13 +48,13 @@
%define _default_patch_fuzz 2
%define gitdate 20130610
%define gitdate 20130902
#% define snapshot
Summary: Mesa graphics libraries
Name: mesa
Version: 9.2
Release: 0.12.%{gitdate}%{?dist}
Release: 1.%{gitdate}%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -75,9 +75,7 @@ Patch9: mesa-8.0-llvmpipe-shmget.patch
Patch12: mesa-8.0.1-fix-16bpp.patch
Patch15: mesa-9.2-hardware-float.patch
Patch16: mesa-9.2-no-useless-vdpau.patch
Patch18: mesa-9.2-llvmpipe-on-big-endian.patch
Patch19: mesa-9.2-no-gallium-osmesa.patch
Patch20: 0001-Revert-i965-Disable-unused-pipeline-stages-once-at-s.patch
Patch20: mesa-9.2-evergreen-big-endian.patch
BuildRequires: pkgconfig autoconf automake libtool
%if %{with_hardware}
@ -302,9 +300,7 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
%patch15 -p1 -b .hwfloat
%patch16 -p1 -b .vdpau
%patch18 -p1 -b .be
%patch19 -p1 -b .osmesa
%patch20 -p1 -b .revert
%patch20 -p1 -b .egbe
%if 0%{with_private_llvm}
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
@ -606,6 +602,15 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Mon Sep 02 2013 Dave Airlie <airlied@redhat.com> 9.2-1.20130902
- 9.2 upstream release + fixes from git branch
* Tue Jul 23 2013 Adam Jackson <ajax@redhat.com> 9.2-0.14.20130723
- Today's git snap of 9.2 branch
* Sun Jul 14 2013 Kyle McMartin <kyle@redhat.com> 9.2-0.13.20130610
- Use LLVM::MCJIT on ARM and AArch64.
* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 9.2-0.12.20130610
- Re-enable hardware float support (#975204)

View File

@ -1 +1 @@
ebed369f4835292aa17eb05ad5b935f1 mesa-20130610.tar.xz
a87aedfb1bbd4522b576e99906131008 mesa-20130902.tar.xz