Merge branch 'master' into f27

This commit is contained in:
Igor Gnatenko 2018-01-01 22:29:30 +01:00
commit 7a95aff696
6 changed files with 23 additions and 2561 deletions

View File

@ -12,15 +12,15 @@ diff --git a/configure.ac b/configure.ac
index 5f75c60..d77f907 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2387,7 +2387,7 @@ if test "x$MESA_LLVM" != x0; then
@@ -2645,7 +2645,7 @@
dnl ourselves.
dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
if test "x$enable_llvm_shared_libs" = xyes; then
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
+ LLVM_SO_NAME=LLVM
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
+ LLVM_SO_NAME=LLVM
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
if test "x$llvm_have_one_so" = xyes; then
if test "x$llvm_have_one_so" = xyes; then
--
2.7.4

File diff suppressed because it is too large Load Diff

View File

@ -1,4 +1,4 @@
VERSION ?= 17.2.4
VERSION ?= 17.3.1
SANITIZE ?= 1
DIRNAME = mesa-${VERSION}
@ -20,4 +20,4 @@ ifdef SANITIZE
endif
archive: clone sanitize
tar cf ${DIRNAME}.tar.xz ${DIRNAME}
tar caf ${DIRNAME}.tar.xz ${DIRNAME}

View File

@ -54,12 +54,12 @@
%global sanitize 1
#global rctag rc6
#global rctag rc3
Name: mesa
Summary: Mesa graphics libraries
Version: 17.2.4
Release: 3%{?rctag:.%{rctag}}%{?dist}
Version: 17.3.1
Release: 1%{?rctag:.%{rctag}}%{?dist}
License: MIT
URL: http://www.mesa3d.org
@ -73,14 +73,10 @@ Source3: Makefile
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
Source4: Mesa-MLAA-License-Clarification-Email.txt
# https://cgit.freedesktop.org/~ajax/mesa/log/?h=mesa-17.2-s3tc
Patch0: 0001-mesa-Squash-merge-of-S3TC-support.patch
Patch1: 0001-llvm-SONAME-without-version.patch
Patch2: 0002-hardware-gloat.patch
Patch3: 0003-evergreen-big-endian.patch
Patch4: 0004-bigendian-assert.patch
Patch5: vc4-Don-t-advertise-tiled-dmabuf-modifiers-if-we-can-t-use-them.patch
# glvnd support patches
# non-upstreamed ones
@ -413,7 +409,7 @@ export LDFLAGS="-static-libstdc++"
--with-platforms=x11,drm,surfaceless%{?with_wayland:,wayland} \
--enable-shared-glapi \
--enable-gbm \
%{?with_omx:--enable-omx} \
%{?with_omx:--enable-omx-bellagio} \
%{?with_opencl:--enable-opencl --enable-opencl-icd} %{!?with_opencl:--disable-opencl} \
--enable-glx-tls \
--enable-texture-float=yes \
@ -696,12 +692,18 @@ popd
%endif
%changelog
* Wed Dec 13 2017 Tom Stellard <tstellar@redhat.com> - 17.2.4-3
- Rebuild for LLVM 5.0
* Mon Jan 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 17.3.1-1
- Update to 17.3.1
* Fri Nov 10 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 17.2.4-2
* Fri Nov 10 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 17.3.0-0.4.rc3
- Sanitize tarball
* Wed Nov 8 2017 Peter Robinson <pbrobinson@fedoraproject.org> 17.3.0-0.3.rc3
- Update to 17.3.0-rc3
* Tue Oct 31 2017 Peter Robinson <pbrobinson@fedoraproject.org> 17.3.0-0.1.rc2
- Update to 17.3.0-rc2
* Tue Oct 31 2017 Peter Robinson <pbrobinson@fedoraproject.org> 17.2.4-1
- Update to 17.2.4 GA

View File

@ -1 +1 @@
SHA512 (mesa-17.2.4.tar.xz) = 57310f9e6dc4dca582e00b74f3b886094560a590fdc21cf8fa810773bcfd0bddca574e46be8723cf69b201f73e66844691b72b4a05fdd9f46a355a92a165db70
SHA512 (mesa-17.3.1.tar.xz) = a1c702f4f6a567c548ab63937ef393fb2afde30a06cd7d193e7f0cc236576c1bd06c030e4449f11e1742fd6c0c4dd407aa4b89b41f618c931d698726f59b6e0e

View File

@ -1,48 +0,0 @@
diff --git a/src/gallium/drivers/vc4/vc4_screen.c b/src/gallium/drivers/vc4/vc4_screen.c
index 5743e13045..b39cc744e6 100644
--- a/src/gallium/drivers/vc4/vc4_screen.c
+++ b/src/gallium/drivers/vc4/vc4_screen.c
@@ -549,25 +549,30 @@ vc4_screen_query_dmabuf_modifiers(struct pipe_screen *pscreen,
unsigned int *external_only,
int *count)
{
+ int m, i;
+ uint64_t available_modifiers[] = {
+ DRM_FORMAT_MOD_BROADCOM_VC4_T_TILED,
+ DRM_FORMAT_MOD_LINEAR,
+ };
+ struct vc4_screen *screen = vc4_screen(pscreen);
+ int num_modifiers = screen->has_tiling_ioctl ? 2 : 1;
+
if (!modifiers) {
- *count = 2;
+ *count = num_modifiers;
return;
}
- *count = MIN2(max, 2);
-
+ *count = MIN2(max, num_modifiers);
+ m = screen->has_tiling_ioctl ? 0 : 1;
/* We support both modifiers (tiled and linear) for all sampler
- * formats.
+ * formats, but if we don't have the DRM_VC4_GET_TILING ioctl
+ * we shouldn't advertise the tiled formats.
*/
- modifiers[0] = DRM_FORMAT_MOD_BROADCOM_VC4_T_TILED;
- if (external_only)
- external_only[0] = false;
- if (max < 2)
- return;
-
- modifiers[1] = DRM_FORMAT_MOD_LINEAR;
- if (external_only)
- external_only[1] = false;
+ for (i = 0; i < *count; i++) {
+ modifiers[i] = available_modifiers[m++];
+ if (external_only)
+ external_only[i] = false;
+ }
}
#define PTR_TO_UINT(x) ((unsigned)((intptr_t)(x)))