- bump to snapshot of mesa master

- mainly has intel dri2 tfp fixes + radeon rewrite patch
This commit is contained in:
Dave Airlie 2009-03-22 02:39:21 +00:00
parent 490adcb608
commit 6db4be10c0
7 changed files with 26 additions and 2556 deletions

View File

@ -2,3 +2,4 @@ gl-manpages-1.0.1.tar.bz2
xdriinfo-1.0.2.tar.bz2 xdriinfo-1.0.2.tar.bz2
MesaDemos-7.3.tar.bz2 MesaDemos-7.3.tar.bz2
MesaLib-7.3.tar.bz2 MesaLib-7.3.tar.bz2
mesa-20090322.tar.bz2

View File

@ -5,8 +5,8 @@ diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.dricore mesa-20080814/src/m
-default: $(TOP)/$(LIB_DIR) subdirs -default: $(TOP)/$(LIB_DIR) subdirs dri.pc
+default: $(TOP)/$(LIB_DIR) $(TOP)/$(LIB_DIR)/libdricore.so subdirs +default: $(TOP)/$(LIB_DIR) $(TOP)/$(LIB_DIR)/libdricore.so subdirs dri.pc
$(TOP)/$(LIB_DIR): $(TOP)/$(LIB_DIR):
@ -58,8 +58,8 @@ diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template $(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
$(MKLIB) -o $@ -noprefix -linker '$(CC)' -ldflags '$(LDFLAGS)' \ $(MKLIB) -o $@ -noprefix -linker '$(CC)' -ldflags '$(LDFLAGS)' \
- $(OBJECTS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS) - $(OBJECTS) $(PIPE_DRIVERS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
+ $(OBJECTS) $(WINOBJ) \ + $(OBJECTS) $(PIPE_DRIVERS) $(WINOBJ) \
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \ + -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \
+ $(DRI_LIB_DEPS) + $(DRI_LIB_DEPS)

View File

@ -13,12 +13,3 @@ diff -up Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c.intel-glthread Mesa-7.1
/* point the renderbufer's region to the texture image region */ /* point the renderbufer's region to the texture image region */
intel_image = intel_texture_image(newImage); intel_image = intel_texture_image(newImage);
if (irb->region != intel_image->mt->region) { if (irb->region != intel_image->mt->region) {
@@ -674,8 +669,6 @@ intel_finish_render_texture(GLcontext *
{
struct intel_renderbuffer *irb = intel_renderbuffer(att->Renderbuffer);
- DBG("End render texture (tid %x) tex %u\n", _glthread_GetID(), att->Texture->Name);
-
if (irb) {
/* just release the region */
intel_region_release(&irb->region);

File diff suppressed because it is too large Load Diff

View File

@ -14,41 +14,38 @@
%define manpages gl-manpages-1.0.1 %define manpages gl-manpages-1.0.1
%define xdriinfo xdriinfo-1.0.2 %define xdriinfo xdriinfo-1.0.2
%define gitdate 20081220 %define gitdate 20090322
#% define snapshot #% define snapshot
Summary: Mesa graphics libraries Summary: Mesa graphics libraries
Name: mesa Name: mesa
Version: 7.3 Version: 7.5
Release: 13%{?dist} Release: 0.1%{?dist}
License: MIT License: MIT
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.mesa3d.org URL: http://www.mesa3d.org
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://downloads.sf.net/mesa3d/MesaLib-%{version}.tar.bz2 #Source0: http://downloads.sf.net/mesa3d/MesaLib-%{version}.tar.bz2
Source1: http://downloads.sf.net/mesa3d/MesaDemos-%{version}.tar.bz2
#Source0: http://www.mesa3d.org/beta/MesaLib-%{version}%{?snapshot}.tar.bz2 #Source0: http://www.mesa3d.org/beta/MesaLib-%{version}%{?snapshot}.tar.bz2
#Source1: http://www.mesa3d.org/beta/MesaDemos-%{version}%{?snapshot}.tar.bz2 #Source1: http://www.mesa3d.org/beta/MesaDemos-%{version}%{?snapshot}.tar.bz2
#Source0: %{name}-%{gitdate}.tar.bz2 Source0: %{name}-%{gitdate}.tar.bz2
#Source1: http://downloads.sf.net/mesa3d/MesaDemos-%{version}.tar.bz2
Source2: %{manpages}.tar.bz2 Source2: %{manpages}.tar.bz2
Source3: make-git-snapshot.sh Source3: make-git-snapshot.sh
Source5: http://www.x.org/pub/individual/app/%{xdriinfo}.tar.bz2 Source5: http://www.x.org/pub/individual/app/%{xdriinfo}.tar.bz2
Patch0: mesa-7.3-fixes-from-7.4-branch.patch
Patch1: mesa-7.1-osmesa-version.patch Patch1: mesa-7.1-osmesa-version.patch
Patch2: mesa-7.1-nukeglthread-debug.patch Patch2: mesa-7.1-nukeglthread-debug.patch
Patch3: mesa-no-mach64.patch Patch3: mesa-no-mach64.patch
Patch5: mesa-7.3-dri-configs-fixes.patch
Patch6: radeon-rewrite.patch Patch6: radeon-rewrite.patch
Patch7: mesa-7.1-link-shared.patch Patch7: mesa-7.1-link-shared.patch
Patch9: intel-revert-vbl.patch Patch9: intel-revert-vbl.patch
Patch12: mesa-7.1-disable-intel-classic-warn.patch Patch12: mesa-7.1-disable-intel-classic-warn.patch
Patch13: mesa-7.3-965-texture-size.patch
BuildRequires: pkgconfig autoconf automake BuildRequires: pkgconfig autoconf automake
%if %{with_dri} %if %{with_dri}
@ -167,18 +164,15 @@ This package provides some demo applications for testing Mesa.
%prep %prep
%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b1 -b2 -b5 #%setup -q -n mesa-%{version}%{?snapshot} -b0 -b2 -b5
#%setup -q -n mesa-%{gitdate} -b2 -b5 %setup -q -n mesa-%{gitdate} -b2 -b5
%patch0 -p1 -b .mesa74
%patch1 -p1 -b .osmesa %patch1 -p1 -b .osmesa
%patch2 -p1 -b .intel-glthread %patch2 -p1 -b .intel-glthread
%patch3 -p0 -b .no-mach64 %patch3 -p0 -b .no-mach64
%patch5 -p1 -b .driconfigs
%patch6 -p1 -b .radeon-rewrite %patch6 -p1 -b .radeon-rewrite
%patch7 -p1 -b .dricore %patch7 -p1 -b .dricore
%patch9 -p1 -b .intel-vbl %patch9 -p1 -b .intel-vbl
%patch12 -p1 -b .intel-nowarn %patch12 -p1 -b .intel-nowarn
%patch13 -p1 -b .965-texture
# Hack the demos to use installed data files # Hack the demos to use installed data files
sed -i 's,../images,%{_libdir}/mesa-demos-data,' progs/demos/*.c sed -i 's,../images,%{_libdir}/mesa-demos-data,' progs/demos/*.c
@ -225,6 +219,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS -Os"
%configure %{common_flags} \ %configure %{common_flags} \
--disable-glw \ --disable-glw \
--disable-glut \ --disable-glut \
--disable-gallium \
--disable-gl-osmesa \ --disable-gl-osmesa \
--with-driver=%{driver} \ --with-driver=%{driver} \
--with-dri-driverdir=%{_libdir}/dri --with-dri-driverdir=%{_libdir}/dri
@ -262,7 +257,11 @@ done | xargs install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri >& /dev/null || :
# strip out undesirable headers # strip out undesirable headers
pushd $RPM_BUILD_ROOT%{_includedir}/GL pushd $RPM_BUILD_ROOT%{_includedir}/GL
rm [a-fh-np-wyz]*.h gg*.h glf*.h rm [a-fh-np-wyz]*.h gg*.h glf*.h glew.h glut*.h glxew.h
popd
pushd $RPM_BUILD_ROOT%{_libdir}
rm libEGL* demodriver.so
popd popd
# XXX demos, since they don't install automatically. should fix that. # XXX demos, since they don't install automatically. should fix that.
@ -419,6 +418,7 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/texdown %{_bindir}/texdown
%{_bindir}/texenv %{_bindir}/texenv
%{_bindir}/texobj %{_bindir}/texobj
%{_bindir}/textures
%{_bindir}/trispd %{_bindir}/trispd
%{_bindir}/tunnel %{_bindir}/tunnel
%{_bindir}/tunnel2 %{_bindir}/tunnel2
@ -427,6 +427,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/mesa-demos-data %{_libdir}/mesa-demos-data
%changelog %changelog
* Fri Mar 20 2009 Dave Airlie <airlied@redhat.com> 7.5-0.1
- bump to snapshot of mesa master
- mainly has intel dri2 tfp fixes + radeon rewrite patch
* Thu Mar 19 2009 Orion Poplawski <orion@cora.nwra.com> 7.3-13 * Thu Mar 19 2009 Orion Poplawski <orion@cora.nwra.com> 7.3-13
- Update libdrm requirement to >= 2.4.3 to match source - Update libdrm requirement to >= 2.4.3 to match source

View File

@ -33405,7 +33405,7 @@ index 8000880..8d8afb4 100644
GLuint pitch); GLuint pitch);
+extern void radeonSetTexBuffer(__DRIcontext *pDRICtx, GLint target, __DRIdrawable *dPriv); +extern void radeonSetTexBuffer(__DRIcontext *pDRICtx, GLint target, __DRIdrawable *dPriv);
+externvoid radeonSetTexBuffer2(__DRIcontext *pDRICtx, GLint target, GLint glx_texture_format, +extern void radeonSetTexBuffer2(__DRIcontext *pDRICtx, GLint target, GLint glx_texture_format,
+ __DRIdrawable *dPriv); + __DRIdrawable *dPriv);
+ +
extern void radeonUpdateTextureState( GLcontext *ctx ); extern void radeonUpdateTextureState( GLcontext *ctx );

View File

@ -1,4 +1,3 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2 6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
a5ec51ed9f0a55dc3462d90d52ff899c xdriinfo-1.0.2.tar.bz2 a5ec51ed9f0a55dc3462d90d52ff899c xdriinfo-1.0.2.tar.bz2
3f0741394069bdf2329565a387396cda MesaDemos-7.3.tar.bz2 2469ad7640d26d1aed61452cfe62fd49 mesa-20090322.tar.bz2
781e7811a6ed5c97b2b8defefc8ffbc9 MesaLib-7.3.tar.bz2