- mesa fix link shared to actually link

This commit is contained in:
Dave Airlie 2009-12-21 02:48:56 +00:00
parent 03b877db6d
commit 62ff43097f
1 changed files with 2 additions and 1 deletions

View File

@ -54,12 +54,13 @@ diff -up mesa-20091221/src/mesa/drivers/dri/Makefile.template.da mesa-20091221/s
COMMON_GALLIUM_SOURCES = \
../common/utils.c \
@@ -70,7 +70,7 @@ lib: symlinks subdirs depend
@@ -70,7 +70,8 @@ lib: symlinks subdirs depend
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(EXTRA_MODULES) $(WINOBJ) Makefile \
$(TOP)/src/mesa/drivers/dri/Makefile.template
$(MKLIB) -o $@ -noprefix -linker '$(CC)' -ldflags '$(LDFLAGS)' \
- $(OBJECTS) $(MESA_MODULES) $(EXTRA_MODULES) $(WINOBJ) \
+ $(OBJECTS) $(EXTRA_MODULES) $(WINOBJ) \
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore
$(DRI_LIB_DEPS)