- rebase to latest upstream snapshot

This commit is contained in:
Dave Airlie 2009-07-23 02:17:11 +00:00
parent ff9b12ce4b
commit 626ed0a9ec
8 changed files with 20 additions and 40283 deletions

View File

@ -3,3 +3,4 @@ xdriinfo-1.0.2.tar.bz2
MesaDemos-7.3.tar.bz2
MesaLib-7.3.tar.bz2
mesa-20090322.tar.bz2
mesa-20090723.tar.bz2

View File

@ -10,12 +10,3 @@ diff -up Mesa-7.1/src/mesa/drivers/osmesa/Makefile.jx Mesa-7.1/src/mesa/drivers/
-install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
-id $(INSTALL_LIB_DIR)/lib$(OSMESA_LIB).$(MESA_MAJOR).dylib \
$(OSMESA_LIB_DEPS) $(OBJECTS)
@@ -58,7 +58,7 @@ $(TOP)/lib/$(OSMESA_LIB_NAME): $(OBJECTS
# with all the other Mesa sources (compiled with -DCHAN_BITS=16/32
osmesa16: $(OBJECTS) $(CORE_MESA)
$(MKLIB) -o $(OSMESA_LIB) -linker '$(CC)' -ldflags '$(LDFLAGS)' \
- -major $(MESA_MAJOR) -minor $(MESA_MINOR) -patch $(MESA_TINY) \
+ -major 6 -minor 5 -patch 3 \
-install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
-id $(INSTALL_LIB_DIR)/lib$(OSMESA_LIB).$(MESA_MAJOR).dylib \
$(OSMESA_LIB_DEPS) $(OBJECTS) $(CORE_MESA)

View File

@ -1,12 +0,0 @@
diff -up mesa-20090428/src/mesa/drivers/dri/r300/r300_cmdbuf.c.jx mesa-20090428/src/mesa/drivers/dri/r300/r300_cmdbuf.c
--- mesa-20090428/src/mesa/drivers/dri/r300/r300_cmdbuf.c.jx 2009-05-18 11:17:36.000000000 -0400
+++ mesa-20090428/src/mesa/drivers/dri/r300/r300_cmdbuf.c 2009-05-21 16:32:32.000000000 -0400
@@ -251,7 +251,7 @@ static void emit_cb_offset(GLcontext *ct
OUT_BATCH(((rrb->width - 1) << R300_SCISSORS_X_SHIFT) |
((rrb->height - 1) << R300_SCISSORS_Y_SHIFT));
END_BATCH();
- BEGIN_BATCH_NO_AUTOSTATE(16);
+ BEGIN_BATCH_NO_AUTOSTATE(7);
for (i = 0; i < 1; i++) {
OUT_BATCH_REGSEQ(R300_SC_CLIPRECT_TL_0 + (i * 8), 2);
OUT_BATCH((0 << R300_CLIPRECT_X_SHIFT) | (0 << R300_CLIPRECT_Y_SHIFT));

View File

@ -1,45 +1,46 @@
--- configure.ac.mach64 2008-09-05 13:53:24.000000000 +1000
+++ configure.ac 2008-09-05 13:53:39.000000000 +1000
@@ -656,7 +656,7 @@
diff -up mesa-20090723/configure.ac.mach64 mesa-20090723/configure.ac
--- mesa-20090723/configure.ac.mach64 2009-07-23 12:11:01.000000000 +1000
+++ mesa-20090723/configure.ac 2009-07-23 12:11:22.000000000 +1000
@@ -713,7 +713,7 @@ if test "$mesa_driver" = dri; then
# because there is no x86-64 system where they could *ever*
# be used.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 radeon \
+ DRI_DIRS="i915 i965 mga r128 r200 r300 radeon \
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
savage tdfx unichrome swrast"
fi
;;
@@ -664,13 +664,13 @@
@@ -721,13 +721,13 @@ if test "$mesa_driver" = dri; then
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="mach64 r128 r200 r300 radeon tdfx swrast"
+ DRI_DIRS="r128 r200 r300 radeon tdfx swrast"
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon tdfx swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast"
fi
;;
sparc*)
# Build only the drivers for cards that exist on sparc`
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="mach64 r128 r200 r300 radeon ffb swrast"
+ DRI_DIRS="r128 r200 r300 radeon ffb swrast"
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon ffb swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon ffb swrast"
fi
;;
esac
@@ -689,7 +689,7 @@
@@ -746,7 +746,7 @@ if test "$mesa_driver" = dri; then
# ffb and gamma are missing because they have not been converted
# to use the new interface.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon tdfx \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 radeon tdfx \
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
unichrome savage sis swrast"
fi
;;
@@ -704,7 +704,7 @@
@@ -765,7 +765,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 radeon s3v \
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon s3v \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon s3v \
savage sis tdfx trident unichrome ffb swrast"
fi

View File

@ -21,7 +21,7 @@
Summary: Mesa graphics libraries
Name: mesa
Version: 7.6
Release: 0.3%{?dist}
Release: 0.4%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org

View File

@ -1,13 +0,0 @@
diff --git a/src/mesa/drivers/dri/r300/r300_cmdbuf.c b/src/mesa/drivers/dri/r300/r300_cmdbuf.c
index afca0e2..a006e8f 100644
--- a/src/mesa/drivers/dri/r300/r300_cmdbuf.c
+++ b/src/mesa/drivers/dri/r300/r300_cmdbuf.c
@@ -252,7 +252,7 @@ static void emit_cb_offset(GLcontext *ctx, struct radeon_state_atom * atom)
((rrb->height - 1) << R300_SCISSORS_Y_SHIFT));
END_BATCH();
BEGIN_BATCH_NO_AUTOSTATE(16);
- for (i = 0; i < 4; i++) {
+ for (i = 0; i < 1; i++) {
OUT_BATCH_REGSEQ(R300_SC_CLIPRECT_TL_0 + (i * 8), 2);
OUT_BATCH((0 << R300_CLIPRECT_X_SHIFT) | (0 << R300_CLIPRECT_Y_SHIFT));
OUT_BATCH(((rrb->width - 1) << R300_CLIPRECT_X_SHIFT) | ((rrb->height - 1) << R300_CLIPRECT_Y_SHIFT));

File diff suppressed because it is too large Load Diff

View File

@ -1,3 +1,3 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
a5ec51ed9f0a55dc3462d90d52ff899c xdriinfo-1.0.2.tar.bz2
93b7016851831fc31d02103e7d9551b3 mesa-20090612.tar.bz2
b3547e33cef106021dac5f5ff44e6bc6 mesa-20090723.tar.bz2