Update to 18.0.0~rc3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2018-02-09 08:17:35 +01:00
parent 9e1266e707
commit 5bcb836bb5
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
4 changed files with 10 additions and 59 deletions

View File

@ -1,51 +0,0 @@
From 23ce168048698eeea3df6bb8c9de5be3ca4784cd Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenko@redhat.com>
Date: Mon, 1 Jan 2018 22:49:00 +0100
Subject: [PATCH 001/607] link mesautil with pthreads
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `u_thread_setname':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../src/util/u_thread.h:66: undefined reference to `pthread_setname_np'
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `thrd_join':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../include/c11/threads_posix.h:336: undefined reference to `pthread_join'
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `u_thread_create':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../src/util/u_thread.h:48: undefined reference to `pthread_sigmask'
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `thrd_create':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../include/c11/threads_posix.h:296: undefined reference to `pthread_create'
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `u_thread_create':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../src/util/u_thread.h:50: undefined reference to `pthread_sigmask'
/builddir/build/BUILD/mesa-17.3.1/src/util/../../src/util/u_thread.h:50: undefined reference to `pthread_sigmask'
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `call_once':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../include/c11/threads_posix.h:96: undefined reference to `pthread_once'
../../src/util/.libs/libmesautil.a(libmesautil_la-u_queue.o): In function `u_thread_get_time_nano':
/builddir/build/BUILD/mesa-17.3.1/src/util/../../src/util/u_thread.h:84: undefined reference to `pthread_getcpuclockid'
collect2: error: ld returned 1 exit status
Reviewed-by: Adam Jackson <ajax@redhat.com>
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
---
src/util/Makefile.am | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index a5241ad27b..633907b9fd 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -31,6 +31,7 @@ noinst_LTLIBRARIES = \
libxmlconfig.la
AM_CPPFLAGS = \
+ $(PTHREAD_CFLAGS) \
-I$(top_srcdir)/include
libmesautil_la_CPPFLAGS = \
@@ -50,6 +51,7 @@ libmesautil_la_SOURCES = \
$(MESA_UTIL_GENERATED_FILES)
libmesautil_la_LIBADD = \
+ $(PTHREAD_LIBS) \
$(CLOCK_LIB) \
$(ZLIB_LIBS) \
$(LIBATOMIC_LIBS)
--
2.14.3

View File

@ -1,4 +1,4 @@
VERSION ?= 17.3.3
VERSION ?= 18.0.0-rc3
SANITIZE ?= 1
DIRNAME = mesa-${VERSION}

View File

@ -54,12 +54,12 @@
%global sanitize 1
#global rctag rc3
%global rctag rc3
Name: mesa
Summary: Mesa graphics libraries
Version: 17.3.3
Release: 1%{?rctag:.%{rctag}}%{?dist}.1
Version: 18.0.0
Release: 0.1%{?rctag:.%{rctag}}%{?dist}
License: MIT
URL: http://www.mesa3d.org
@ -82,7 +82,6 @@ Patch4: 0004-bigendian-assert.patch
# non-upstreamed ones
Patch10: glvnd-fix-gl-dot-pc.patch
Patch11: 0001-Fix-linkage-against-shared-glapi.patch
Patch12: 0001-link-mesautil-with-pthreads.patch
# backport from upstream
@ -108,7 +107,7 @@ BuildRequires: libXi-devel
BuildRequires: libXmu-devel
BuildRequires: libxshmfence-devel
BuildRequires: elfutils
BuildRequires: python
BuildRequires: python2
BuildRequires: gettext
%if 0%{?with_llvm}
BuildRequires: llvm-devel >= 3.4-7
@ -117,7 +116,7 @@ BuildRequires: clang-devel >= 3.0
%endif
%endif
BuildRequires: elfutils-libelf-devel
BuildRequires: libxml2-python
BuildRequires: python2-libxml2
BuildRequires: libudev-devel
BuildRequires: bison flex
%if %{with wayland}
@ -693,6 +692,9 @@ popd
%endif
%changelog
* Thu Feb 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 18.0.0-0.1.rc3
- Update to 18.0.0~rc3
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 17.3.3-1.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (mesa-17.3.3.tar.xz) = fc555e93e6bdeaf3b710d166acdff8b2c565e88a2a1ca4514b1903f6d14c42c19024e14a7e982df069d4f551b87e231155a34064f2c308c276256f9a308718db
SHA512 (mesa-18.0.0-rc3.tar.xz) = 17fa6d403bf31836e172942c012c2573a70bbcc6c0f9a3daf7a5fa1b9fa0cd41925d423bfc5c311ea03b6abc5189bcd09189bddb90691b0bb1b2d29af940168f