fix the gallium p_config header for non-x86 arches (Dave Airlie)
This commit is contained in:
parent
aa62ccdcd5
commit
3faf4cdb31
28
mesa-20110525-gallium-config.patch
Normal file
28
mesa-20110525-gallium-config.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From: Dave Airlie <airlied at redhat.com>
|
||||
|
||||
We are getting inconsistent methods for endian detection (same answer when
|
||||
it works, just doesn't work on some platforms) depending on whether __GLIBC__
|
||||
is defined, which of course depends on include ordering before p_config.h
|
||||
|
||||
Just make p_config.h include limits.h to solve this.
|
||||
|
||||
Signed-off-by: Dave Airlie <airlied at redhat.com>
|
||||
---
|
||||
src/gallium/include/pipe/p_config.h | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/include/pipe/p_config.h b/src/gallium/include/pipe/p_config.h
|
||||
index 1818c8b..40f6f2b 100644
|
||||
--- a/src/gallium/include/pipe/p_config.h
|
||||
+++ b/src/gallium/include/pipe/p_config.h
|
||||
@@ -46,7 +46,7 @@
|
||||
#ifndef P_CONFIG_H_
|
||||
#define P_CONFIG_H_
|
||||
|
||||
-
|
||||
+#include <limits.h>
|
||||
/*
|
||||
* Compiler
|
||||
*/
|
||||
--
|
||||
1.7.4.4
|
10
mesa.spec
10
mesa.spec
@ -18,7 +18,7 @@
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 7.11
|
||||
Release: 0.11.%{gitdate}.0%{?dist}
|
||||
Release: 0.12.%{gitdate}.0%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
@ -41,6 +41,9 @@ Patch8: mesa-7.10-llvmcore.patch
|
||||
Patch30: mesa-7.6-hush-vblank-warning.patch
|
||||
Patch31: mesa-7.10-swrastg.patch
|
||||
|
||||
# build fix
|
||||
Patch40: mesa-20110525-gallium-config.patch
|
||||
|
||||
BuildRequires: pkgconfig autoconf automake libtool
|
||||
%if %{with_hardware}
|
||||
BuildRequires: kernel-headers >= 2.6.27-0.305.rc5.git6
|
||||
@ -225,6 +228,8 @@ Requires: Xorg %(xserver-sdk-abi-requires ansic) %(xserver-sdk-abi-requires vide
|
||||
%patch8 -p1 -b .llvmcore
|
||||
%endif
|
||||
|
||||
%patch40 -p1 -b .header-order
|
||||
|
||||
%build
|
||||
|
||||
autoreconf --install
|
||||
@ -488,6 +493,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/libOSMesa.so
|
||||
|
||||
%changelog
|
||||
* Mon May 30 2011 Dan Horák <dan[at]danny.cz> 7.11-0.12.20110525.0
|
||||
- fix the gallium p_config header for non-x86 arches (Dave Airlie)
|
||||
|
||||
* Wed May 25 2011 Dave Airlie <airlied@redhat.com> 7.11-0.11.20110525.0
|
||||
- rebase to latest upstream for llvm fix + r600g cayman/eg support
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user