- rebase for latest 7.8 upstream release

This commit is contained in:
Dave Airlie 2010-03-24 22:58:05 +00:00
parent 203ec05135
commit 3f69ad74d5
6 changed files with 36 additions and 32 deletions

View File

@ -1,3 +1,4 @@
gl-manpages-1.0.1.tar.bz2
xdriinfo-1.0.3.tar.bz2
mesa-20100217.tar.bz2
mesa-7.8-20100325.tar.bz2

View File

@ -1,15 +1,15 @@
diff -up Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c.intel-glthread Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c
--- Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c.intel-glthread 2008-08-25 10:49:40.000000000 -0400
+++ Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c 2008-08-28 14:26:17.000000000 -0400
@@ -633,11 +633,6 @@ intel_render_texture(GLcontext * ctx,
diff -up mesa-20100325/src/mesa/drivers/dri/intel/intel_fbo.c.da mesa-20100325/src/mesa/drivers/dri/intel/intel_fbo.c
--- mesa-20100325/src/mesa/drivers/dri/intel/intel_fbo.c.da 2010-03-25 08:42:47.000000000 +1000
+++ mesa-20100325/src/mesa/drivers/dri/intel/intel_fbo.c 2010-03-25 08:42:52.000000000 +1000
@@ -554,11 +554,6 @@ intel_render_texture(GLcontext * ctx,
return;
}
- DBG("Begin render texture tid %x tex=%u w=%d h=%d refcount=%d\n",
- DBG("Begin render texture tid %lx tex=%u w=%d h=%d refcount=%d\n",
- _glthread_GetID(),
- att->Texture->Name, newImage->Width, newImage->Height,
- irb->Base.RefCount);
-
/* point the renderbufer's region to the texture image region */
intel_image = intel_texture_image(newImage);
if (irb->region != intel_image->mt->region) {
if (irb->region)

View File

@ -1,16 +1,16 @@
diff -up mesa-20091221/configure.ac.da mesa-20091221/configure.ac
--- mesa-20091221/configure.ac.da 2009-12-21 08:09:11.000000000 +1000
+++ mesa-20091221/configure.ac 2009-12-21 08:41:04.000000000 +1000
@@ -723,7 +723,7 @@ if test "$mesa_driver" = dri; then
# because there is no x86-64 system where they could *ever*
# be used.
diff -up mesa-20100325/configure.ac.no-mach64 mesa-20100325/configure.ac
--- mesa-20100325/configure.ac.no-mach64 2010-03-25 05:08:17.000000000 +1000
+++ mesa-20100325/configure.ac 2010-03-25 08:46:04.000000000 +1000
@@ -748,7 +748,7 @@ if test "$mesa_driver" = dri; then
# the new interface. i810 are missing because there is no
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
savage tdfx unichrome swrast"
fi
;;
@@ -731,13 +731,13 @@ if test "$mesa_driver" = dri; then
@@ -756,13 +756,13 @@ if test "$mesa_driver" = dri; then
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
@ -21,26 +21,26 @@ diff -up mesa-20091221/configure.ac.da mesa-20091221/configure.ac
sparc*)
# Build only the drivers for cards that exist on sparc`
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon ffb swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon ffb swrast"
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon swrast"
fi
;;
esac
@@ -756,7 +756,7 @@ if test "$mesa_driver" = dri; then
# ffb and gamma are missing because they have not been converted
# to use the new interface.
@@ -779,7 +779,7 @@ if test "$mesa_driver" = dri; then
fi
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
unichrome savage sis swrast"
fi
;;
@@ -775,7 +775,7 @@ if test "$mesa_driver" = dri; then
@@ -798,7 +798,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
savage sis tdfx unichrome ffb swrast"
savage sis tdfx unichrome swrast"
fi

View File

@ -13,7 +13,7 @@
%define manpages gl-manpages-1.0.1
%define xdriinfo xdriinfo-1.0.3
%define gitdate 20100217
%define gitdate 20100325
#% define snapshot
%define demodir %{_libdir}/mesa
@ -21,7 +21,7 @@
Summary: Mesa graphics libraries
Name: mesa
Version: 7.8
Release: 0.18%{?dist}
Release: 0.19%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -30,7 +30,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
#Source0: http://downloads.sf.net/mesa3d/MesaLib-%{version}.tar.bz2
#Source0: http://www.mesa3d.org/beta/MesaLib-%{version}%{?snapshot}.tar.bz2
#Source1: http://www.mesa3d.org/beta/MesaDemos-%{version}%{?snapshot}.tar.bz2
Source0: %{name}-%{gitdate}.tar.bz2
Source0: %{name}-7.8-%{gitdate}.tar.bz2
#Source1: http://downloads.sf.net/mesa3d/MesaDemos-%{version}.tar.bz2
Source2: %{manpages}.tar.bz2
Source3: make-git-snapshot.sh
@ -406,6 +406,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
%changelog
* Thu Mar 25 2010 Dave Airlie <airlied@redhat.com> 7.8-0.19
- rebase for latest 7.8 upstream release
* Wed Feb 17 2010 Adam Jackson <ajax@redhat.com> 7.8-0.18
- Enable legacy nouveau build on ppc too, on the off chance that it works
(#564346)

View File

@ -1,8 +1,8 @@
diff -up mesa-20100217/configure.ac.nouveau-legacy mesa-20100217/configure.ac
--- mesa-20100217/configure.ac.nouveau-legacy 2010-02-17 12:50:36.000000000 -0500
+++ mesa-20100217/configure.ac 2010-02-17 12:51:34.000000000 -0500
@@ -723,14 +723,14 @@ if test "$mesa_driver" = dri; then
# be used.
diff -up mesa-20100325/configure.ac.nouveau-legacy mesa-20100325/configure.ac
--- mesa-20100325/configure.ac.nouveau-legacy 2010-03-25 08:46:42.000000000 +1000
+++ mesa-20100325/configure.ac 2010-03-25 08:51:14.000000000 +1000
@@ -749,14 +749,14 @@ if test "$mesa_driver" = dri; then
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
- savage tdfx unichrome swrast"
@ -18,12 +18,12 @@ diff -up mesa-20100217/configure.ac.nouveau-legacy mesa-20100217/configure.ac
fi
;;
sparc*)
@@ -775,7 +775,7 @@ if test "$mesa_driver" = dri; then
@@ -799,7 +799,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
- savage sis tdfx unichrome ffb swrast"
+ savage sis tdfx unichrome ffb swrast nouveau"
- savage sis tdfx unichrome swrast"
+ savage sis tdfx unichrome swrast nouveau"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`

View File

@ -1,3 +1,3 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
cb304d1ce562ac48b68eedeba38c662f xdriinfo-1.0.3.tar.bz2
8141575e2adcf4f752fb4db94095ae2d mesa-20100217.tar.bz2
89b54f78c6aa65a491031e013d65e252 mesa-7.8-20100325.tar.bz2