- Update mesa to latest git snapshot - drop patches merged upstream
This commit is contained in:
parent
f8d0402a0c
commit
3f2f8cafa8
@ -1 +1,2 @@
|
||||
mesa-20080612.tar.bz2
|
||||
gl-manpages-1.0.1.tar.bz2
|
||||
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -32,7 +32,7 @@ diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.dricore mesa-20080612/src/m
|
||||
fi \
|
||||
done
|
||||
+ $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||
+ $(INSTALL) -m 755 -d $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||
+ $(INSTALL) -m 755 $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||
$(INSTALL) -d $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_sarea.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- mesa-20080331/configure.ac.BAD 2008-04-12 11:37:32.000000000 -0500
|
||||
+++ mesa-20080331/configure.ac 2008-04-12 11:39:37.000000000 -0500
|
||||
@@ -512,6 +512,12 @@
|
||||
DRI_DIRS="mach64 r128 r200 r300 radeon tdfx"
|
||||
fi
|
||||
;;
|
||||
+ sparc*)
|
||||
+ # Build only the drivers for cards that exist on sparc`
|
||||
+ if test "x$DRI_DIRS" = x; then
|
||||
+ DRI_DIRS="mach64 r128 r200 r300 radeon ffb"
|
||||
+ fi
|
||||
+ ;;
|
||||
esac
|
||||
;;
|
||||
freebsd*)
|
@ -1,39 +1,21 @@
|
||||
From 8a156f47fc6547d5ed0fb8031f332cbf9e16948d Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Thu, 1 Nov 2007 16:16:52 +1000
|
||||
Subject: [PATCH] mesa: keep OSMESA version at 6.5.3
|
||||
|
||||
---
|
||||
src/mesa/Makefile | 9 +++++----
|
||||
1 files changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/mesa/Makefile b/src/mesa/Makefile
|
||||
index 77bb7be..e2a09ed 100644
|
||||
--- a/src/mesa/Makefile
|
||||
+++ b/src/mesa/Makefile
|
||||
@@ -117,17 +117,18 @@ $(TOP)/$(LIB_DIR)/$(GL_LIB_NAME): $(STAND_ALONE_OBJECTS)
|
||||
$(MKLIB_OPTIONS) $(GL_LIB_DEPS) $(STAND_ALONE_OBJECTS)
|
||||
|
||||
# Make the OSMesa library
|
||||
+# Note: version is kept at 6.5.3 to simplify app/linking issues
|
||||
$(TOP)/$(LIB_DIR)/$(OSMESA_LIB_NAME): $(OSMESA_DRIVER_OBJECTS) $(OSMESA16_OBJECTS)
|
||||
@ if [ "${DRIVER_DIRS}" = "osmesa" ] ; then \
|
||||
$(TOP)/bin/mklib -o $(OSMESA_LIB) -linker '$(CC)' \
|
||||
- -ldflags '$(LDFLAGS)' -major $(MESA_MAJOR) \
|
||||
- -minor $(MESA_MINOR) -patch $(MESA_TINY) \
|
||||
+ -ldflags '$(LDFLAGS)' -major 6 \
|
||||
+ -minor 5 -patch 3 \
|
||||
-install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
|
||||
$(OSMESA_LIB_DEPS) $(OSMESA16_OBJECTS) ; \
|
||||
else \
|
||||
$(TOP)/bin/mklib -o $(OSMESA_LIB) -linker '$(CC)' \
|
||||
- -ldflags '$(LDFLAGS)' -major $(MESA_MAJOR) \
|
||||
- -minor $(MESA_MINOR) -patch $(GL_TINY) \
|
||||
+ -ldflags '$(LDFLAGS)' -major 6 \
|
||||
+ -minor 5 -patch 3 \
|
||||
-install $(TOP)/$(LIB_DIR) $(MKLIB_OPTIONS) \
|
||||
$(OSMESA_LIB_DEPS) $(OSMESA_DRIVER_OBJECTS) ; \
|
||||
fi
|
||||
--
|
||||
1.5.3.4
|
||||
|
||||
diff -up mesa-20080612/src/mesa/drivers/osmesa/Makefile.osmesa mesa-20080612/src/mesa/drivers/osmesa/Makefile
|
||||
--- mesa-20080612/src/mesa/drivers/osmesa/Makefile.osmesa 2008-06-12 12:17:27.000000000 +1000
|
||||
+++ mesa-20080612/src/mesa/drivers/osmesa/Makefile 2008-06-12 13:14:24.000000000 +1000
|
||||
@@ -47,7 +47,7 @@ osmesa8: $(TOP)/lib/$(OSMESA_LIB_NAME)
|
||||
$(TOP)/lib/$(OSMESA_LIB_NAME): $(OBJECTS)
|
||||
$(TOP)/bin/mklib -o $(OSMESA_LIB) \
|
||||
-linker "$(CC)" \
|
||||
- -major $(MESA_MAJOR) -minor $(MESA_MINOR) -patch $(MESA_TINY) \
|
||||
+ -major 6 -minor 5 -patch 3 \
|
||||
-install $(TOP)/$(LIB_DIR) \
|
||||
$(MKLIB_OPTIONS) \
|
||||
$(OSMESA_LIB_DEPS) $(OBJECTS)
|
||||
@@ -60,7 +60,7 @@ $(TOP)/lib/$(OSMESA_LIB_NAME): $(OBJECTS
|
||||
osmesa16: $(OBJECTS) $(CORE_MESA)
|
||||
$(TOP)/bin/mklib -o $(OSMESA_LIB) \
|
||||
-linker "$(CC)" \
|
||||
- -major $(MESA_MAJOR) -minor $(MESA_MINOR) -patch $(MESA_TINY) \
|
||||
+ -major 6 -minor 5 -patch 3 \
|
||||
-install $(TOP)/$(LIB_DIR) \
|
||||
$(MKLIB_OPTIONS) \
|
||||
$(OSMESA_LIB_DEPS) $(OBJECTS) $(CORE_MESA)
|
||||
|
File diff suppressed because it is too large
Load Diff
16
mesa.spec
16
mesa.spec
@ -10,12 +10,12 @@
|
||||
%endif
|
||||
|
||||
%define manpages gl-manpages-1.0.1
|
||||
%define gitdate 20080415
|
||||
%define gitdate 20080612
|
||||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 7.1
|
||||
Release: 0.34%{?dist}
|
||||
Release: 0.35%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
@ -29,18 +29,13 @@ Source3: make-git-snapshot.sh
|
||||
|
||||
Patch0: mesa-7.1pre-osmesa-version.patch
|
||||
Patch2: mesa-7.1pre-nukeglthread-debug.patch
|
||||
Patch3: mesa-7.1-fda4895d-update.patch
|
||||
|
||||
# This doesn't work, disable for now.
|
||||
Patch4: disable-tex-offset.patch
|
||||
|
||||
Patch7: mesa-7.1-link-shared.patch
|
||||
# lets only build drivers on sparc that are remotely useful
|
||||
Patch8: mesa-7.1-sparc.patch
|
||||
|
||||
Patch10: mesa-7.1-bag-of-fixes.patch
|
||||
Patch12: mesa-7.1-disable-intel-classic-warn.patch
|
||||
Patch13: mesa-r500-support.patch
|
||||
|
||||
BuildRequires: pkgconfig autoconf automake
|
||||
%if %{with_dri}
|
||||
@ -166,13 +161,9 @@ This package provides some demo applications for testing Mesa.
|
||||
%setup -q -n mesa-%{gitdate} -b2
|
||||
%patch0 -p1 -b .osmesa
|
||||
%patch2 -p1 -b .intel-glthread
|
||||
%patch3 -p1 -b .git-update-fix-intel
|
||||
%patch4 -p1 -b .disable-tex-offset
|
||||
%patch7 -p1 -b .dricore
|
||||
%patch8 -p1
|
||||
%patch10 -p1 -b .misc-fixes
|
||||
%patch12 -p1 -b .intel-nowarn
|
||||
%patch13 -p1 -b .r500
|
||||
|
||||
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
||||
# license and are not open source/free software, so we remove them.
|
||||
@ -421,6 +412,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/mesa-demos-data
|
||||
|
||||
%changelog
|
||||
* Thu Jun 12 2008 Dave Airlie <airlied@redhat.com> 7.1-0.35
|
||||
- Update mesa to latest git snapshot - drop patches merged upstream
|
||||
|
||||
* Wed Jun 04 2008 Adam Jackson <ajax@redhat.com> 7.1-0.34
|
||||
- Link libdricore with gcc instead of ld, so we automagically pick up the
|
||||
ld --build-id flags.
|
||||
|
Loading…
Reference in New Issue
Block a user