- Bump to latest git snapshot.

- Drop mesa-7.1-dri-drivers.patch, it's upstream.
This commit is contained in:
Kristian Høgsberg 2008-03-04 01:49:32 +00:00
parent 46f14b6096
commit 0f60cf05a0
5 changed files with 21 additions and 71 deletions

View File

@ -1,3 +1,2 @@
gl-manpages-1.0.1.tar.bz2
mesa-20080215.tar.bz2
mesa-20080218.tar.bz2
mesa-20080303.tar.bz2

View File

@ -1,17 +1,22 @@
#!/bin/sh
# Usage: ./make-git-snapshot.sh [COMMIT]
#
# to make a snapshot of the given tag/branch. Defaults to HEAD.
# Point env var REF to a local mesa repo to reduce clone time.
DIRNAME=mesa-$( date +%Y%m%d )
echo REF ${REF:+--reference $REF}
echo DIRNAME $DIRNAME
echo HEAD ${1:-HEAD}
rm -rf $DIRNAME
git clone git://git.freedesktop.org/git/mesa/mesa $DIRNAME
cd $DIRNAME
if [ -z "$1" ]; then
git log | head -1
else
git checkout $1
fi
git log | head -1 | awk '{ print $2 }' > ../commitid
git repack -a -d
cd ..
tar jcf $DIRNAME.tar.bz2 $DIRNAME
rm -rf $DIRNAME
git clone ${REF:+--reference $REF} \
git://git.freedesktop.org/git/mesa/mesa $DIRNAME
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
| bzip2 > $DIRNAME.tar.bz2
# rm -rf $DIRNAME

View File

@ -1,55 +0,0 @@
diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
--- mesa-20080218/configure.ac.jx 2008-02-18 12:01:51.000000000 -0500
+++ mesa-20080218/configure.ac 2008-02-21 13:09:44.000000000 -0500
@@ -459,12 +459,7 @@
PROGRAM_DIRS="egl"
fi
- # default drivers
- if test "x$DRI_DIRS" = x; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
- savage sis tdfx trident unichrome ffb"
- fi
# Platform specific settings and drivers to build
case "$host_os" in
linux*)
@@ -475,7 +470,7 @@
fi
case "$host_cpu" in
- x86_64)
+ x86_64*)
# ffb, gamma, and sis are missing because they have not be
# converted to use the new interface. i810 are missing
# because there is no x86-64 system where they could *ever*
@@ -484,13 +479,15 @@
DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 radeon \
savage tdfx unichrome"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed 's/i810//g'`"
;;
powerpc*)
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = x; then
- DRI_DIRS="mach64 r128 r200 r300 radeon tdfx"
+ DRI_DIRS="mach64 mga r128 r200 r300 radeon savage tdfx"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed s/i810//g | sed s/i9.5//`"
;;
esac
;;
@@ -513,6 +510,12 @@
fi
;;
esac
+ # default drivers
+ if test "x$DRI_DIRS" = x; then
+ DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
+ savage sis tdfx trident unichrome ffb"
+ fi
+
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
# Check for expat

View File

@ -32,7 +32,7 @@ Patch2: mesa-7.1pre-nukeglthread-debug.patch
BuildRequires: pkgconfig autoconf automake
%if %{with_dri}
BuildRequires: libdrm-devel >= 2.4.0-0.4
BuildRequires: libdrm-devel >= 2.4.0-0.5
%endif
BuildRequires: libXxf86vm-devel
BuildRequires: expat-devel >= 2.0
@ -396,6 +396,7 @@ rm -rf $RPM_BUILD_ROOT
* Mon Mar 3 2008 Kristian Høgsberg <krh@redhat.com> - 7.1-0.19
- Bump to latest git snapshot.
- Drop mesa-7.1-dri-drivers.patch, it's upstream.
- Require libdrm-devel >= 2.4.0-0.5
* Mon Mar 03 2008 Dave Airlie <airlied@redhat.com> 7.1-0.18
- fix i915 build due to symbol visibility

View File

@ -1,2 +1,2 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
0faf6afeee7f2ef78efeb681690c0c25 mesa-20080218.tar.bz2
2b1a09d87cd56f4601265993ac747db3 mesa-20080303.tar.bz2