rebase patches

Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
This commit is contained in:
Igor Gnatenko 2016-05-01 08:13:24 +02:00
parent b4248df350
commit 0a3293d6d5
4 changed files with 15 additions and 15 deletions

View File

@ -1,4 +1,4 @@
From d4ddf13509e47cb92aa192283b51517e2ac5ba40 Mon Sep 17 00:00:00 2001
From c2b4d93a5e4796ca53361c61d7e31edc24241932 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 20 Mar 2016 13:26:25 +0100
Subject: [PATCH 1/4] llvm SONAME without version
@ -9,10 +9,10 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index ffd51db..99f94b2 100644
index 5f75c60..d77f907 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2331,7 +2331,7 @@ if test "x$MESA_LLVM" != x0; then
@@ -2387,7 +2387,7 @@ if test "x$MESA_LLVM" != x0; then
dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
if test "x$enable_llvm_shared_libs" = xyes; then
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,

View File

@ -1,4 +1,4 @@
From e0c9dfde64eae9d2faea55ff2d1868ffa750664d Mon Sep 17 00:00:00 2001
From 00bcd599310dc7fce4fe336ffd85902429051a0c Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 20 Mar 2016 13:27:04 +0100
Subject: [PATCH 2/4] hardware gloat
@ -10,10 +10,10 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
2 files changed, 14 insertions(+)
diff --git a/src/gallium/drivers/llvmpipe/lp_screen.c b/src/gallium/drivers/llvmpipe/lp_screen.c
index 2529b54..5b86dee 100644
index 4f61de8..3b0ec77 100644
--- a/src/gallium/drivers/llvmpipe/lp_screen.c
+++ b/src/gallium/drivers/llvmpipe/lp_screen.c
@@ -409,6 +409,13 @@ llvmpipe_is_format_supported( struct pipe_screen *_screen,
@@ -411,6 +411,13 @@ llvmpipe_is_format_supported( struct pipe_screen *_screen,
if (!format_desc)
return FALSE;
@ -28,10 +28,10 @@ index 2529b54..5b86dee 100644
target == PIPE_TEXTURE_1D ||
target == PIPE_TEXTURE_1D_ARRAY ||
diff --git a/src/gallium/drivers/softpipe/sp_screen.c b/src/gallium/drivers/softpipe/sp_screen.c
index bfd3598..63e6c9f 100644
index 031602b..c279120 100644
--- a/src/gallium/drivers/softpipe/sp_screen.c
+++ b/src/gallium/drivers/softpipe/sp_screen.c
@@ -352,6 +352,13 @@ softpipe_is_format_supported( struct pipe_screen *screen,
@@ -358,6 +358,13 @@ softpipe_is_format_supported( struct pipe_screen *screen,
if (!format_desc)
return FALSE;

View File

@ -1,4 +1,4 @@
From 3235442c3b2b7a472fd8aed08131f507f7b94d20 Mon Sep 17 00:00:00 2001
From 0ec3bdb2264b491fd3f5dc4e638b4c12611ef219 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 20 Mar 2016 13:27:45 +0100
Subject: [PATCH 3/4] evergreen big endian
@ -9,12 +9,12 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/gallium/drivers/r600/r600_state_common.c b/src/gallium/drivers/r600/r600_state_common.c
index df41d3f..856b276 100644
index cac240e..4b620a1 100644
--- a/src/gallium/drivers/r600/r600_state_common.c
+++ b/src/gallium/drivers/r600/r600_state_common.c
@@ -2726,7 +2726,7 @@ uint32_t r600_translate_colorformat(enum chip_class chip, enum pipe_format forma
@@ -2716,7 +2716,7 @@ uint32_t r600_translate_colorformat(enum chip_class chip, enum pipe_format forma
uint32_t r600_colorformat_endian_swap(uint32_t colorformat)
uint32_t r600_colorformat_endian_swap(uint32_t colorformat, bool do_endian_swap)
{
- if (R600_BIG_ENDIAN) {
+ if (0 && R600_BIG_ENDIAN) {

View File

@ -1,4 +1,4 @@
From 6f7af73d73cead0bf4e29d4f91ad2885bdf879cb Mon Sep 17 00:00:00 2001
From 6ccae713acc457d7df6ab15e124a7d77c5093213 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 20 Mar 2016 13:28:07 +0100
Subject: [PATCH 4/4] bigendian assert
@ -9,10 +9,10 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
1 file changed, 3 insertions(+)
diff --git a/src/gallium/auxiliary/util/u_math.h b/src/gallium/auxiliary/util/u_math.h
index e92f83a..e403d49 100644
index ecb1d63..90ada14 100644
--- a/src/gallium/auxiliary/util/u_math.h
+++ b/src/gallium/auxiliary/util/u_math.h
@@ -55,6 +55,9 @@
@@ -59,6 +59,9 @@
extern "C" {
#endif