10.0 upstream release

v1: dropped libdricore.so* (dropped by upstream)
    updated libxatracker.so.1 to libxatracker.so.2 (updated by upstream)
    updated patches and tools:
    make-git-snapshot updated for 10.0 branch
    sanitize-tarball updated for new functions
    nv-50 build fix updated for new file location
    dropped no-useless-vdpau, because not needed for new mesa stack

v2: Added msm_dri.so (added by upstream)

v3: Fix sanitize for vl_level_supported()
    Reported-and-tested-by: Kirill Rusinov <carasin.berlogue@mail.ru>

v4: Add reference to spec
    Drop old patch nv50

Tested-by: Kirill Rusinov <carasin.berlogue@mail.ru>
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Reference: https://bugzilla.redhat.com/show_bug.cgi?id=1036361
This commit is contained in:
Igor Gnatenko 2013-12-01 16:51:48 +04:00
parent f5c756cfd1
commit 037ad6c04b
6 changed files with 40 additions and 74 deletions

View File

@ -15,11 +15,11 @@ DIRNAME=mesa-$( date +%Y%m%d )
echo REF ${REF:+--reference $REF}
echo DIRNAME $DIRNAME
echo HEAD ${1:-9.2}
echo HEAD ${1:-10.0}
rm -rf $DIRNAME
git clone --depth 1 ${REF:+--reference $REF} --branch 9.2 \
git clone --depth 1 ${REF:+--reference $REF} --branch 10.0 \
git://git.freedesktop.org/git/mesa/mesa $DIRNAME
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \

View File

@ -0,0 +1,12 @@
diff -uNr mesa-20131201.orig/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp mesa-20131201/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp
--- mesa-20131201.orig/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp 2013-12-01 11:29:21.000000000 +0400
+++ mesa-20131201/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp 2013-12-01 16:05:06.488417551 +0400
@@ -739,7 +739,7 @@
if (!i)
i = new_Instruction(pol.context(), op, dType);
#ifndef NDEBUG // non-conformant assert, so this is required
- assert(typeid(*i) == typeid(*this));
+ //assert(typeid(*i) == typeid(*this));
#endif
pol.set<Instruction>(this, i);

View File

@ -1,27 +0,0 @@
Neither of these drivers does anything on-GPU, so, no.
diff -up mesa-20130508/src/gallium/targets/Makefile.am.jx mesa-20130508/src/gallium/targets/Makefile.am
--- mesa-20130508/src/gallium/targets/Makefile.am.jx 2013-05-08 13:23:41.000000000 -0400
+++ mesa-20130508/src/gallium/targets/Makefile.am 2013-05-08 14:59:50.897835932 -0400
@@ -78,10 +78,6 @@ endif
if HAVE_ST_XVMC
SUBDIRS += xvmc-r300
endif
-
-if HAVE_ST_VDPAU
-SUBDIRS += vdpau-r300
-endif
endif
if HAVE_GALLIUM_R600
@@ -142,10 +138,6 @@ endif
if HAVE_ST_XVMC
SUBDIRS += xvmc-softpipe
endif
-
-if HAVE_ST_VDPAU
-SUBDIRS += vdpau-softpipe
-endif
endif
if NEED_GALLIUM_LOADER

View File

@ -48,12 +48,12 @@
%define _default_patch_fuzz 2
%define gitdate 20131128
%define gitdate 20131206
#% define snapshot
Summary: Mesa graphics libraries
Name: mesa
Version: 9.2.4
Version: 10.0
Release: 1.%{gitdate}%{?dist}
License: MIT
Group: System Environment/Libraries
@ -70,11 +70,10 @@ Source3: make-git-snapshot.sh
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
Source4: Mesa-MLAA-License-Clarification-Email.txt
Patch1: nv50-fix-build.patch
Patch1: mesa-10.0-nv50-fix-build.patch
Patch9: mesa-8.0-llvmpipe-shmget.patch
Patch12: mesa-8.0.1-fix-16bpp.patch
Patch15: mesa-9.2-hardware-float.patch
Patch16: mesa-9.2-no-useless-vdpau.patch
Patch20: mesa-9.2-evergreen-big-endian.patch
BuildRequires: pkgconfig autoconf automake libtool
@ -299,7 +298,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
#patch12 -p1 -b .16bpp
%patch15 -p1 -b .hwfloat
%patch16 -p1 -b .vdpau
%patch20 -p1 -b .egbe
%if 0%{with_private_llvm}
@ -475,19 +473,12 @@ rm -rf $RPM_BUILD_ROOT
%endif
%if 0%{?with_freedreno}
%{_libdir}/dri/kgsl_dri.so
%{_libdir}/dri/msm_dri.so
%endif
%{_libdir}/dri/nouveau_dri.so
%if 0%{?with_vmware}
%{_libdir}/dri/vmwgfx_dri.so
%endif
%{_libdir}/libdricore*.so*
%endif
# this is funky; it doesn't get built for gallium drivers, so it doesn't
# exist on s390x where swrast is llvmpipe, but does exist on s390 where
# swrast is classic mesa. this seems like a bug? in that it probably
# means the gallium drivers are linking dricore statically? fixme.
%ifarch s390
%{_libdir}/libdricore*.so*
%endif
%{_libdir}/dri/swrast_dri.so
@ -584,8 +575,8 @@ rm -rf $RPM_BUILD_ROOT
%defattr(-,root,root,-)
%doc docs/COPYING
%if %{with_hardware}
%{_libdir}/libxatracker.so.1
%{_libdir}/libxatracker.so.1.*
%{_libdir}/libxatracker.so.2
%{_libdir}/libxatracker.so.2.*
%endif
%files libxatracker-devel
@ -600,6 +591,9 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Sun Dec 01 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.0-1.20131206
- 10.0 upstream (RHBZ 1036361)
* Thu Nov 28 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 9.2.4-1.20131128
- 9.2.4 upstream release

View File

@ -1,12 +0,0 @@
diff -up mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp.rtti mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp
--- mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp.rtti 2013-02-13 18:08:17.533677028 +1000
+++ mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp 2013-02-13 18:08:20.496752128 +1000
@@ -716,7 +716,7 @@ Instruction::clone(ClonePolicy<Function>
if (!i)
i = new_Instruction(pol.context(), op, dType);
#ifndef NDEBUG // non-conformant assert, so this is required
- assert(typeid(*i) == typeid(*this));
+ // assert(typeid(*i) == typeid(*this));
#endif
pol.set<Instruction>(this, i);

View File

@ -20,14 +20,9 @@ pushd $dirname
cat > src/gallium/auxiliary/vl/vl_mpeg12_decoder.c << EOF
#include "vl_mpeg12_decoder.h"
struct pipe_video_decoder *
struct pipe_video_codec *
vl_create_mpeg12_decoder(struct pipe_context *context,
enum pipe_video_profile profile,
enum pipe_video_entrypoint entrypoint,
enum pipe_video_chroma_format chroma_format,
unsigned width, unsigned height,
unsigned max_references,
bool expect_chunked_decode)
const struct pipe_video_codec *templat)
{
return NULL;
}
@ -35,20 +30,24 @@ EOF
cat > src/gallium/auxiliary/vl/vl_decoder.c << EOF
#include "vl_decoder.h"
bool vl_profile_supported(struct pipe_screen *screen,
enum pipe_video_profile profile)
bool
vl_profile_supported(struct pipe_screen *screen, enum pipe_video_profile profile,
enum pipe_video_entrypoint entrypoint)
{
return false;
return false;
}
struct pipe_video_decoder *
vl_create_decoder(struct pipe_context *pipe,
enum pipe_video_profile profile,
enum pipe_video_entrypoint entrypoint,
enum pipe_video_chroma_format chroma_format,
unsigned width, unsigned height, unsigned max_references,
bool expect_chunked_decode)
int
vl_level_supported(struct pipe_screen *screen, enum pipe_video_profile profile)
{
return NULL;
return 0;
}
struct pipe_video_codec *
vl_create_decoder(struct pipe_context *pipe,
const struct pipe_video_codec *templat)
{
return NULL;
}
EOF