update to latest mesa 7.11 with nvfx g-s fix.

This commit is contained in:
Dave Airlie 2011-06-21 13:25:44 +10:00
parent 026565821e
commit 02e68ef39f
6 changed files with 39 additions and 100 deletions

View File

@ -1,12 +1,12 @@
diff -up mesa-20100529/configure.ac.nouveau mesa-20100529/configure.ac
--- mesa-20100529/configure.ac.nouveau 2010-05-29 18:57:30.000000000 +1000
+++ mesa-20100529/configure.ac 2010-05-29 18:58:24.000000000 +1000
@@ -820,20 +820,20 @@ if test "$mesa_driver" = dri; then
diff -up mesa-20110620/configure.ac.classic mesa-20110620/configure.ac
--- mesa-20110620/configure.ac.classic 2011-06-20 13:52:52.000000000 +1000
+++ mesa-20110620/configure.ac 2011-06-20 13:55:09.000000000 +1000
@@ -1023,20 +1023,20 @@ if test "$mesa_driver" = dri -o "$mesa_d
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
- savage tdfx unichrome swrast"
+ savage tdfx unichrome nouveau"
DRI_DIRS="i915 i965 mga nouveau r128 r200 r300 r600 \
- radeon savage tdfx unichrome swrast"
+ radeon savage tdfx unichrome"
fi
;;
powerpc*)
@ -25,12 +25,12 @@ diff -up mesa-20100529/configure.ac.nouveau mesa-20100529/configure.ac
fi
;;
esac
@@ -870,7 +870,7 @@ if test "$mesa_driver" = dri; then
@@ -1080,7 +1080,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 radeon \
- savage sis tdfx unichrome swrast"
+ savage sis tdfx unichrome nouveau"
+ savage sis tdfx unichrome"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`

View File

@ -1,28 +0,0 @@
From: Dave Airlie <airlied at redhat.com>
We are getting inconsistent methods for endian detection (same answer when
it works, just doesn't work on some platforms) depending on whether __GLIBC__
is defined, which of course depends on include ordering before p_config.h
Just make p_config.h include limits.h to solve this.
Signed-off-by: Dave Airlie <airlied at redhat.com>
---
src/gallium/include/pipe/p_config.h | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/gallium/include/pipe/p_config.h b/src/gallium/include/pipe/p_config.h
index 1818c8b..40f6f2b 100644
--- a/src/gallium/include/pipe/p_config.h
+++ b/src/gallium/include/pipe/p_config.h
@@ -46,7 +46,7 @@
#ifndef P_CONFIG_H_
#define P_CONFIG_H_
-
+#include <limits.h>
/*
* Compiler
*/
--
1.7.4.4

View File

@ -1,15 +1,15 @@
diff -up mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c.dave mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c
--- mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c.dave 2010-05-30 18:24:35.000000000 +1000
+++ mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c 2010-05-30 18:24:42.000000000 +1000
@@ -558,11 +558,6 @@ intel_render_texture(GLcontext * ctx,
diff -up mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c.da mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c
--- mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c.da 2011-06-20 13:51:25.000000000 +1000
+++ mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c 2011-06-20 13:51:32.000000000 +1000
@@ -612,11 +612,6 @@ intel_render_texture(struct gl_context *
return;
}
- DBG("Begin render texture tid %lx tex=%u w=%d h=%d refcount=%d\n",
- _glthread_GetID(),
- att->Texture->Name, newImage->Width, newImage->Height,
- att->Texture->Name, image->Width, image->Height,
- irb->Base.RefCount);
-
/* point the renderbufer's region to the texture image region */
if (irb->region != intel_image->mt->region) {
if (irb->region)
intel_renderbuffer_set_draw_offset(irb, intel_image, att->Zoffset);
intel_image->used_as_render_target = GL_TRUE;

View File

@ -1,26 +0,0 @@
From 1d24e6ec1d13c2b88b858997900aa8b69de92b13 Mon Sep 17 00:00:00 2001
From: Ben Skeggs <bskeggs@redhat.com>
Date: Mon, 6 Jun 2011 10:17:59 +1000
Subject: [PATCH] dri/nouveau: fix gnome-shell segfault
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
---
src/mesa/drivers/dri/nouveau/nouveau_context.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/mesa/drivers/dri/nouveau/nouveau_context.c b/src/mesa/drivers/dri/nouveau/nouveau_context.c
index 71dde41..22b9957 100644
--- a/src/mesa/drivers/dri/nouveau/nouveau_context.c
+++ b/src/mesa/drivers/dri/nouveau/nouveau_context.c
@@ -261,7 +261,7 @@ nouveau_update_renderbuffers(__DRIcontext *dri_ctx, __DRIdrawable *draw)
assert(!ret);
}
- _mesa_resize_framebuffer(NULL, fb, draw->w, draw->h);
+ _mesa_resize_framebuffer(ctx, fb, draw->w, draw->h);
}
static void
--
1.7.5.2

View File

@ -1,16 +1,16 @@
diff -up mesa-20100529/configure.ac.mach64 mesa-20100529/configure.ac
--- mesa-20100529/configure.ac.mach64 2010-05-29 11:31:22.000000000 +1000
+++ mesa-20100529/configure.ac 2010-05-29 18:53:55.000000000 +1000
@@ -819,7 +819,7 @@ if test "$mesa_driver" = dri; then
diff -up mesa-20110620/configure.ac.no-mach64 mesa-20110620/configure.ac
--- mesa-20110620/configure.ac.no-mach64 2011-06-20 12:19:16.000000000 +1000
+++ mesa-20110620/configure.ac 2011-06-20 13:52:27.000000000 +1000
@@ -1022,7 +1022,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
# the new interface. i810 are missing because there is no
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
savage tdfx unichrome swrast"
- DRI_DIRS="i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
+ DRI_DIRS="i915 i965 mga nouveau r128 r200 r300 r600 \
radeon savage tdfx unichrome swrast"
fi
;;
@@ -827,13 +827,13 @@ if test "$mesa_driver" = dri; then
@@ -1030,13 +1030,13 @@ if test "$mesa_driver" = dri -o "$mesa_d
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
@ -26,21 +26,21 @@ diff -up mesa-20100529/configure.ac.mach64 mesa-20100529/configure.ac
fi
;;
esac
@@ -850,7 +850,7 @@ if test "$mesa_driver" = dri; then
@@ -1050,7 +1050,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
fi
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
unichrome savage sis swrast"
- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
+ DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 \
radeon tdfx unichrome savage sis swrast"
fi
;;
@@ -869,7 +869,7 @@ if test "$mesa_driver" = dri; then
@@ -1079,7 +1079,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 radeon \
+ DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 radeon \
savage sis tdfx unichrome swrast"
fi

View File

@ -12,13 +12,13 @@
%define _default_patch_fuzz 2
%define manpages gl-manpages-1.0.1
%define gitdate 20110525
%define gitdate 20110621
#% define snapshot
Summary: Mesa graphics libraries
Name: mesa
Version: 7.11
Release: 0.13.%{gitdate}.0%{?dist}
Release: 0.14.%{gitdate}.0%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -41,12 +41,6 @@ Patch8: mesa-7.10-llvmcore.patch
Patch30: mesa-7.6-hush-vblank-warning.patch
Patch31: mesa-7.10-swrastg.patch
# build fix
Patch40: mesa-20110525-gallium-config.patch
# fix gnome-shell on pre-nv30 chipsets
Patch41: mesa-7.11-nouveau-old-gs.patch
BuildRequires: pkgconfig autoconf automake libtool
%if %{with_hardware}
BuildRequires: kernel-headers >= 2.6.27-0.305.rc5.git6
@ -231,10 +225,6 @@ Requires: Xorg %(xserver-sdk-abi-requires ansic) %(xserver-sdk-abi-requires vide
%patch8 -p1 -b .llvmcore
%endif
%patch40 -p1 -b .header-order
%patch41 -p1 -b .vieux-gs
%build
autoreconf --install
@ -498,7 +488,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libOSMesa.so
%changelog
* Mon Jul 06 2011 Ben Skeggs <bskeggs@redhat.com> 7.11-0.13.20110525.0
* Tue Jun 21 2011 Dave Airlie <airlied@redhat.com> 7.11-0.14.20110621.0
- update to latest mesa 7.11 with nvfx g-s fix.
* Mon Jun 06 2011 Ben Skeggs <bskeggs@redhat.com> 7.11-0.13.20110525.0
- nouveau: fix shell segfault on pre-gallium drivers (#708004)
* Mon May 30 2011 Dan Horák <dan[at]danny.cz> 7.11-0.12.20110525.0