41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
--- examples/CMakeLists.txt 2014-01-28 17:02:51.498837020 +0700
|
|
+++ examples/CMakeLists.txt-examples 2014-01-28 17:04:52.118182901 +0700
|
|
@@ -4,22 +4,26 @@ endif(MGL_HAVE_GSL)
|
|
|
|
add_executable(mgl_example wnd_samples.cpp full_test.cpp samples.cpp)
|
|
target_link_libraries(mgl_example mgl)
|
|
+SET(MGL_INSTALL_EXAMPLES_LIST mgl_example)
|
|
|
|
if(MGL_HAVE_FLTK)
|
|
include_directories(${FLTK_INCLUDE_DIR})
|
|
add_executable(mgl_fltk_example wnd_samples.cpp fltk_example.cpp)
|
|
target_link_libraries(mgl_fltk_example mgl-fltk)
|
|
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_fltk_example)
|
|
endif(MGL_HAVE_FLTK)
|
|
|
|
if(MGL_HAVE_GLUT)
|
|
add_executable(mgl_glut_example wnd_samples.cpp glut_example.cpp)
|
|
target_link_libraries(mgl_glut_example mgl-glut)
|
|
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_glut_example)
|
|
endif(MGL_HAVE_GLUT)
|
|
|
|
if(MGL_HAVE_WX)
|
|
include(${wxWidgets_USE_FILE})
|
|
add_executable(mgl_wx_example wnd_samples.cpp wx_example.cpp)
|
|
target_link_libraries(mgl_wx_example mgl-wx)
|
|
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_wx_example)
|
|
endif(MGL_HAVE_WX)
|
|
|
|
if(enable-qt)
|
|
@@ -31,4 +35,10 @@ if(enable-qt)
|
|
include(../cmake-qt4.txt)
|
|
target_link_libraries(mgl_qt_example mgl-qt4)
|
|
endif(enable-qt5)
|
|
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_qt_example)
|
|
endif(enable-qt)
|
|
+
|
|
+install(
|
|
+ TARGETS ${MGL_INSTALL_EXAMPLES_LIST}
|
|
+ RUNTIME DESTINATION bin
|
|
+)
|