24 lines
744 B
Diff
24 lines
744 B
Diff
--- CMakeLists.txt.initial 2014-10-07 17:16:53.271970273 +0700
|
|
+++ CMakeLists.txt 2014-10-07 17:17:01.168867231 +0700
|
|
@@ -265,7 +265,7 @@ endif(enable-gsl)
|
|
# set(MGL_HAVE_LTDL 0)
|
|
#endif(enable-all OR enable-ltdl)
|
|
|
|
-if(enable-hdf4)
|
|
+if(enable-hdf4 AND (NOT enable-hdf5))
|
|
set(MGL_HAVE_HDF4 1)
|
|
find_library(HDF4_LIB df)
|
|
find_library(HDF4MF_LIB mfhdf)
|
|
@@ -276,9 +276,9 @@ if(enable-hdf4)
|
|
message(SEND_ERROR "${HDF4_INCLUDE_DIR}")
|
|
message(SEND_ERROR "Couldn't find HDF4 libraries.")
|
|
endif(NOT HDF4_LIB OR NOT HDF4MF_LIB OR NOT HDF4_INCLUDE_DIR)
|
|
-else(enable-hdf4)
|
|
+else(enable-hdf4 AND (NOT enable-hdf5))
|
|
set(MGL_HAVE_HDF4 0)
|
|
-endif(enable-hdf4)
|
|
+endif(enable-hdf4 AND (NOT enable-hdf5))
|
|
|
|
if(enable-hdf5)
|
|
set(MGL_HAVE_HDF5 1)
|