24 lines
748 B
Diff
24 lines
748 B
Diff
--- CMakeLists.txt 2015-11-24 12:15:35.787678739 +0600
|
|
+++ CMakeLists.txt 2015-11-24 12:20:24.562634222 +0600
|
|
@@ -292,7 +292,7 @@ else(enable-all OR enable-ltdl)
|
|
set(MGL_HAVE_LTDL 0)
|
|
endif(enable-all OR enable-ltdl)
|
|
|
|
-if(enable-hdf4)
|
|
+if(enable-hdf4 AND (NOT enable-hdf5))
|
|
set(MGL_HAVE_HDF4 1)
|
|
find_library(HDF4_LIB df)
|
|
find_library(HDF4MF_LIB mfhdf)
|
|
@@ -303,9 +303,9 @@ if(enable-hdf4)
|
|
message(SEND_ERROR "${HDF4_INCLUDE_DIR}")
|
|
message(SEND_ERROR "Couldn't find HDF4 libraries.")
|
|
endif(NOT HDF4_LIB OR NOT HDF4MF_LIB OR NOT HDF4_INCLUDE_DIR)
|
|
-else(enable-hdf4)
|
|
+else(enable-hdf4 AND (NOT enable-hdf5))
|
|
set(MGL_HAVE_HDF4 0)
|
|
-endif(enable-hdf4)
|
|
+endif(enable-hdf4 AND (NOT enable-hdf5))
|
|
|
|
if(enable-hdf5)
|
|
set(MGL_HAVE_HDF5 1)
|