Update to 8.0.1

Drop Qt4 support
This commit is contained in:
Orion Poplawski 2022-10-06 18:53:02 -06:00
parent 6c54689497
commit cc28cd133f
6 changed files with 86 additions and 134 deletions

1
.gitignore vendored
View File

@ -12,3 +12,4 @@ mathgl-1.10.2.1.tgz
/mathgl-2.4.1.tar.gz
/mathgl-2.4.2.1.tar.gz
/mathgl-2.4.4.tar.gz
/mathgl-8.0.1.tar.gz

View File

@ -1,60 +1,7 @@
diff -up mathgl-2.4.2/lang/CMakeLists.txt.lang mathgl-2.4.2/lang/CMakeLists.txt
--- mathgl-2.4.2/lang/CMakeLists.txt.lang 2018-03-21 10:48:17.000000000 -0600
+++ mathgl-2.4.2/lang/CMakeLists.txt 2018-11-07 21:47:46.663647687 -0700
@@ -17,52 +17,6 @@ if(NOT SWIG_FOUND)
endif(NOT SWIG_FOUND)
INCLUDE(${SWIG_USE_FILE})
-if(enable-python)
- set(Python_ADDITIONAL_VERSIONS 2.7)
- FIND_PACKAGE(PythonInterp)
- if(NOT PYTHONINTERP_FOUND)
- message(SEND_ERROR "Couldn't find python interpreter.")
- endif(NOT PYTHONINTERP_FOUND)
- FIND_PACKAGE(PythonLibs)
- if(NOT PYTHONLIBS_FOUND)
- message(SEND_ERROR "Couldn't find python development libraries.")
- endif(NOT PYTHONLIBS_FOUND)
- execute_process(
- COMMAND ${PYTHON_EXECUTABLE} -c "import numpy; print numpy.get_include()"
- OUTPUT_VARIABLE NUMPY_INCLUDE_PATH
- RESULT_VARIABLE NUMPY_ERR
- OUTPUT_STRIP_TRAILING_WHITESPACE
- )
- if(NOT NUMPY_INCLUDE_PATH)
- message(SEND_ERROR "Couldn't find numpy.")
- endif(NOT NUMPY_INCLUDE_PATH)
-
- include_directories(${PYTHON_INCLUDE_DIR} ${NUMPY_INCLUDE_PATH})
- execute_process(
- COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(prefix='${CMAKE_INSTALL_PREFIX}')"
- OUTPUT_VARIABLE MGL_PYTHON_SITE_PACKAGES
- OUTPUT_STRIP_TRAILING_WHITESPACE)
- set(SWIG_MODULE_mathgl_EXTRA_DEPS numpy.i ${src_imp_dep})
- if(${CMAKE_VERSION} VERSION_LESS "3.8.0")
- SWIG_ADD_MODULE(mathgl python mathgl.i)
- else(${CMAKE_VERSION} VERSION_LESS "3.8.0")
- SWIG_ADD_LIBRARY(mathgl LANGUAGE python SOURCES mathgl.i)
- endif(${CMAKE_VERSION} VERSION_LESS "3.8.0")
- SWIG_LINK_LIBRARIES(mathgl mgl ${PYTHON_LIBRARIES})
- set_target_properties(_mathgl PROPERTIES BUILD_WITH_INSTALL_RPATH ON)
- add_custom_command(OUTPUT mathgl.pyc
- COMMAND ${PYTHON_EXECUTABLE}
- ARGS -c \"from py_compile import compile\; compile('mathgl.py') \"
- WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/lang
- DEPENDS _mathgl
- )
- add_custom_target(mgl_python_module ALL DEPENDS _mathgl mathgl.pyc)
-
- install(FILES ${MathGL2_BINARY_DIR}/lang/mathgl.py ${MathGL2_BINARY_DIR}/lang/mathgl.pyc DESTINATION ${MGL_PYTHON_SITE_PACKAGES})
- install (TARGETS _mathgl LIBRARY DESTINATION ${MGL_PYTHON_SITE_PACKAGES})
- set(mgl_clean_files ${mgl_clean_files} mathgl.py)
-endif(enable-python)
-
if(enable-lua)
INCLUDE(FindLua51)
if(NOT LUA51_FOUND)
@@ -145,4 +99,8 @@ message(STATUS "${oct_prog} ${oct_host}
diff -up mathgl-8.0.1/lang/CMakeLists.txt.lang mathgl-8.0.1/lang/CMakeLists.txt
--- mathgl-8.0.1/lang/CMakeLists.txt.lang 2022-01-11 13:48:54.000000000 -0700
+++ mathgl-8.0.1/lang/CMakeLists.txt 2022-10-05 20:17:12.149704032 -0600
@@ -145,4 +145,8 @@ message(STATUS "${oct_prog} ${oct_host}
endif(enable-octave-install)
set(mgl_clean_files ${mgl_clean_files} mathgl)
endif(enable-octave)
@ -63,9 +10,9 @@ diff -up mathgl-2.4.2/lang/CMakeLists.txt.lang mathgl-2.4.2/lang/CMakeLists.txt
+add_subdirectory( python3 )
+
set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES "${mgl_clean_files}")
diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
--- mathgl-2.4.2/lang/numpy.i.lang 2018-03-21 10:48:17.000000000 -0600
+++ mathgl-2.4.2/lang/numpy.i 2018-11-07 21:45:40.490389470 -0700
diff -up mathgl-8.0.1/lang/numpy.i.lang mathgl-8.0.1/lang/numpy.i
--- mathgl-8.0.1/lang/numpy.i.lang 2022-01-11 13:48:54.000000000 -0700
+++ mathgl-8.0.1/lang/numpy.i 2022-10-05 20:22:27.909092484 -0600
@@ -97,7 +97,7 @@
{
/* Given a PyObject, return a string describing its type.
@ -75,20 +22,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
if (py_obj == NULL ) return "C NULL value";
if (py_obj == Py_None ) return "Python None" ;
if (PyCallable_Check(py_obj)) return "callable" ;
@@ -107,17 +107,18 @@
if (PyDict_Check( py_obj)) return "dict" ;
if (PyList_Check( py_obj)) return "list" ;
if (PyTuple_Check( py_obj)) return "tuple" ;
- if (PyFile_Check( py_obj)) return "file" ;
if (PyModule_Check( py_obj)) return "module" ;
+%#if PY_MAJOR_VERSION < 3
+ if (PyFile_Check( py_obj)) return "file" ;
if (PyInstance_Check(py_obj)) return "instance" ;
-
- return "unknow type";
+%#endif
+ return "unkown type";
}
@@ -114,8 +114,8 @@
/* Given a NumPy typecode, return a string describing the type.
*/
@ -99,7 +33,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
"short", "unsigned short", "int",
"unsigned int", "long", "unsigned long",
"long long", "unsigned long long",
@@ -159,8 +160,8 @@
@@ -157,8 +157,8 @@
}
else if is_array(input)
{
@ -110,7 +44,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
PyErr_Format(PyExc_TypeError,
"Array of type '%s' required. Array of type '%s' given",
desired_type, actual_type);
@@ -168,8 +169,8 @@
@@ -166,8 +166,8 @@
}
else
{
@ -121,7 +55,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
PyErr_Format(PyExc_TypeError,
"Array of type '%s' required. A '%s' was given",
desired_type, actual_type);
@@ -307,6 +308,95 @@
@@ -305,6 +305,95 @@
return ary1;
}
@ -217,7 +151,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
} /* end fragment */
@@ -601,7 +691,7 @@
@@ -599,7 +688,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[1] = { $1_dim0 };
@ -226,7 +160,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 1) ||
!require_size(array, size, 1)) SWIG_fail;
@@ -628,7 +718,7 @@
@@ -626,7 +715,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[1] = { -1 };
@ -235,7 +169,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 1) ||
!require_size(array, size, 1)) SWIG_fail;
@@ -656,7 +746,7 @@
@@ -654,7 +743,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[1] = {-1};
@ -244,7 +178,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 1) ||
!require_size(array, size, 1)) SWIG_fail;
@@ -684,7 +774,7 @@
@@ -682,7 +771,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[2] = { $1_dim0, $1_dim1 };
@ -253,7 +187,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 2) ||
!require_size(array, size, 2)) SWIG_fail;
@@ -711,7 +801,7 @@
@@ -709,7 +798,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[2] = { -1, -1 };
@ -262,7 +196,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 2) ||
!require_size(array, size, 2)) SWIG_fail;
@@ -740,7 +830,7 @@
@@ -738,7 +827,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[2] = { -1, -1 };
@ -271,7 +205,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 2) ||
!require_size(array, size, 2)) SWIG_fail;
@@ -769,7 +859,7 @@
@@ -767,7 +856,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[2] = { -1, -1 };
@ -280,7 +214,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 2) ||
!require_size(array, size, 2) || !require_fortran(array)) SWIG_fail;
@@ -798,7 +888,7 @@
@@ -796,7 +885,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[2] = { -1, -1 };
@ -289,7 +223,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 2) ||
!require_size(array, size, 2) || !require_fortran(array)) SWIG_fail;
@@ -827,7 +917,7 @@
@@ -825,7 +914,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[3] = { $1_dim0, $1_dim1, $1_dim2 };
@ -298,7 +232,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 3) ||
!require_size(array, size, 3)) SWIG_fail;
@@ -855,7 +945,7 @@
@@ -853,7 +942,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[3] = { -1, -1, -1 };
@ -307,7 +241,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 3) ||
!require_size(array, size, 3)) SWIG_fail;
@@ -886,7 +976,7 @@
@@ -884,7 +973,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[3] = { -1, -1, -1 };
@ -316,7 +250,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 3) ||
!require_size(array, size, 3)) SWIG_fail;
@@ -917,7 +1007,7 @@
@@ -915,7 +1004,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[3] = { -1, -1, -1 };
@ -325,7 +259,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 3) ||
!require_size(array, size, 3) | !require_fortran(array)) SWIG_fail;
@@ -948,7 +1038,7 @@
@@ -946,7 +1035,7 @@
(PyArrayObject* array=NULL, int is_new_object=0)
{
npy_intp size[3] = { -1, -1, -1 };
@ -334,7 +268,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
&is_new_object);
if (!array || !require_dimensions(array, 3) ||
!require_size(array, size, 3) || !require_fortran(array)) SWIG_fail;
@@ -1291,7 +1381,7 @@
@@ -1289,7 +1378,7 @@
npy_intp dims[1];
if (!PyInt_Check($input))
{
@ -343,7 +277,7 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
PyErr_Format(PyExc_TypeError,
"Int dimension expected. '%s' given.",
typestring);
@@ -1319,7 +1409,7 @@
@@ -1317,7 +1406,7 @@
npy_intp dims[1];
if (!PyInt_Check($input))
{
@ -352,9 +286,9 @@ diff -up mathgl-2.4.2/lang/numpy.i.lang mathgl-2.4.2/lang/numpy.i
PyErr_Format(PyExc_TypeError,
"Int dimension expected. '%s' given.",
typestring);
diff -up mathgl-2.4.2/lang/python3/CMakeLists.txt.lang mathgl-2.4.2/lang/python3/CMakeLists.txt
--- mathgl-2.4.2/lang/python3/CMakeLists.txt.lang 2018-11-07 21:45:40.441388976 -0700
+++ mathgl-2.4.2/lang/python3/CMakeLists.txt 2018-11-07 21:45:40.503389601 -0700
diff -up mathgl-8.0.1/lang/python3/CMakeLists.txt.lang mathgl-8.0.1/lang/python3/CMakeLists.txt
--- mathgl-8.0.1/lang/python3/CMakeLists.txt.lang 2022-10-05 20:17:12.061703367 -0600
+++ mathgl-8.0.1/lang/python3/CMakeLists.txt 2022-10-05 20:17:12.153704063 -0600
@@ -0,0 +1,75 @@
+set(src_imp_dep
+../../include/mgl2/type.h

25
mathgl-libharu2.4.patch Normal file
View File

@ -0,0 +1,25 @@
diff -up mathgl-8.0.1/src/prc.cpp.libharu2.4 mathgl-8.0.1/src/prc.cpp
--- mathgl-8.0.1/src/prc.cpp.libharu2.4 2022-01-11 13:48:53.000000000 -0700
+++ mathgl-8.0.1/src/prc.cpp 2022-10-05 21:10:18.640050969 -0600
@@ -36,6 +36,7 @@
#include <hpdf.h>
#include <hpdf_u3d.h>
#include <hpdf_annotation.h>
+#include <hpdf_version.h>
#endif // MGL_HAVE_PDF
@@ -959,7 +960,12 @@ void MGL_EXPORT mgl_write_prc(HMGL gr, c
HPDF_U3D_SetDefault3DView(u3d, "DefaultView");
// Create annotation
- annot = HPDF_Page_Create3DAnnot (page, rect, u3d );
+ annot
+#if HPDF_VERSION_ID >= 20400
+ = HPDF_Page_Create3DAnnot (page, rect, HPDF_FALSE, HPDF_FALSE, u3d, NULL);
+#else
+ = HPDF_Page_Create3DAnnot (page, rect, u3d );
+#endif
// Enable toolbar
HPDF_Dict action = (HPDF_Dict)HPDF_Dict_GetItem (annot, "3DA", HPDF_OCLASS_DICT);

View File

@ -1,7 +1,7 @@
diff -urp mathgl-2.4.1/lang/CMakeLists.txt mathgl-2.4.1-nooctaveinstall/lang/CMakeLists.txt
--- mathgl-2.4.1/lang/CMakeLists.txt 2017-12-05 11:57:45.607214992 +0700
+++ mathgl-2.4.1-nooctaveinstall/lang/CMakeLists.txt 2017-12-05 11:59:48.869607674 +0700
@@ -84,11 +84,6 @@ message(STATUS "${oct_prog} ${oct_host}
diff -up mathgl-8.0.1/lang/CMakeLists.txt.nooctaveinstall mathgl-8.0.1/lang/CMakeLists.txt
--- mathgl-8.0.1/lang/CMakeLists.txt.nooctaveinstall 2022-10-05 20:51:43.595636043 -0600
+++ mathgl-8.0.1/lang/CMakeLists.txt 2022-10-05 20:52:22.411935656 -0600
@@ -138,11 +138,6 @@ message(STATUS "${oct_prog} ${oct_host}
add_custom_target(mgl_octave_module ALL DEPENDS mathgl.tar.gz)
install(FILES ${CMAKE_BINARY_DIR}/lang/mathgl.tar.gz DESTINATION ${MGL_DATA_PATH})
@ -12,4 +12,4 @@ diff -urp mathgl-2.4.1/lang/CMakeLists.txt mathgl-2.4.1-nooctaveinstall/lang/CMa
- endif(enable-octave-install)
set(mgl_clean_files ${mgl_clean_files} mathgl)
endif(enable-octave)
set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES "${mgl_clean_files}")

View File

@ -18,8 +18,8 @@
Name: mathgl
Version: 2.4.4
Release: 18%{?dist}
Version: 8.0.1
Release: 1%{?dist}
Summary: Cross-platform library for making high-quality scientific graphics
Summary(de): Plattformübergreifende Bibliothek für hochwertige wissenschaftliche Graphiken
Summary(ru): Библиотека для осуществления высококачественной визуализации данных
@ -37,13 +37,13 @@ Patch1: mathgl-2.4.1-fltk-skip-fluid.patch
Patch2: mathgl-2.4.1-no_hdf4-and-hdf5-simultaneously.patch
# Let macros to decide how to install octave module
Patch3: mathgl-2.4.1-nooctaveinstall.patch
Patch3: mathgl-nooctaveinstall.patch
# There is no easy way to disable ONLY octave. Have to cut it from CmakeList.txt
Patch4: mathgl-2.4.1-nooctave.patch
# Add python3 support
Patch5: mathgl-2.4.2-lang.patch
Patch5: mathgl-lang.patch
# Fix convertions
Patch6: mathgl-2.4.1-gcc7.patch
@ -58,6 +58,9 @@ Patch8: mathgl-freeglut.patch
# between different archs (or not if you are lucky. I'm not.)
Patch9: mathgl-2.4.2.1-norebuild_l10n.patch
# https://sourceforge.net/p/mathgl/bugs/48/
# Support for libharu 2.4
Patch10: mathgl-libharu2.4.patch
Requires: %{name}-common = %{version}-%{release}
@ -72,7 +75,6 @@ BuildRequires: perl(Storable)
BuildRequires: freeglut-devel hdf5-devel libjpeg-devel libtiff-devel
BuildRequires: fltk-devel
BuildRequires: qt5-qtbase-devel qt5-qtwebkit-devel
BuildRequires: qt4-devel qt4-webkit-devel
BuildRequires: wxGTK-devel giflib-devel libtool-ltdl-devel
BuildRequires: libharu-devel
BuildRequires: swig lua-devel
@ -255,24 +257,12 @@ Requires: zlib-devel%{?_isa}
%{summary}.
%endif
%package qt4
Summary: Qt4 widgets of %{name} library
Requires: %{name} = %{version}-%{release}
%description qt4
%{summary}.
%package qt4-devel
Summary: Devel files for qt4 widgets of %{name} library
Requires: %{name}-devel = %{version}-%{release}
%description qt4-devel
%{summary}.
%package qt5
Summary: Qt5 widgets of %{name} library
Requires: %{name} = %{version}-%{release}
Obsoletes: %{name}-qt < 2.4
Provides: %{name}-qt = %{version}-%{release}
Obsoletes: %{name}-qt4 < 8.0
%description qt5
%{summary}.
@ -281,6 +271,8 @@ Obsoletes: %{name}-qt < 2.4
Summary: Devel files for qt5 widgets of %{name} library
Requires: %{name}-devel = %{version}-%{release}
Obsoletes: %{name}-qt-devel < 2.4
Provides: %{name}-qt-devel = %{version}-%{release}
Obsoletes: %{name}-qt4-devel < 8.0
Requires: qt5-qtbase-devel
%description qt5-devel
@ -324,8 +316,8 @@ Requires: wxGTK-devel
rm -rf addons/getopt
# prep for both py2 and py3 build
mkdir lang/python3
touch lang/python3/CMakeLists.txt
#mkdir lang/python3
#touch lang/python3/CMakeLists.txt
#convert EOL encodings, maintaining timestames
for file in AUTHORS ChangeLog.txt README ; do
@ -337,7 +329,7 @@ done
%patch0 -p1 -b .examples
%patch1 -p1 -b .fluid
%patch2 -p1 -b .no-hdf4-and-hdf5-simultaneously
%patch5 -p1 -b .lang
#patch5 -p1 -b .lang
%patch6 -p1 -b .gcc7
%patch7 -p1 -b .no_updatedb
%if 0%{?with_octave}
@ -347,11 +339,12 @@ done
%endif
%patch8 -p0 -b .freeglut
%patch9 -p1 -b .norebuild_l10n
%patch10 -p1 -b .libharu2.4
# Fix hardcoded Python version
sed -i -e 's,3\.[0-9],%{python3_version},g' \
-e 's,cpython-3[0-9],cpython-%{python3_version_nodots},g' \
lang/python3/CMakeLists.txt
#sed -i -e 's,3\.[0-9],%{python3_version},g' \
# -e 's,cpython-3[0-9],cpython-%{python3_version_nodots},g' \
# lang/python3/CMakeLists.txt
# Fix hardcoded paths
sed -i s,/usr/local/share/doc/mathgl/,%{_docdir}/%{name}/, udav/udav_wnd.h
@ -396,6 +389,7 @@ BUILD_MPI="-Denable-mpi=off \
-DMathGL_INSTALL_CMAKE_DIR=%{_libdir}/cmake/mathgl \\\
-DMathGL_INSTALL_LIB_DIR=%{_libdir} \\\
-Denable-all=on \\\
-Denable-qt5asqt=off \\\
$BUILD_MPI \\\
..; \
%{cmake_build}
@ -497,8 +491,6 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/mgllab.desktop
%ldconfig_scriptlets
%ldconfig_scriptlets qt4
%ldconfig_scriptlets qt5
%ldconfig_scriptlets fltk
@ -542,17 +534,13 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/mgllab.desktop
%{_mandir}/man1/mglview.1.gz
%endif
%files qt4
%{_libdir}/libmgl-qt4.so.*
%files qt4-devel
%{_libdir}/libmgl-qt4.so
%files qt5
%{_libdir}/libmgl-qt.so.*
%{_libdir}/libmgl-qt5.so.*
%{_libdir}/libmgl-wnd.so.*
%files qt5-devel
%{_libdir}/libmgl-qt.so
%{_libdir}/libmgl-qt5.so
%{_libdir}/libmgl-wnd.so
@ -632,6 +620,10 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/mgllab.desktop
%endif
%changelog
* Thu Oct 06 2022 Orion Poplawski <orion@nwra.com> - 8.0.1-1
- Update to 8.0.1
- Drop Qt4 support
* Tue Aug 23 2022 Mamoru TASAKA <mtasaka@fedoraproject.org> - 2.4.4-18
- Rebuild for gsl-2.7.1

View File

@ -1 +1 @@
SHA512 (mathgl-2.4.4.tar.gz) = 6955cb3630b4c17ab7eeb7542569a7fba653f592640f30700988abe340ecb17f09f1cbcd3903232797e9debc9f74ba2ea1f76f51935749bc8dec5e05951bb573
SHA512 (mathgl-8.0.1.tar.gz) = 1ff3023f1bbd7bfd84202777a0166a8d4255a020a07f3650b9858929345bc8a2ceea4db155d2c93ba32b762d2304474276290a9edac99fda70fb4b5bc12982c2