Update to 1.10.2.1

Fix DSO link bug (Bug #564982)
This commit is contained in:
mycae 2010-04-14 21:42:09 +00:00
parent 644d3bc0ad
commit b19b43140c
4 changed files with 82 additions and 12 deletions

View File

@ -0,0 +1,34 @@
--- examples/Makefile.am.org 2010-04-14 22:11:30.868130523 +0100
+++ examples/Makefile.am 2010-04-14 22:20:08.230133173 +0100
@@ -8,19 +8,19 @@
if USE_FLTK
bin_PROGRAMS += mgl_fltk_example
mgl_fltk_example_SOURCES = wnd_samples.cpp fltk_example.cpp
-mgl_fltk_example_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la
+mgl_fltk_example_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la $(top_builddir)/mgl/libmgl.la
mgl_fltk_example_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
check_PROGRAMS += test
test_SOURCES = wnd_samples.cpp main.cpp
-test_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la
+test_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la $(top_builddir)/mgl/libmgl.la
test_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
endif
if USE_GLUT
bin_PROGRAMS += mgl_glut_example
mgl_glut_example_SOURCES = wnd_samples.cpp glut_example.cpp
-mgl_glut_example_LDADD = $(top_builddir)/widgets/libmgl-glut.la
+mgl_glut_example_LDADD = $(top_builddir)/widgets/libmgl-glut.la $(top_builddir)/mgl/libmgl.la
endif
if USE_WX
@@ -36,7 +36,7 @@
bin_PROGRAMS += mgl_qt_example
mgl_qt_example_SOURCES = wnd_samples.cpp $(top_builddir)/include/mgl/mgl_qt.moc.cpp $(top_srcdir)/include/mgl/mgl_qt.h qt_example.cpp
-mgl_qt_example_LDADD = $(QT_LIBS) $(top_builddir)/widgets/libmgl-qt.la
+mgl_qt_example_LDADD = $(QT_LIBS) $(top_builddir)/widgets/libmgl-qt.la $(top_builddir)/mgl/libmgl.la
mgl_qt_example_LDFLAGS = $(QT_LDFLAGS)
mgl_qt_example_CPPFLAGS = $(QT_CPPFLAGS) $(AM_CPPFLAGS)
mgl_qt_example_CXXFLAGS = $(QT_CXXFLAGS) $(AM_CXXFLAGS)

View File

@ -0,0 +1,14 @@
--- utils/Makefile.am.orig 2010-04-14 22:08:19.024131927 +0100
+++ utils/Makefile.am 2010-04-14 22:08:40.576140435 +0100
@@ -21,9 +21,10 @@
mgl2svg_SOURCES = mgl2svg.cpp
mgl2svg_LDADD = $(top_builddir)/mgl/libmgl.la
+
if USE_FLTK
mglview_SOURCES = mglview.cpp
-mglview_LDADD = $(top_builddir)/widgets/libmgl-fltk.la
+mglview_LDADD = $(top_builddir)/widgets/libmgl-fltk.la $(top_builddir)/mgl/libmgl.la
mglview_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
endif

11
mathgl-novfm-fonts.patch Normal file
View File

@ -0,0 +1,11 @@
--- Makefile.am.orig 2010-04-14 22:34:02.671143647 +0100
+++ Makefile.am 2010-04-14 22:34:07.963146109 +0100
@@ -13,7 +13,7 @@
install-data-local: $(doctargets)
mkdir -p $(mgldest)
- cp -r $(top_srcdir)/fonts/*.vfm $(mgldest)
+# cp -r $(top_srcdir)/fonts/*.vfm $(mgldest)
uninstall-local:
rm -rf $(mgldest)

View File

@ -1,7 +1,7 @@
%{!?octave_api:%global octave_api %(octave-config -p API_VERSION || echo 0)}
Name: mathgl
Version: 1.10
Release: 2%{?dist}.1
Version: 1.10.2.1
Release: 1%{?dist}
Summary: Cross-platform library for making high-quality scientific graphics
Summary(ru): MathGL - это библиотека для осуществления высококачественной визуализации данных
License: GPLv2+
@ -13,6 +13,11 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tgz
Patch0: %{name}-info.patch
#Remove empty libmgl-wx from compilation
Patch1: %{name}-no-mglwx.patch
#Fix DSO linking in mglview util & examples (linker flags) (2 and 3 reseectively)
Patch2: %{name}-mglview-ldflags.patch
Patch3: %{name}-examples-ldflags.patch
#Remove missing file from install.
Patch4: %{name}-novfm-fonts.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -24,7 +29,7 @@ BuildRequires: swig
BuildRequires: freeglut-devel hdf5-devel libjpeg-devel libtiff-devel fltk-devel qt4-devel
BuildRequires: wxGTK-devel giflib-devel octave-devel
#For autoreconf (required for patch1, libtool)
#For autoreconf (required for patches, libtool)
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
@ -69,6 +74,7 @@ package.
%prep
%setup -q
#convert EOL encodings, maintaining timestames
for file in AUTHORS ChangeLog.txt README COPYRIGHT; do
sed 's/\r//' $file > $file.new && \
@ -78,6 +84,9 @@ done
%patch0
%patch1
%patch2
%patch3
%patch4
autoreconf
@ -118,7 +127,7 @@ tar -zxf $RPM_BUILD_ROOT/%{_datadir}/%{name}/octave/%{name}.tar.gz
rm $RPM_BUILD_ROOT/%{_datadir}/%{name}/octave/%{name}.tar.gz
#Copy the .oct file and supporting files to octave packages dir
mkdir -p $RPM_BUILD_ROOT/%{_prefix}/libexec/octave/packages/%{name}-1.10.0/
mkdir -p $RPM_BUILD_ROOT/%{_prefix}/libexec/octave/packages/%{name}-1.10.1/
#Remove empty INDEX file
rm %{name}/INDEX
@ -127,16 +136,16 @@ echo "pkg load mathgl" > %{name}/PKG_ADD
echo "mathgl;" >> %{name}/PKG_ADD
#fix wrong version number in description
sed -i 's/1.9/1.10/' %{name}/DESCRIPTION
sed -i 's/1.9/1.10.1/' %{name}/DESCRIPTION
#We cannot use version macro with octave package search,
# as pkg.m assumes a x.y.z format for packages. Failing
# to do this renders the plugin inoperable
cp -pR %{name}/inst/* $RPM_BUILD_ROOT/%{_prefix}/libexec/octave/packages/%{name}-1.10.0/
cp -pR %{name}/inst/* $RPM_BUILD_ROOT/%{_prefix}/libexec/octave/packages/%{name}-1.10.1/
#packinfo dir is required, or octave will not find the dir in recursive search
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/octave/packages/%{name}-1.10.0/packinfo
cp -p %{name}/[A-Z]* $RPM_BUILD_ROOT/%{_datadir}/octave/packages/%{name}-1.10.0/packinfo
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/octave/packages/%{name}-1.10.1/packinfo
cp -p %{name}/[A-Z]* $RPM_BUILD_ROOT/%{_datadir}/octave/packages/%{name}-1.10.1/packinfo
popd
@ -195,8 +204,8 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so.*
%{_bindir}/mgl*
%{_datadir}/%{name}/
%{_prefix}/libexec/octave/packages/%{name}-1.10.0/
%{_datadir}/octave/packages/%{name}-1.10.0/
%{_prefix}/libexec/octave/packages/%{name}-1.10.1/
%{_datadir}/octave/packages/%{name}-1.10.1/
%{_infodir}/%{name}.*.gz
%{_infodir}/%{name}_ru.*.gz
@ -211,8 +220,10 @@ rm -rf $RPM_BUILD_ROOT
%doc texinfo/docs/*
%changelog
* Sat Jan 02 2010 <mycae(a!t)yahoo.com> - 1.10-2.1
- Import new tgz file into cvs
* Wed Apr 14 2010 <mycae(a!t)yahoo.com> - 1.10.2.1-1
- Update to 1.10.2.1
- Fix linker error due to DSO change (Bug #564982)
* Sat Jan 02 2010 <mycae(a!t)yahoo.com> - 1.10-2
- Fix octave interface to load on startup
- Fix texinfo insatll