Update to 2.3.4
This commit is contained in:
parent
1c9b1da854
commit
987f6cda30
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ mathgl-1.10.2.1.tgz
|
||||
/mathgl-2.2.1.tar.gz
|
||||
/mathgl-2.3.tar.gz
|
||||
/mathgl-2.3.3.tar.gz
|
||||
/mathgl-2.3.4.tar.gz
|
||||
|
@ -1,45 +0,0 @@
|
||||
--- examples/CMakeLists.txt 2015-11-24 12:19:29.605547590 +0600
|
||||
+++ examples/CMakeLists.txt 2015-11-24 12:24:58.377140217 +0600
|
||||
@@ -4,22 +4,26 @@ endif(MGL_HAVE_GSL)
|
||||
|
||||
add_executable(mgl_example wnd_samples.cpp full_test.cpp samples.cpp)
|
||||
target_link_libraries(mgl_example mgl)
|
||||
+SET(MGL_INSTALL_EXAMPLES_LIST mgl_example)
|
||||
|
||||
if(MGL_HAVE_FLTK)
|
||||
include_directories(${FLTK_INCLUDE_DIR})
|
||||
add_executable(mgl_fltk_example wnd_samples.cpp fltk_example.cpp)
|
||||
target_link_libraries(mgl_fltk_example mgl-fltk)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_fltk_example)
|
||||
endif(MGL_HAVE_FLTK)
|
||||
|
||||
if(MGL_HAVE_GLUT)
|
||||
add_executable(mgl_glut_example wnd_samples.cpp glut_example.cpp)
|
||||
target_link_libraries(mgl_glut_example mgl-glut)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_glut_example)
|
||||
endif(MGL_HAVE_GLUT)
|
||||
|
||||
if(MGL_HAVE_WX)
|
||||
include(${wxWidgets_USE_FILE})
|
||||
add_executable(mgl_wx_example wnd_samples.cpp wx_example.cpp)
|
||||
target_link_libraries(mgl_wx_example mgl-wx)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_wx_example)
|
||||
endif(MGL_HAVE_WX)
|
||||
|
||||
if(enable-qt)
|
||||
@@ -41,6 +45,7 @@ if(enable-qt)
|
||||
target_link_libraries(mgl_qgl_example mgl)
|
||||
target_link_libraries(mgl_qgl_example ${QT_LIBRARIES})
|
||||
endif(enable-qt5)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_qt_example)
|
||||
|
||||
endif(enable-qt)
|
||||
|
||||
@@ -50,3 +55,7 @@ if(MGL_HAVE_LTDL)
|
||||
target_link_libraries(mgl_module mgl) # for compatibility with win32
|
||||
endif(MGL_HAVE_LTDL)
|
||||
|
||||
+install(
|
||||
+ TARGETS ${MGL_INSTALL_EXAMPLES_LIST}
|
||||
+ RUNTIME DESTINATION bin
|
||||
+)
|
@ -1,54 +0,0 @@
|
||||
diff -urp mathgl-2.3.3/CMakeLists.txt mathgl-2.3.3-gsl2/CMakeLists.txt
|
||||
--- mathgl-2.3.3/CMakeLists.txt 2015-12-08 21:39:12.774499940 +0600
|
||||
+++ mathgl-2.3.3-gsl2/CMakeLists.txt 2015-12-08 21:39:50.534220640 +0600
|
||||
@@ -259,6 +259,16 @@ endif(enable-pthread)
|
||||
|
||||
if(enable-gsl)
|
||||
set(MGL_HAVE_GSL 1)
|
||||
+ FIND_PACKAGE(PkgConfig)
|
||||
+ pkg_check_modules(GSL2 REQUIRED gsl)
|
||||
+ if ( GSL2_FOUND )
|
||||
+ if ( NOT ${GSL2_VERSION} LESS 2.0 )
|
||||
+ SET(ISGSL2 1)
|
||||
+ endif ( NOT ${GSL2_VERSION} LESS 2.0 )
|
||||
+ if ( ${GSL2_VERSION} LESS 1.16 )
|
||||
+ SET(ISOLDGSL 1)
|
||||
+ endif ( ${GSL2_VERSION} LESS 1.16 )
|
||||
+ endif ( GSL2_FOUND )
|
||||
find_library(GSL_LIB gsl)
|
||||
find_library(GSL_CBLAS_LIB gslcblas)
|
||||
find_path(GSL_INCLUDE_DIR gsl/gsl_fft_complex.h)
|
||||
diff -urp mathgl-2.3.3/src/CMakeLists.txt mathgl-2.3.3-gsl2/src/CMakeLists.txt
|
||||
--- mathgl-2.3.3/src/CMakeLists.txt 2015-06-01 13:29:02.000000000 +0600
|
||||
+++ mathgl-2.3.3-gsl2/src/CMakeLists.txt 2015-12-08 21:40:21.154183235 +0600
|
||||
@@ -23,6 +23,12 @@ ${MathGL_BINARY_DIR}/include/mgl2/dllexp
|
||||
)
|
||||
|
||||
add_definitions(-DMGL_SRC)
|
||||
+if(DEFINED ISGSL2)
|
||||
+add_definitions(-DHAVE_GSL_2)
|
||||
+endif(DEFINED ISGSL2)
|
||||
+if(DEFINED ISOLDGSL)
|
||||
+add_definitions(-DGSL_DISABLE_DEPRECATED)
|
||||
+endif(DEFINED ISOLDGSL)
|
||||
|
||||
if(MGL_HAVE_PNG)
|
||||
set(prc_src prc/PRCbitStream.cc prc/PRCdouble.cc prc/oPRCFile.cc prc/writePRC.cc prc.cpp )
|
||||
diff -urp mathgl-2.3.3/src/fit.cpp mathgl-2.3.3-gsl2/src/fit.cpp
|
||||
--- mathgl-2.3.3/src/fit.cpp 2015-06-01 13:29:02.000000000 +0600
|
||||
+++ mathgl-2.3.3-gsl2/src/fit.cpp 2015-12-08 21:41:24.987020578 +0600
|
||||
@@ -193,7 +193,14 @@ mreal MGL_NO_EXPORT mgl_fit_base(mglFitD
|
||||
}
|
||||
while ( status == GSL_CONTINUE && iter < 500 );
|
||||
gsl_matrix *covar = gsl_matrix_alloc(m, m);
|
||||
+#ifdef HAVE_GSL_2
|
||||
+ gsl_matrix *J = gsl_matrix_alloc(s->fdf->n, s->fdf->p);
|
||||
+ gsl_multifit_fdfsolver_jac(s, J);
|
||||
+ gsl_multifit_covar (J, 0.0, covar);
|
||||
+ gsl_matrix_free (J);
|
||||
+#else
|
||||
gsl_multifit_covar (s->J, 0.0, covar );
|
||||
+#endif
|
||||
mglFitCovar.Set(covar);
|
||||
mreal res = gsl_blas_dnrm2(s->f);
|
||||
for(i=0;i<m;i++) ini[i] = gsl_vector_get(s->x, i);
|
@ -1,9 +0,0 @@
|
||||
--- json/Backend.hpp 2015-11-24 12:34:41.587916006 +0600
|
||||
+++ json/Backend.hpp 2015-11-24 12:37:37.116832634 +0600
|
||||
@@ -1,5 +1,6 @@
|
||||
#pragma once
|
||||
|
||||
+#include <QObject>
|
||||
#include <QStringList>
|
||||
|
||||
class Backend : public QObject
|
@ -1,15 +0,0 @@
|
||||
--- udav/CMakeLists.txt 2015-11-24 12:33:30.016396488 +0600
|
||||
+++ udav/CMakeLists.txt 2015-11-24 12:35:44.813724765 +0600
|
||||
@@ -40,10 +40,10 @@ endif(enable-qt5)
|
||||
add_executable(udav ${udav_src} ${udav_moc_src} ${udav_rc_src})
|
||||
#set_target_properties(udav PROPERTIES COMPILE_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
|
||||
if(enable-qt5)
|
||||
- target_link_libraries(udav mgl-qt5)
|
||||
+ target_link_libraries(udav mgl-qt5 X11)
|
||||
qt5_use_modules(udav Core Widgets Gui PrintSupport)
|
||||
else(enable-qt5)
|
||||
- target_link_libraries(udav mgl-qt4)
|
||||
+ target_link_libraries(udav mgl-qt4 X11)
|
||||
target_link_libraries(udav ${QT_LIBRARIES})
|
||||
endif(enable-qt5)
|
||||
|
39
mathgl.spec
39
mathgl.spec
@ -18,8 +18,8 @@
|
||||
|
||||
|
||||
Name: mathgl
|
||||
Version: 2.3.3
|
||||
Release: 10%{?dist}
|
||||
Version: 2.3.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross-platform library for making high-quality scientific graphics
|
||||
Summary(de): Plattformübergreifende Bibliothek für hochwertige wissenschaftliche Graphiken
|
||||
Summary(ru): Библиотека для осуществления высококачественной визуализации данных
|
||||
@ -32,7 +32,7 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.g
|
||||
Patch0: mathgl-2.3.3-no-hdf4-and-hdf5-simultaneously.patch
|
||||
|
||||
# Install binaries for generation examples of illustrations
|
||||
Patch1: mathgl-2.3.3-examples.patch
|
||||
Patch1: mathgl-2.3.4-examples.patch
|
||||
|
||||
# There is no easy way to disable ONLY octave. Have to cut it from CmakeList.txt
|
||||
Patch2: mathgl-2.3.3-no_octave.patch
|
||||
@ -44,19 +44,10 @@ Patch3: mathgl-2.3.3-fltk-skip-fluid.patch
|
||||
Patch4: mathgl-2.3.3-no_qt4.patch
|
||||
|
||||
# Fix linking with libX11
|
||||
Patch5: mathgl-2.3.3-x11.patch
|
||||
|
||||
# Add missing includes
|
||||
Patch6: mathgl-2.3.3-includes.patch
|
||||
Patch5: mathgl-2.3.4-x11.patch
|
||||
|
||||
# Let macros to decide how to install octave module
|
||||
Patch7: mathgl-2.3.3-nooctaveinstall.patch
|
||||
|
||||
# Add support for GSL v.2 and above. Sent to upstream
|
||||
Patch50: mathgl-2.3.3-gsl2.patch
|
||||
|
||||
# On ARM "char" must be explicitly "signed char" for getopt(). Sent to upstream
|
||||
Patch51: mathgl-2.3.3-signed_char.patch
|
||||
Patch6: mathgl-2.3.3-nooctaveinstall.patch
|
||||
|
||||
Requires: %{name}-common = %{version}-%{release}
|
||||
|
||||
@ -148,8 +139,9 @@ Group: Applications/Engineering
|
||||
Requires: %{name}-qt = %{version}-%{release}
|
||||
|
||||
%description mglview
|
||||
mglview reads MGL scripts from scriptfile to produce plots of specified
|
||||
functions or data. The program will create a GUI window showing the script result.
|
||||
mglview reads MGL scripts from scriptfile to produce plots of
|
||||
specified functions or data. The program will create a GUI window
|
||||
showing the script result.
|
||||
|
||||
%package -n python-mathgl
|
||||
Summary: Python module for MathGL
|
||||
@ -305,19 +297,16 @@ for file in AUTHORS ChangeLog.txt README ; do
|
||||
mv $file.new $file
|
||||
done
|
||||
|
||||
%patch50 -p1 -b .gsl2
|
||||
%patch51 -p1 -b .signed_char
|
||||
%patch0 -b .no-hdf4-and-hdf5-simultaneously
|
||||
%patch1 -b .examples
|
||||
%patch1 -p1 -b .examples
|
||||
%if 0%{?with_octave}
|
||||
%patch7 -b .nooctaveinstall
|
||||
%patch6 -b .nooctaveinstall
|
||||
%else
|
||||
%patch2 -b .no_octave
|
||||
%endif
|
||||
%patch3 -b .fluid
|
||||
%patch4 -b .no_qt4
|
||||
%patch5 -b .qt5
|
||||
%patch6 -b .includes
|
||||
%patch5 -b .x11
|
||||
|
||||
# Fix hardcoded paths
|
||||
sed -i s,/usr/local/share/doc/mathgl/,%{_docdir}/%{name}/, udav/udav_wnd.h
|
||||
@ -595,6 +584,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 15 2016 Dmitrij S. Kryzhevich <kryzhev@ispms.ru> - 2.3.4-1
|
||||
- Drop patches: mathgl-2.3.3-includes.patch, mathgl-2.3.3-signed_char.patch,
|
||||
mathgl-2.3.3-gsl2.patch. Emplemented in upstream.
|
||||
- Update *-examples.patch and *-x11.patch.
|
||||
- Update to new 2.3.4.
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.3-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user