2.4.4, new freeglut.

This commit is contained in:
Gwyn Ciesla 2019-10-04 07:40:49 -05:00
parent 8c048f3b40
commit 889ec31627
4 changed files with 57 additions and 5 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@ mathgl-1.10.2.1.tgz
/mathgl-2.3.5.1.tar.gz
/mathgl-2.4.1.tar.gz
/mathgl-2.4.2.1.tar.gz
/mathgl-2.4.4.tar.gz

43
mathgl-freeglut.patch Normal file
View File

@ -0,0 +1,43 @@
--- CMakeLists.txt~ 2019-09-26 14:18:04.000000000 -0500
+++ CMakeLists.txt 2019-09-26 14:18:34.476407791 -0500
@@ -581,9 +581,9 @@
message(SEND_ERROR "You have to enable OpenGL if you plan to use GLUT.")
endif(NOT MGL_HAVE_OPENGL)
include(FindGLUT)
- if(NOT GLUT_FOUND)
- message(SEND_ERROR "Couldn't find GLUT library.")
- endif(NOT GLUT_FOUND)
+# if(NOT GLUT_FOUND)
+# message(SEND_ERROR "Couldn't find GLUT library.")
+# endif(NOT GLUT_FOUND)
else(enable-glut)
set(MGL_HAVE_GLUT 0)
endif(enable-glut)
--- widgets/glut.cpp~ 2019-07-08 13:56:57.000000000 -0500
+++ widgets/glut.cpp 2019-09-26 14:24:21.070662407 -0500
@@ -30,7 +30,7 @@
#include "glut.h"
#else
#include <GL/gl.h>
- #include <GL/glut.h>
+ #include <GL/freeglut.h>
#endif
#endif
--- widgets/CMakeLists.txt~ 2019-07-08 13:56:57.000000000 -0500
+++ widgets/CMakeLists.txt 2019-09-26 14:28:13.770162047 -0500
@@ -14,10 +14,10 @@
if(MGL_HAVE_GLUT)
mgl_add_lib(glut glut.cpp ../include/mgl2/glut.h)
- target_include_directories(mgl-glut SYSTEM PUBLIC ${GLUT_INCLUDE_DIR})
- target_include_directories(mgl-glut-static SYSTEM PUBLIC ${GLUT_INCLUDE_DIR})
- target_link_libraries(mgl-glut mgl ${GLUT_LIBRARIES} ${OPENGL_LIBRARIES})
- target_link_libraries(mgl-glut-static mgl-static ${GLUT_LIBRARIES} ${OPENGL_LIBRARIES})
+ target_include_directories(mgl-glut SYSTEM PUBLIC ${FreeGLUT_INCLUDE_DIR})
+ target_include_directories(mgl-glut-static SYSTEM PUBLIC ${FreeGLUT_INCLUDE_DIR})
+ target_link_libraries(mgl-glut mgl ${FreeGLUT_LIBRARIES} ${OPENGL_LIBRARIES} -lglut)
+ target_link_libraries(mgl-glut-static mgl-static ${FreeGLUT_LIBRARIES} ${OPENGL_LIBRARIES} -lglut)
endif(MGL_HAVE_GLUT)
if(MGL_HAVE_WX)

View File

@ -18,8 +18,8 @@
Name: mathgl
Version: 2.4.2.1
Release: 12%{?dist}
Version: 2.4.4
Release: 1%{?dist}
Summary: Cross-platform library for making high-quality scientific graphics
Summary(de): Plattformübergreifende Bibliothek für hochwertige wissenschaftliche Graphiken
Summary(ru): Библиотека для осуществления высококачественной визуализации данных
@ -51,6 +51,8 @@ Patch6: mathgl-2.4.1-gcc7.patch
# Disable uppdate-{destop,mine}-database during install process
Patch7: mathgl-2.4.1-no_updatedb.patch
Patch8: mathgl-freeglut.patch
Requires: %{name}-common = %{version}-%{release}
# mandatory packages
@ -336,6 +338,7 @@ done
%else
%patch4 -p1 -b .no_octave
%endif
%patch8 -p0 -b .freeglut
# Fix hardcoded Python version
sed -i -e 's,3\.[0-9],%{python3_version},g' \
@ -383,7 +386,7 @@ BUILD_MPI="-Denable-mpi=off \
%define buildcommon() \
mkdir -p %{_target_platform}_$MPI_COMPILER_NAME; \
pushd %{_target_platform}_$MPI_COMPILER_NAME; \
%cmake3 \\\
%cmake \\\
-DMathGL_INSTALL_CMAKE_DIR=%{_libdir}/cmake/mathgl \\\
-DMathGL_INSTALL_LIB_DIR=%{_libdir} \\\
-Denable-all=on \\\
@ -462,7 +465,7 @@ rm %{buildroot}/%{_libdir}/*.a
# Remove the binary mgl.cgi. Im not convinced about it (eg mem leak in main), and that its really needed
# The same with man file for it
rm %{buildroot}/%{_datadir}/mathgl/mgl.cgi
rm %{buildroot}/%{_prefix}/lib/cgi-bin/mgl.cgi
%if 0%{?with_doc}
rm %{buildroot}/%{_mandir}/man1/mgl.cgi.1*
@ -505,6 +508,7 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/mgllab.desktop
%doc AUTHORS ChangeLog.txt README COPYING README_V2
%{_libdir}/libmgl.so.*
%{_bindir}/mglconv
%{_bindir}/mgltask
%exclude %{_bindir}/mgl_*example
%if 0%{?with_doc}
%{_mandir}/man1/mglconv.1.gz
@ -514,6 +518,7 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/mgllab.desktop
%{_libdir}/libmgl.so
%{_includedir}/mgl2/
%{_libdir}/cmake/mathgl/
%{_libdir}/cmake/mathgl2/
%files mgllab
%{_bindir}/mgllab
@ -615,6 +620,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/mgllab.desktop
%endif
%changelog
* Fri Oct 04 2019 Gwyn Ciesla <gwync@protonmail.com> - 2.4.4-1
- 2.4.4, Rebuilt for new freeglut
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 2.4.2.1-12
- Rebuilt for Python 3.8.0rc1 (#1748018)

View File

@ -1 +1 @@
SHA512 (mathgl-2.4.2.1.tar.gz) = bc8c38af0a2e0e09666a2488078c2ed3caee13437fc44e9edccfeecb6e486c55af9ad5069ddf53213bd3592ceea823942b6fb56ad47f68c7c0628f2d31316247
SHA512 (mathgl-2.4.4.tar.gz) = 6955cb3630b4c17ab7eeb7542569a7fba653f592640f30700988abe340ecb17f09f1cbcd3903232797e9debc9f74ba2ea1f76f51935749bc8dec5e05951bb573