Update to 2.3.4. Readd modified patches
This commit is contained in:
parent
987f6cda30
commit
6b308cbc81
48
mathgl-2.3.4-examples.patch
Normal file
48
mathgl-2.3.4-examples.patch
Normal file
@ -0,0 +1,48 @@
|
||||
diff -urp mathgl-2.3.4/examples/CMakeLists.txt mathgl-2.3.4-examples/examples/CMakeLists.txt
|
||||
--- mathgl-2.3.4/examples/CMakeLists.txt 2016-02-14 01:03:50.000000000 +0600
|
||||
+++ mathgl-2.3.4-examples/examples/CMakeLists.txt 2016-02-16 10:32:34.276636812 +0600
|
||||
@@ -1,6 +1,7 @@
|
||||
if(MGL_HAVE_GSL)
|
||||
include_directories(${GSL_INCLUDE_DIR})
|
||||
endif(MGL_HAVE_GSL)
|
||||
+SET(MGL_INSTALL_EXAMPLES_LIST mgl_example)
|
||||
|
||||
add_executable(mgl_example wnd_samples.cpp full_test.cpp samples.cpp)
|
||||
target_link_libraries(mgl_example mgl)
|
||||
@@ -9,17 +10,20 @@ if(MGL_HAVE_FLTK)
|
||||
include_directories(${FLTK_INCLUDE_DIR})
|
||||
add_executable(mgl_fltk_example wnd_samples.cpp fltk_example.cpp)
|
||||
target_link_libraries(mgl_fltk_example mgl-fltk)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_fltk_example)
|
||||
endif(MGL_HAVE_FLTK)
|
||||
|
||||
if(MGL_HAVE_GLUT)
|
||||
add_executable(mgl_glut_example wnd_samples.cpp glut_example.cpp)
|
||||
target_link_libraries(mgl_glut_example mgl-glut)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_glut_example)
|
||||
endif(MGL_HAVE_GLUT)
|
||||
|
||||
if(MGL_HAVE_WX)
|
||||
include(${wxWidgets_USE_FILE})
|
||||
add_executable(mgl_wx_example wnd_samples.cpp wx_example.cpp)
|
||||
target_link_libraries(mgl_wx_example mgl-wx)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_wx_example)
|
||||
endif(MGL_HAVE_WX)
|
||||
|
||||
if(QT_ENABLED)
|
||||
@@ -39,6 +43,7 @@ if(QT_ENABLED)
|
||||
target_link_libraries(mgl_qgl_example mgl)
|
||||
qt4_use_modules(mgl_qgl_example ${MGL_QT4_LIBS})
|
||||
endif(enable-qt5)
|
||||
+ SET(MGL_INSTALL_EXAMPLES_LIST ${MGL_INSTALL_EXAMPLES_LIST} mgl_qt_example mgl_qgl_example)
|
||||
|
||||
endif(QT_ENABLED)
|
||||
|
||||
@@ -48,3 +53,7 @@ if(MGL_HAVE_LTDL)
|
||||
target_link_libraries(mgl_module mgl) # for compatibility with win32
|
||||
endif(MGL_HAVE_LTDL)
|
||||
|
||||
+install(
|
||||
+ TARGETS ${MGL_INSTALL_EXAMPLES_LIST}
|
||||
+ RUNTIME DESTINATION bin
|
||||
+)
|
15
mathgl-2.3.4-x11.patch
Normal file
15
mathgl-2.3.4-x11.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- udav/CMakeLists.txt 2016-02-15 16:59:57.763709611 +0600
|
||||
+++ udav/CMakeLists.txt 2016-02-16 10:57:58.345497232 +0600
|
||||
@@ -38,10 +38,10 @@ endif(enable-qt5)
|
||||
add_executable(udav ${udav_src} ${udav_moc_hdr} ${udav_rc_src})
|
||||
#set_target_properties(udav PROPERTIES COMPILE_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
|
||||
if(enable-qt5)
|
||||
- target_link_libraries(udav mgl-qt5)
|
||||
+ target_link_libraries(udav mgl-qt5 X11)
|
||||
qt5_use_modules(udav ${MGL_QT5_LIBS})
|
||||
else(enable-qt5)
|
||||
- target_link_libraries(udav mgl-qt4)
|
||||
+ target_link_libraries(udav mgl-qt4 X11)
|
||||
qt4_use_modules(udav ${MGL_QT4_LIBS})
|
||||
endif(enable-qt5)
|
||||
|
Loading…
x
Reference in New Issue
Block a user