update to 1.10.1 release

This commit is contained in:
raveit65 2015-07-19 12:59:42 +02:00
parent 6a4ebf712b
commit 4ec2db206a
6 changed files with 43 additions and 152 deletions

1
.gitignore vendored
View File

@ -15,3 +15,4 @@
/mate-settings-daemon-1.8.1.tar.xz
/mate-settings-daemon-1.8.2.tar.xz
/mate-settings-daemon-1.8.3.tar.xz
/mate-settings-daemon-1.10.1.tar.xz

View File

@ -1,26 +1,36 @@
# Conditional for release and snapshot builds. Uncomment for release-builds.
%global rel_build 1
# This is needed, because src-url contains branched part of versioning-scheme.
%global branch 1.10
# Settings used for build from snapshots.
%{!?rel_build:%global commit 83fe1f587f5c6328b10a899a880275d79bf88921}
%{!?rel_build:%global commit_date 20141215}
%{!?rel_build:%global shortcommit %(c=%{commit};echo ${c:0:7})}
%{!?rel_build:%global git_ver git%{commit_date}-%{shortcommit}}
%{!?rel_build:%global git_rel .git%{commit_date}.%{shortcommit}}
%{!?rel_build:%global git_tar %{name}-%{version}-%{git_ver}.tar.xz}
Name: mate-settings-daemon
Version: 1.8.3
Version: %{branch}.1
%if 0%{?rel_build}
Release: 1%{?dist}
%else
Release: 0.1%{?git_rel}%{?dist}
%endif
Summary: MATE Desktop settings daemon
License: GPLv2+
URL: http://mate-desktop.org
Source0: http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
# for downloading the tarball use 'spectool -g -R mate-settings-daemon.spec'
# Source for release-builds.
%{?rel_build:Source0: http://pub.mate-desktop.org/releases/%{branch}/%{name}-%{version}.tar.xz}
# Source for snapshot-builds.
%{!?rel_build:Source0: http://git.mate-desktop.org/%{name}/snapshot/%{name}-%{commit}.tar.xz#/%{git_tar}}
# fix rhbz (#1140329)
Patch0: mate-settings-daemon_fix-xrdb-plugin-for-rhel.patch
# rhbz (1102581)
# https://github.com/mate-desktop/mate-settings-daemon/pull/91
Patch1: mate-settings-daemon_safer-access-to-list-element-data.patch
# rhbz (#1157698)
# https://github.com/mate-desktop/mate-settings-daemon/pull/99
Patch2: mate-settings-daemon_changed-reaction-to-numlock-state.patch
# https://github.com/mate-desktop/mate-settings-daemon/pull/97
Patch3: mate-settings-daemon_a11y-keyboard-crash.patch
# To generate tarball
# wget http://git.mate-desktop.org/%%{name}/snapshot/%%{name}-{_internal_version}.tar.xz -O %%{name}-%%{version}.git%%{_internal_version}.tar.xz
#Source0: http://raveit65.fedorapeople.org/Mate/git-upstream/%{name}-%{version}.git%{_internal_version}.tar.xz
BuildRequires: dbus-glib-devel
BuildRequires: dconf-devel
@ -61,9 +71,14 @@ under it.
%setup -q
%patch0 -p1 -b .xrdb
%patch1 -p1 -b .safer-access
%patch2 -p1 -b .changed-reaction
%patch3 -p1 -b .a11y-keyboard
%if 0%{?rel_build}
#NOCONFIGURE=1 ./autogen.sh
%else # 0%{?rel_build}
# for snapshots
# needed for git snapshots
NOCONFIGURE=1 ./autogen.sh
%endif # 0%{?rel_build}
%build
%configure \
@ -71,9 +86,9 @@ under it.
--disable-static \
--disable-schemas-compile \
--enable-polkit \
--disable-gstreamer \
--with-x \
--with-nssdb
--with-nssdb \
--with-gtk=2.0
make %{?_smp_mflags} V=1
@ -112,17 +127,19 @@ fi
%dir %{_sysconfdir}/mate-settings-daemon/xrandr
%config %{_sysconfdir}/dbus-1/system.d/org.mate.SettingsDaemon.DateTimeMechanism.conf
%{_sysconfdir}/xdg/autostart/mate-settings-daemon.desktop
%{_sysconfdir}/xrdb/
%{_libdir}/mate-settings-daemon
%{_libexecdir}/mate-settings-daemon
%{_libexecdir}/msd-datetime-mechanism
%{_libexecdir}/msd-locate-pointer
%{_datadir}/mate-control-center/keybindings/50-accessibility.xml
%{_datadir}/dbus-1/services/org.mate.SettingsDaemon.service
%{_datadir}/dbus-1/system-services/org.mate.SettingsDaemon.DateTimeMechanism.service
%{_datadir}/icons/mate/*/*/*
%{_datadir}/mate-settings-daemon
%{_datadir}/glib-2.0/schemas/org.mate.*.xml
%{_datadir}/polkit-1/actions/org.mate.settingsdaemon.datetimemechanism.policy
%{_mandir}/man1/mate-settings-daemon.1.*
%{_mandir}/man1/*
%files devel
%{_includedir}/mate-settings-daemon
@ -130,6 +147,10 @@ fi
%changelog
* Sat Jul 18 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.10.1-1
- update to 1.10.1 release
- remove upstreamed patches
* Wed Mar 11 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.8.3.1
- update to 1.8.3 release
- fix rhbz (#1157698)

View File

@ -1,86 +0,0 @@
diff --git a/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c b/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c
index 72d42ff..675b993 100644
--- a/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c
+++ b/plugins/a11y-keyboard/msd-a11y-preferences-dialog.c
@@ -458,7 +458,7 @@ on_sticky_keys_checkbutton_toggled (GtkToggleButton *button,
static void
on_bounce_keys_checkbutton_toggled (GtkToggleButton *button,
- MsdA11yPreferencesDialog *dialog)
+ MsdA11yPreferencesDialog *dialog)
{
config_set_bounce_keys (dialog, gtk_toggle_button_get_active (button));
}
@@ -649,7 +649,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_sticky_keys_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_sticky_keys (dialog, &is_writable);
ui_set_sticky_keys (dialog, enabled);
if (! is_writable) {
@@ -662,7 +662,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_bounce_keys_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_bounce_keys (dialog, &is_writable);
ui_set_bounce_keys (dialog, enabled);
if (! is_writable) {
@@ -675,7 +675,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_slow_keys_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_slow_keys (dialog, &is_writable);
ui_set_slow_keys (dialog, enabled);
if (! is_writable) {
@@ -688,7 +688,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_high_contrast_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_high_contrast (dialog, &is_writable);
ui_set_high_contrast (dialog, enabled);
if (! is_writable) {
@@ -701,7 +701,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_at_screen_keyboard_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_at_screen_keyboard (dialog, &is_writable);
ui_set_at_screen_keyboard (dialog, enabled);
if (! is_writable) {
@@ -720,7 +720,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_at_screen_reader_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_at_screen_reader (dialog, &is_writable);
ui_set_at_screen_reader (dialog, enabled);
if (! is_writable) {
@@ -739,7 +739,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_at_screen_magnifier_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_at_screen_magnifier (dialog, &is_writable);
ui_set_at_screen_magnifier (dialog, enabled);
if (! is_writable) {
@@ -758,7 +758,7 @@ setup_dialog (MsdA11yPreferencesDialog *dialog,
g_signal_connect (widget,
"toggled",
G_CALLBACK (on_large_print_checkbutton_toggled),
- NULL);
+ dialog);
enabled = config_get_large_print (&is_writable);
ui_set_large_print (dialog, enabled);
if (! is_writable) {

View File

@ -1,31 +0,0 @@
diff --git a/plugins/keyboard/msd-keyboard-manager.c b/plugins/keyboard/msd-keyboard-manager.c
index a4b97e5..8d261b6 100644
--- a/plugins/keyboard/msd-keyboard-manager.c
+++ b/plugins/keyboard/msd-keyboard-manager.c
@@ -267,10 +267,6 @@ apply_settings (GSettings *settings,
bell_volume = (volume_string && !strcmp (volume_string, "on")) ? 50 : 0;
g_free (volume_string);
-#ifdef HAVE_X11_EXTENSIONS_XKB_H
- rnumlock = g_settings_get_boolean (settings, KEY_NUMLOCK_REMEMBER);
-#endif /* HAVE_X11_EXTENSIONS_XKB_H */
-
gdk_error_trap_push ();
if (repeat) {
gboolean rate_set = FALSE;
@@ -306,8 +302,12 @@ apply_settings (GSettings *settings,
&kbdcontrol);
#ifdef HAVE_X11_EXTENSIONS_XKB_H
- if (manager->priv->have_xkb && rnumlock) {
- numlock_set_xkb_state (numlock_get_settings_state (settings));
+ rnumlock = g_settings_get_boolean (settings, KEY_NUMLOCK_REMEMBER);
+
+ if (rnumlock == 0 || key == NULL) {
+ if (manager->priv->have_xkb && rnumlock) {
+ numlock_set_xkb_state (numlock_get_settings_state (settings));
+ }
}
#endif /* HAVE_X11_EXTENSIONS_XKB_H */

View File

@ -1,14 +0,0 @@
diff --git a/plugins/background/msd-background-manager.c b/plugins/background/msd-background-manager.c
index 215be80..5b6a04b 100644
--- a/plugins/background/msd-background-manager.c
+++ b/plugins/background/msd-background-manager.c
@@ -269,7 +269,7 @@ on_screen_size_changed (GdkScreen *screen,
return;
gint scr_num = gdk_screen_get_number (screen);
- gchar *old_size = g_list_nth (manager->priv->scr_sizes, scr_num)->data;
+ gchar *old_size = g_list_nth_data (manager->priv->scr_sizes, scr_num);
gchar *new_size = g_strdup_printf ("%dx%d", gdk_screen_get_width (screen),
gdk_screen_get_height (screen));
if (g_strcmp0 (old_size, new_size) != 0)

View File

@ -1 +1 @@
83b4a0b715abd273569c83d1f5198e93 mate-settings-daemon-1.8.3.tar.xz
8543bb862d370647cd99079c4755eabf mate-settings-daemon-1.10.1.tar.xz