Rebase to 10.1.25
This commit is contained in:
parent
ba432eb69b
commit
e89fd4e189
@ -1,12 +0,0 @@
|
||||
--- mariadb-10.2.7/mysys_ssl/openssl.c 2017-07-10 12:53:28.000000000 +0200
|
||||
+++ mariadb-10.2.7/mysys_ssl/openssl.c_patched 2017-07-13 11:22:30.449704470 +0200
|
||||
@@ -34,7 +34,8 @@ int check_openssl_compatibility()
|
||||
|
||||
static uint testing, alloc_size, alloc_count;
|
||||
|
||||
-static void *coc_malloc(size_t size, const char *, int)
|
||||
+static void *coc_malloc(size_t size, const char *f __attribute__((unused)),
|
||||
+ int l __attribute__((unused)))
|
||||
{
|
||||
if (unlikely(testing))
|
||||
{
|
@ -1,57 +0,0 @@
|
||||
The following problems have been found by Coverity - static analysis tool.
|
||||
|
||||
mysql-5.5.31/plugin/semisync/semisync_master.cc:672:parameter_as_source – Note: This defect has an elevated risk because the source argument is a parameter of the current function.
|
||||
|
||||
mysql-5.5.31/plugin/semisync/semisync_master.cc:661:parameter_as_source – Note: This defect has an elevated risk because the source argument is a parameter of the current function.
|
||||
|
||||
mysql-5.5.31/plugin/semisync/semisync_master.cc:555:parameter_as_source – Note: This defect has an elevated risk because the source argument is a parameter of the current function.
|
||||
|
||||
diff -up mariadb-10.0.21/plugin/semisync/semisync_master.cc.orig mariadb-10.0.21/plugin/semisync/semisync_master.cc
|
||||
--- mariadb-10.0.21/plugin/semisync/semisync_master.cc.orig 2015-08-05 20:11:31.000000000 +0200
|
||||
+++ mariadb-10.0.21/plugin/semisync/semisync_master.cc 2015-08-10 17:22:31.700604043 +0200
|
||||
@@ -553,7 +553,8 @@ int ReplSemiSyncMaster::reportReplyBinlo
|
||||
|
||||
if (need_copy_send_pos)
|
||||
{
|
||||
- strcpy(reply_file_name_, log_file_name);
|
||||
+ strncpy(reply_file_name_, log_file_name, sizeof(reply_file_name_)-1);
|
||||
+ reply_file_name_[sizeof(reply_file_name_)-1] = '\0';
|
||||
reply_file_pos_ = log_file_pos;
|
||||
reply_file_name_inited_ = true;
|
||||
|
||||
@@ -661,7 +662,8 @@ int ReplSemiSyncMaster::commitTrx(const
|
||||
if (cmp <= 0)
|
||||
{
|
||||
/* This thd has a lower position, let's update the minimum info. */
|
||||
- strcpy(wait_file_name_, trx_wait_binlog_name);
|
||||
+ strncpy(wait_file_name_, trx_wait_binlog_name, sizeof(wait_file_name_)-1);
|
||||
+ wait_file_name_[sizeof(wait_file_name_)-1] = '\0';
|
||||
wait_file_pos_ = trx_wait_binlog_pos;
|
||||
|
||||
rpl_semi_sync_master_wait_pos_backtraverse++;
|
||||
@@ -672,7 +674,8 @@ int ReplSemiSyncMaster::commitTrx(const
|
||||
}
|
||||
else
|
||||
{
|
||||
- strcpy(wait_file_name_, trx_wait_binlog_name);
|
||||
+ strncpy(wait_file_name_, trx_wait_binlog_name, sizeof(wait_file_name_)-1);
|
||||
+ wait_file_name_[sizeof(wait_file_name_)-1] = '\0';
|
||||
wait_file_pos_ = trx_wait_binlog_pos;
|
||||
wait_file_name_inited_ = true;
|
||||
|
||||
|
||||
mysql-5.5.31/sql/rpl_handler.cc:306:fixed_size_dest – You might overrun the 512 byte fixed-size string "log_info->log_file" by copying "log_file + dirname_length(log_file)" without checking the length. diff -up mysql-5.5.31/sql/rpl_handler.cc.covscan-stroverflow mysql-5.5.31/sql/rpl_handler.cc
|
||||
|
||||
diff -up mariadb-10.0.21/sql/rpl_handler.cc.orig mariadb-10.0.21/sql/rpl_handler.cc
|
||||
--- mariadb-10.0.21/sql/rpl_handler.cc.orig 2015-08-05 20:11:31.000000000 +0200
|
||||
+++ mariadb-10.0.21/sql/rpl_handler.cc 2015-08-10 17:28:57.093803582 +0200
|
||||
@@ -261,7 +261,8 @@ int Binlog_storage_delegate::after_flush
|
||||
thd->semisync_info= log_info;
|
||||
}
|
||||
|
||||
- strcpy(log_info->log_file, log_file+dirname_length(log_file));
|
||||
+ strncpy(log_info->log_file, log_file+dirname_length(log_file), sizeof(log_info->log_file)-1);
|
||||
+ log_info->log_file[sizeof(log_info->log_file)-1] = '\0';
|
||||
log_info->log_pos = log_pos;
|
||||
|
||||
FOREACH_OBSERVER(ret, after_flush, false,
|
@ -1,10 +1,10 @@
|
||||
--- mariadb-10.1.11.orig/scripts/CMakeLists.txt 2016-01-28 13:12:51.000000000 +0100
|
||||
+++ mariadb-10.1.11/scripts/CMakeLists.txt 2016-02-03 12:46:26.306109293 +0100
|
||||
@@ -320,6 +320,33 @@ ELSE()
|
||||
COMPONENT ${${file}_COMPONENT}
|
||||
diff -up mariadb-10.2.8/scripts/CMakeLists.txt.p7 mariadb-10.2.8/scripts/CMakeLists.txt
|
||||
--- mariadb-10.2.8/scripts/CMakeLists.txt.p7 2017-08-20 13:26:10.640779557 +0200
|
||||
+++ mariadb-10.2.8/scripts/CMakeLists.txt 2017-08-20 13:27:05.774925486 +0200
|
||||
@@ -338,6 +338,33 @@ ELSE()
|
||||
)
|
||||
ENDFOREACH()
|
||||
+
|
||||
|
||||
+ # files for systemd
|
||||
+ SET(SYSTEMD_SCRIPTS
|
||||
+ mysql.tmpfiles.d
|
||||
@ -31,7 +31,7 @@
|
||||
+ "${CMAKE_CURRENT_SOURCE_DIR}" )
|
||||
+ ENDIF()
|
||||
+ ENDFOREACH()
|
||||
+
|
||||
ENDIF()
|
||||
|
||||
# Install libgcc as mylibgcc.a
|
||||
|
||||
|
21
mariadb.spec
21
mariadb.spec
@ -122,11 +122,11 @@
|
||||
# Make long macros shorter
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
%global compatver 10.2
|
||||
%global bugfixver 7
|
||||
%global bugfixver 8
|
||||
|
||||
Name: mariadb
|
||||
Version: %{compatver}.%{bugfixver}
|
||||
Release: 8%{?with_debug:.debug}%{?dist}
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
@ -175,13 +175,8 @@ Patch8: %{pkgnamepatch}-install-db-sharedir.patch
|
||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||
|
||||
# Patches specific for this mysql package
|
||||
# Patch34:
|
||||
# TODO: I should run covscan again
|
||||
Patch34: %{pkgnamepatch}-covscan-stroverflow.patch
|
||||
# Patch37: don't create a test DB: https://jira.mariadb.org/browse/MDEV-12645
|
||||
Patch37: %{pkgnamepatch}-notestdb.patch
|
||||
# Patch only for 10.1.27, resolving FTBFS
|
||||
Patch38: %{pkgnamepatch}-10.2.7.patch
|
||||
|
||||
# Patches for galera
|
||||
Patch40: %{pkgnamepatch}-galera.cnf.patch
|
||||
@ -626,9 +621,7 @@ MariaDB is a community developed branch of MySQL.
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch34 -p1
|
||||
%patch37 -p1
|
||||
%patch38 -p1
|
||||
%patch40 -p1
|
||||
|
||||
# workaround for upstream bug #56342
|
||||
@ -783,9 +776,9 @@ make -f /usr/share/selinux/devel/Makefile %{name}-server-galera.pp
|
||||
make DESTDIR=%{buildroot} install
|
||||
|
||||
# multilib header support
|
||||
for header in mysql/my_config.h mysql/private/config.h; do
|
||||
%multilib_fix_c_header --file %{_includedir}/$header
|
||||
done
|
||||
#for header in mysql/my_config.h mysql/private/config.h; do
|
||||
#%multilib_fix_c_header --file %{_includedir}/$header
|
||||
#done
|
||||
|
||||
ln -s mysql_config.1.gz %{buildroot}%{_mandir}/man1/mariadb_config.1.gz
|
||||
|
||||
@ -1198,6 +1191,7 @@ fi
|
||||
%lang(fr) %{_datadir}/%{pkg_name}/french
|
||||
%lang(de) %{_datadir}/%{pkg_name}/german
|
||||
%lang(el) %{_datadir}/%{pkg_name}/greek
|
||||
%lang(el) %{_datadir}/%{pkg_name}/hindi
|
||||
%lang(hu) %{_datadir}/%{pkg_name}/hungarian
|
||||
%lang(it) %{_datadir}/%{pkg_name}/italian
|
||||
%lang(ja) %{_datadir}/%{pkg_name}/japanese
|
||||
@ -1444,6 +1438,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Aug 20 2017 Honza Horak <hhorak@redhat.com> - 3:10.2.8-1
|
||||
- Rebase to 10.1.25
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3:10.2.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mariadb-10.2.7.tar.gz) = fa595acc0f5c9c62077db000f1721af79628994c08e82b2eb95d265e3c556e80942c487fc1b91299c382becd71f21a0a117ca93d7428752f436ed83683a4f4cd
|
||||
SHA512 (mariadb-10.2.8.tar.gz) = c0527481a99249caef829a3ad2f610f6ebb30ed9af49c56b783695ce4fe83db93021ef0f60efad92750038c8894b957cbb1f2c4ee56fe8d5c15c878c83ba46d1
|
||||
|
Loading…
Reference in New Issue
Block a user