Update to 10.0.18
Conflicts: mariadb-ssltest.patch mariadb.spec
This commit is contained in:
parent
e83c0889de
commit
913badf090
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
|||||||
/mariadb-10.0.15.tar.gz
|
/mariadb-10.0.15.tar.gz
|
||||||
/mariadb-10.0.16.tar.gz
|
/mariadb-10.0.16.tar.gz
|
||||||
/mariadb-10.0.17.tar.gz
|
/mariadb-10.0.17.tar.gz
|
||||||
|
/mariadb-10.0.18.tar.gz
|
||||||
|
@ -1,63 +0,0 @@
|
|||||||
Change the DH key length from 512 to 1024 bits to meet minimum requirements
|
|
||||||
of FIPS 140-2. (In principle we could use the larger size only when FIPS
|
|
||||||
mode is on, but it doesn't seem worth the trouble.)
|
|
||||||
|
|
||||||
The new parameter value was generated using "openssl dhparam -C 1024".
|
|
||||||
|
|
||||||
|
|
||||||
diff -up mariadb-10.0.16/vio/viosslfactories.c.orig mariadb-10.0.16/vio/viosslfactories.c
|
|
||||||
--- mariadb-10.0.16/vio/viosslfactories.c.orig 2015-01-25 16:21:38.000000000 +0100
|
|
||||||
+++ mariadb-10.0.16/vio/viosslfactories.c 2015-02-03 10:48:26.012560285 +0100
|
|
||||||
@@ -20,27 +20,32 @@
|
|
||||||
static my_bool ssl_algorithms_added = FALSE;
|
|
||||||
static my_bool ssl_error_strings_loaded= FALSE;
|
|
||||||
|
|
||||||
-static unsigned char dh512_p[]=
|
|
||||||
+static unsigned char dh1024_p[]=
|
|
||||||
{
|
|
||||||
- 0xDA,0x58,0x3C,0x16,0xD9,0x85,0x22,0x89,0xD0,0xE4,0xAF,0x75,
|
|
||||||
- 0x6F,0x4C,0xCA,0x92,0xDD,0x4B,0xE5,0x33,0xB8,0x04,0xFB,0x0F,
|
|
||||||
- 0xED,0x94,0xEF,0x9C,0x8A,0x44,0x03,0xED,0x57,0x46,0x50,0xD3,
|
|
||||||
- 0x69,0x99,0xDB,0x29,0xD7,0x76,0x27,0x6B,0xA2,0xD3,0xD4,0x12,
|
|
||||||
- 0xE2,0x18,0xF4,0xDD,0x1E,0x08,0x4C,0xF6,0xD8,0x00,0x3E,0x7C,
|
|
||||||
- 0x47,0x74,0xE8,0x33,
|
|
||||||
+ 0xBF,0x5C,0xFA,0xD1,0xDD,0xBB,0xB3,0x0A,0x58,0x29,0x05,0xF5,
|
|
||||||
+ 0x7D,0x64,0xB2,0xE1,0xCE,0xE8,0xE0,0xE1,0x7A,0xB6,0xBC,0x5B,
|
|
||||||
+ 0x21,0x56,0xDF,0x2C,0x82,0x60,0xDC,0x31,0xCA,0x1E,0x02,0xFE,
|
|
||||||
+ 0xC4,0xE7,0x24,0x63,0x31,0xE4,0x67,0x1C,0x0B,0xFF,0x86,0x12,
|
|
||||||
+ 0x0D,0x2E,0xE6,0x35,0x0A,0x07,0x4F,0xE7,0x3F,0xDE,0xFE,0xF0,
|
|
||||||
+ 0x13,0x1C,0xA2,0x2B,0xF4,0xEE,0x2C,0x90,0x10,0x57,0x6B,0x2B,
|
|
||||||
+ 0xB9,0x1E,0x1B,0x47,0xB0,0x25,0xBF,0x45,0x86,0xDA,0x87,0x35,
|
|
||||||
+ 0x2C,0xF5,0x6A,0x41,0xA2,0x57,0xD8,0x16,0x5E,0x82,0x91,0x99,
|
|
||||||
+ 0x33,0xA0,0x8B,0x9D,0x34,0xCE,0x03,0x01,0x80,0x32,0x07,0x3B,
|
|
||||||
+ 0xF2,0x93,0xFC,0x3A,0x25,0xEC,0xB3,0xED,0x5C,0x4E,0x57,0xF2,
|
|
||||||
+ 0x3C,0x2E,0x0D,0xB1,0x59,0xA2,0x08,0x93,
|
|
||||||
};
|
|
||||||
|
|
||||||
-static unsigned char dh512_g[]={
|
|
||||||
+static unsigned char dh1024_g[]={
|
|
||||||
0x02,
|
|
||||||
};
|
|
||||||
|
|
||||||
-static DH *get_dh512(void)
|
|
||||||
+static DH *get_dh1024(void)
|
|
||||||
{
|
|
||||||
DH *dh;
|
|
||||||
if ((dh=DH_new()))
|
|
||||||
{
|
|
||||||
- dh->p=BN_bin2bn(dh512_p,sizeof(dh512_p),NULL);
|
|
||||||
- dh->g=BN_bin2bn(dh512_g,sizeof(dh512_g),NULL);
|
|
||||||
+ dh->p=BN_bin2bn(dh1024_p,sizeof(dh1024_p),NULL);
|
|
||||||
+ dh->g=BN_bin2bn(dh1024_g,sizeof(dh1024_g),NULL);
|
|
||||||
if (! dh->p || ! dh->g)
|
|
||||||
{
|
|
||||||
DH_free(dh);
|
|
||||||
@@ -257,7 +262,7 @@ new_VioSSLFd(const char *key_file, const
|
|
||||||
}
|
|
||||||
|
|
||||||
/* DH stuff */
|
|
||||||
- dh=get_dh512();
|
|
||||||
+ dh=get_dh1024();
|
|
||||||
SSL_CTX_set_tmp_dh(ssl_fd->ssl_context, dh);
|
|
||||||
DH_free(dh);
|
|
||||||
|
|
@ -1,48 +0,0 @@
|
|||||||
Don't test EDH-RSA-DES-CBC-SHA cipher, it seems to be removed from openssl
|
|
||||||
which now makes mariadb/mysql FTBFS because openssl_1 test fails
|
|
||||||
|
|
||||||
Related: #1044565
|
|
||||||
|
|
||||||
|
|
||||||
diff -up mariadb-10.0.16/mysql-test/r/openssl_1.result.testssl mariadb-10.0.16/mysql-test/r/openssl_1.result
|
|
||||||
--- mariadb-10.0.16/mysql-test/r/openssl_1.result.testssl 2015-01-25 16:21:38.000000000 +0100
|
|
||||||
+++ mariadb-10.0.16/mysql-test/r/openssl_1.result 2015-02-10 12:15:06.178207088 +0100
|
|
||||||
@@ -198,8 +198,6 @@ Ssl_cipher DHE-RSA-AES256-SHA
|
|
||||||
Variable_name Value
|
|
||||||
Ssl_cipher EDH-RSA-DES-CBC3-SHA
|
|
||||||
Variable_name Value
|
|
||||||
-Ssl_cipher EDH-RSA-DES-CBC-SHA
|
|
||||||
-Variable_name Value
|
|
||||||
Ssl_cipher RC4-SHA
|
|
||||||
select 'is still running; no cipher request crashed the server' as result from dual;
|
|
||||||
result
|
|
||||||
diff -up mariadb-10.0.16/mysql-test/t/openssl_1.test.testssl mariadb-10.0.16/mysql-test/t/openssl_1.test
|
|
||||||
--- mariadb-10.0.16/mysql-test/t/openssl_1.test.testssl 2015-01-25 16:21:38.000000000 +0100
|
|
||||||
+++ mariadb-10.0.16/mysql-test/t/openssl_1.test 2015-02-10 12:16:49.769911038 +0100
|
|
||||||
@@ -132,7 +132,7 @@ drop table t1;
|
|
||||||
# verification of servers certificate by setting both ca certificate
|
|
||||||
# and ca path to NULL
|
|
||||||
#
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result AES128-GCM-SHA256 DHE-RSA-AES256-SHA
|
|
||||||
--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
|
|
||||||
--echo End of 5.0 tests
|
|
||||||
|
|
||||||
@@ -222,7 +222,7 @@ DROP TABLE t1;
|
|
||||||
# Common ciphers to openssl and yassl
|
|
||||||
--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=DHE-RSA-AES256-SHA
|
|
||||||
--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC3-SHA
|
|
||||||
---exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC-SHA
|
|
||||||
+#--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=EDH-RSA-DES-CBC-SHA
|
|
||||||
--exec $MYSQL --host=localhost -e "SHOW STATUS LIKE 'Ssl_cipher';" --ssl-cipher=RC4-SHA
|
|
||||||
--disable_query_log
|
|
||||||
--disable_result_log
|
|
||||||
@@ -259,7 +259,7 @@ select 'is still running; no cipher requ
|
|
||||||
GRANT SELECT ON test.* TO bug42158@localhost REQUIRE X509;
|
|
||||||
FLUSH PRIVILEGES;
|
|
||||||
connect(con1,localhost,bug42158,,,,,SSL);
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result AES128-GCM-SHA256 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
disconnect con1;
|
|
||||||
connection default;
|
|
11
mariadb.spec
11
mariadb.spec
@ -113,11 +113,11 @@
|
|||||||
# Make long macros shorter
|
# Make long macros shorter
|
||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
%global compatver 10.0
|
%global compatver 10.0
|
||||||
%global bugfixver 17
|
%global bugfixver 18
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: %{compatver}.%{bugfixver}
|
Version: %{compatver}.%{bugfixver}
|
||||||
Release: 4%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
Summary: A community developed branch of MySQL
|
Summary: A community developed branch of MySQL
|
||||||
@ -155,7 +155,6 @@ Patch2: %{pkgnamepatch}-install-test.patch
|
|||||||
Patch3: %{pkgnamepatch}-s390-tsc.patch
|
Patch3: %{pkgnamepatch}-s390-tsc.patch
|
||||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||||
Patch5: %{pkgnamepatch}-file-contents.patch
|
Patch5: %{pkgnamepatch}-file-contents.patch
|
||||||
Patch6: %{pkgnamepatch}-dh1024.patch
|
|
||||||
Patch7: %{pkgnamepatch}-scripts.patch
|
Patch7: %{pkgnamepatch}-scripts.patch
|
||||||
Patch8: %{pkgnamepatch}-install-db-sharedir.patch
|
Patch8: %{pkgnamepatch}-install-db-sharedir.patch
|
||||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||||
@ -167,7 +166,6 @@ Patch31: %{pkgnamepatch}-string-overflow.patch
|
|||||||
Patch32: %{pkgnamepatch}-basedir.patch
|
Patch32: %{pkgnamepatch}-basedir.patch
|
||||||
Patch33: %{pkgnamepatch}-covscan-signexpr.patch
|
Patch33: %{pkgnamepatch}-covscan-signexpr.patch
|
||||||
Patch34: %{pkgnamepatch}-covscan-stroverflow.patch
|
Patch34: %{pkgnamepatch}-covscan-stroverflow.patch
|
||||||
Patch36: %{pkgnamepatch}-ssltest.patch
|
|
||||||
Patch37: %{pkgnamepatch}-notestdb.patch
|
Patch37: %{pkgnamepatch}-notestdb.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -496,7 +494,6 @@ MariaDB is a community developed branch of MySQL.
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
@ -506,7 +503,6 @@ MariaDB is a community developed branch of MySQL.
|
|||||||
%patch32 -p1
|
%patch32 -p1
|
||||||
%patch33 -p1
|
%patch33 -p1
|
||||||
%patch34 -p1
|
%patch34 -p1
|
||||||
%patch36 -p1
|
|
||||||
%patch37 -p1
|
%patch37 -p1
|
||||||
|
|
||||||
# removing bundled cmd-line-utils is now disabled
|
# removing bundled cmd-line-utils is now disabled
|
||||||
@ -1152,6 +1148,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 07 2015 Honza Horak <hhorak@redhat.com> - 1:10.0.18-1
|
||||||
|
- Update to 10.0.18
|
||||||
|
|
||||||
* Fri May 07 2015 Honza Horak <hhorak@redhat.com> - 1:10.0.17-4
|
* Fri May 07 2015 Honza Horak <hhorak@redhat.com> - 1:10.0.17-4
|
||||||
- Include client plugins into -common package since they are used by both -libs
|
- Include client plugins into -common package since they are used by both -libs
|
||||||
and base packages.
|
and base packages.
|
||||||
|
Loading…
Reference in New Issue
Block a user