Rebase to 10.3.10
This commit is contained in:
parent
391a464898
commit
7e676213ef
15
mariadb-shebang.patch
Normal file
15
mariadb-shebang.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
*** WARNING: mangling shebang in /usr/bin/myrocks_hotbackup from #!/usr/bin/env python to #!/usr/bin/python2. This will become an ERROR, fix it manually!
|
||||||
|
|
||||||
|
Maintainer's note:
|
||||||
|
This script is not python3 compatible:
|
||||||
|
ModuleNotFoundError: No module named 'commands'
|
||||||
|
|
||||||
|
diff -Naurp mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup_patched
|
||||||
|
--- mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup 2018-10-02 11:45:43.000000000 +0200
|
||||||
|
+++ mariadb-10.3.10/storage/rocksdb/myrocks_hotbackup_patched 2018-10-05 14:27:02.960060700 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
+#!/usr/bin/python2
|
||||||
|
|
||||||
|
from __future__ import division
|
||||||
|
from optparse import OptionParser
|
22
mariadb.spec
22
mariadb.spec
@ -142,8 +142,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.3.9
|
Version: 10.3.10
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: MariaDB: a very fast and robust SQL database server
|
Summary: MariaDB: a very fast and robust SQL database server
|
||||||
@ -176,6 +176,8 @@ Source71: LICENSE.clustercheck
|
|||||||
# https://jira.mariadb.org/browse/MDEV-12646
|
# https://jira.mariadb.org/browse/MDEV-12646
|
||||||
Source72: mariadb-server-galera.te
|
Source72: mariadb-server-galera.te
|
||||||
|
|
||||||
|
# Patch1: Fix python shebang to specificaly say the python version
|
||||||
|
Patch1: %{pkgnamepatch}-shebang.patch
|
||||||
# Patch4: Red Hat distributions specific logrotate fix
|
# Patch4: Red Hat distributions specific logrotate fix
|
||||||
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
||||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||||
@ -673,6 +675,7 @@ sources.
|
|||||||
# Remove JAR files that upstream puts into tarball
|
# Remove JAR files that upstream puts into tarball
|
||||||
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
||||||
|
|
||||||
|
%patch1 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
@ -923,6 +926,7 @@ ln -s unstable-tests %{buildroot}%{_datadir}/mysql-test/rh-skipped-tests.list
|
|||||||
# Client that uses libmysqld embedded server.
|
# Client that uses libmysqld embedded server.
|
||||||
# Pretty much like normal mysql command line client, but it doesn't require a running mariadb server.
|
# Pretty much like normal mysql command line client, but it doesn't require a running mariadb server.
|
||||||
%{?with_embedded:rm %{buildroot}%{_bindir}/mysql_embedded}
|
%{?with_embedded:rm %{buildroot}%{_bindir}/mysql_embedded}
|
||||||
|
rm %{buildroot}%{_mandir}/man1/mysql_embedded.1*
|
||||||
# Static libraries
|
# Static libraries
|
||||||
rm %{buildroot}%{_libdir}/*.a
|
rm %{buildroot}%{_libdir}/*.a
|
||||||
# This script creates the MySQL system tables and starts the server.
|
# This script creates the MySQL system tables and starts the server.
|
||||||
@ -1034,7 +1038,7 @@ rm %{buildroot}%{_sysconfdir}/my.cnf.d/mysql-clients.cnf
|
|||||||
%if %{without tokudb}
|
%if %{without tokudb}
|
||||||
# because upstream ships manpages for tokudb even on architectures that tokudb doesn't support
|
# because upstream ships manpages for tokudb even on architectures that tokudb doesn't support
|
||||||
rm %{buildroot}%{_mandir}/man1/tokuftdump.1*
|
rm %{buildroot}%{_mandir}/man1/tokuftdump.1*
|
||||||
rm %{buildroot}%{_mandir}/man1/tokuft_logdump.1*
|
rm %{buildroot}%{_mandir}/man1/tokuft_logprint.1*
|
||||||
%else
|
%else
|
||||||
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
|
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
|
||||||
echo 'Environment="LD_PRELOAD=%{_libdir}/libjemalloc.so.2"' >> %{buildroot}%{_sysconfdir}/systemd/system/mariadb.service.d/tokudb.conf
|
echo 'Environment="LD_PRELOAD=%{_libdir}/libjemalloc.so.2"' >> %{buildroot}%{_sysconfdir}/systemd/system/mariadb.service.d/tokudb.conf
|
||||||
@ -1084,7 +1088,9 @@ rm %{buildroot}%{_bindir}/galera_recovery
|
|||||||
rm %{buildroot}%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
rm %{buildroot}%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if %{without rocksdb}
|
||||||
|
rm %{buildroot}%{_mandir}/man1/mysql_ldb.1*
|
||||||
|
%endif
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%if %{with test}
|
%if %{with test}
|
||||||
@ -1421,6 +1427,8 @@ fi
|
|||||||
%files backup
|
%files backup
|
||||||
%{_bindir}/mariabackup
|
%{_bindir}/mariabackup
|
||||||
%{_bindir}/mbstream
|
%{_bindir}/mbstream
|
||||||
|
%{_mandir}/man1/mariabackup.1*
|
||||||
|
%{_mandir}/man1/mbstream.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with rocksdb}
|
%if %{with rocksdb}
|
||||||
@ -1430,6 +1438,7 @@ fi
|
|||||||
%{_bindir}/mysql_ldb
|
%{_bindir}/mysql_ldb
|
||||||
%{_bindir}/sst_dump
|
%{_bindir}/sst_dump
|
||||||
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
||||||
|
%{_mandir}/man1/mysql_ldb.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with tokudb}
|
%if %{with tokudb}
|
||||||
@ -1437,7 +1446,7 @@ fi
|
|||||||
%{_bindir}/tokuftdump
|
%{_bindir}/tokuftdump
|
||||||
%{_bindir}/tokuft_logprint
|
%{_bindir}/tokuft_logprint
|
||||||
%{_mandir}/man1/tokuftdump.1*
|
%{_mandir}/man1/tokuftdump.1*
|
||||||
%{_mandir}/man1/tokuft_logdump.1*
|
%{_mandir}/man1/tokuft_logprint.1*
|
||||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
|
%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
|
||||||
%{_libdir}/%{pkg_name}/plugin/ha_tokudb.so
|
%{_libdir}/%{pkg_name}/plugin/ha_tokudb.so
|
||||||
/usr/lib/systemd/system/mariadb.service.d/tokudb.conf
|
/usr/lib/systemd/system/mariadb.service.d/tokudb.conf
|
||||||
@ -1547,6 +1556,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 05 2018 Michal Schorm <mschorm@redhat.com> - 3:10.3.10-1
|
||||||
|
- Rebase to 10.3.10
|
||||||
|
|
||||||
* Tue Sep 04 2018 Michal Schorm <mschorm@redhat.com> - 3:10.3.9-2
|
* Tue Sep 04 2018 Michal Schorm <mschorm@redhat.com> - 3:10.3.9-2
|
||||||
- Fix parallel installability of x86_64 and i686 devel packages
|
- Fix parallel installability of x86_64 and i686 devel packages
|
||||||
|
|
||||||
|
@ -15,3 +15,6 @@ main.type_float :
|
|||||||
main.type_newdecimal :
|
main.type_newdecimal :
|
||||||
main.type_ranges :
|
main.type_ranges :
|
||||||
|
|
||||||
|
# 10.3.10
|
||||||
|
parts.partition_alter1_2_innodb :
|
||||||
|
parts.partition_alter1_1_2_innodb :
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.3.9.tar.gz) = 7c7a678fb0c85da64b6df3df17b8cf7f2ccf862e27dcf8535f7403f8693c76b3b1a912f4b6ca876a591ada60a99577a947bfe7a63c602f754332e1e4f689e6e7
|
SHA512 (mariadb-10.3.10.tar.gz) = dee7789dff359a6352ceacb2db6bcb4730940e9458adda4e23894f9bfa0a7ff8c238060bffca58a60b662275e52a31ea1784d51fae114312b003c024e9412b31
|
||||||
|
Loading…
Reference in New Issue
Block a user