Update to non-LTS version for testing
This commit is contained in:
parent
19889e78e3
commit
6c3626c330
@ -1,6 +1,7 @@
|
|||||||
--- mariadb-10.4.14/support-files/CMakeLists.txt 2020-08-06 17:28:28.000000000 +0200
|
diff -up mariadb-11.2.2/support-files/CMakeLists.txt.patch9 mariadb-11.2.2/support-files/CMakeLists.txt
|
||||||
+++ mariadb-10.4.14/support-files/CMakeLists.txt_patched 2020-09-03 13:21:07.826658279 +0200
|
--- mariadb-11.2.2/support-files/CMakeLists.txt.patch9 2023-11-19 08:41:57.000000000 +0100
|
||||||
@@ -187,6 +187,7 @@ IF(UNIX)
|
+++ mariadb-11.2.2/support-files/CMakeLists.txt 2024-02-01 22:34:07.518104344 +0100
|
||||||
|
@@ -237,6 +237,7 @@ IF(UNIX AND NOT WITHOUT_SERVER)
|
||||||
COMPONENT SharedLibraries)
|
COMPONENT SharedLibraries)
|
||||||
INSTALL(FILES rpm/mysql-clients.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
|
INSTALL(FILES rpm/mysql-clients.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
|
||||||
COMPONENT Client)
|
COMPONENT Client)
|
||||||
@ -8,14 +9,13 @@
|
|||||||
INSTALL(FILES rpm/server.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
|
INSTALL(FILES rpm/server.cnf DESTINATION ${INSTALL_SYSCONF2DIR}
|
||||||
COMPONENT IniFiles)
|
COMPONENT IniFiles)
|
||||||
INSTALL(FILES rpm/enable_encryption.preset DESTINATION ${INSTALL_SYSCONF2DIR}
|
INSTALL(FILES rpm/enable_encryption.preset DESTINATION ${INSTALL_SYSCONF2DIR}
|
||||||
|
diff -up mariadb-11.2.2/support-files/rpm/server.cnf.patch9 mariadb-11.2.2/support-files/rpm/server.cnf
|
||||||
|
--- mariadb-11.2.2/support-files/rpm/server.cnf.patch9 2024-02-01 22:34:07.518104344 +0100
|
||||||
|
+++ mariadb-11.2.2/support-files/rpm/server.cnf 2024-02-01 22:35:11.235350567 +0100
|
||||||
|
@@ -12,7 +12,15 @@
|
||||||
|
[mariadb]
|
||||||
|
|
||||||
diff -up mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup mariadb-10.0.15/support-files/rpm/server.cnf
|
# This group is read by both MariaDB and MySQL servers
|
||||||
--- mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup 2015-01-24 23:55:55.110063592 +0100
|
|
||||||
+++ mariadb-10.0.15/support-files/rpm/server.cnf 2015-01-24 23:57:42.308114387 +0100
|
|
||||||
@@ -9,7 +9,16 @@
|
|
||||||
[server]
|
|
||||||
|
|
||||||
# this is only for the mysqld standalone daemon
|
|
||||||
+# Settings user and group are ignored when systemd is used.
|
+# Settings user and group are ignored when systemd is used.
|
||||||
+# If you need to run mysqld under a different user or group,
|
+# If you need to run mysqld under a different user or group,
|
||||||
+# customize your systemd unit file for mysqld/mariadb according to the
|
+# customize your systemd unit file for mysqld/mariadb according to the
|
||||||
@ -25,7 +25,6 @@ diff -up mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup mariadb-10.0.15/s
|
|||||||
+socket=@MYSQL_UNIX_ADDR@
|
+socket=@MYSQL_UNIX_ADDR@
|
||||||
+log-error=@LOG_LOCATION@
|
+log-error=@LOG_LOCATION@
|
||||||
+pid-file=@PID_FILE_DIR@/@DAEMON_NO_PREFIX@.pid
|
+pid-file=@PID_FILE_DIR@/@DAEMON_NO_PREFIX@.pid
|
||||||
+
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# * Galera-related settings
|
# * Galera-related settings
|
||||||
|
@ -1,11 +1,11 @@
|
|||||||
We have some downstream patches and other scripts that include variables to
|
We have some downstream patches and other scripts that include variables to
|
||||||
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
||||||
|
|
||||||
# Install libgcc as mylibgcc.a
|
diff -up mariadb-11.2.2/scripts/CMakeLists.txt.patch7 mariadb-11.2.2/scripts/CMakeLists.txt
|
||||||
--- mariadb-10.5.5/scripts/CMakeLists.txt.old 2020-09-24 10:13:35.272589689 +0200
|
--- mariadb-11.2.2/scripts/CMakeLists.txt.patch7 2023-11-19 08:41:57.000000000 +0100
|
||||||
+++ mariadb-10.5.5/scripts/CMakeLists.txt 2020-09-24 10:17:31.428985798 +0200
|
+++ mariadb-11.2.2/scripts/CMakeLists.txt 2024-02-01 22:41:21.031114440 +0100
|
||||||
@@ -377,6 +377,34 @@
|
@@ -388,6 +388,34 @@ ELSE()
|
||||||
INSTALL_LINK(${file} ${binname} ${INSTALL_BINDIR} ${${file}_COMPONENT})
|
INSTALL_LINK(${file} ${binname} ${INSTALL_BINDIR} ${${file}_COMPONENT}Symlinks)
|
||||||
ENDIF()
|
ENDIF()
|
||||||
ENDFOREACH()
|
ENDFOREACH()
|
||||||
+
|
+
|
||||||
|
@ -1,10 +1,10 @@
|
|||||||
# Plain package name for cases, where %{name} differs (e.g. for versioned packages)
|
# Plain package name for cases, where %{name} differs (e.g. for versioned packages)
|
||||||
%global majorname mariadb
|
%global majorname mariadb
|
||||||
%define package_version 10.11.6
|
%define package_version 11.2.2
|
||||||
%define majorversion %(echo %{package_version} | cut -d'.' -f1-2 )
|
%define majorversion %(echo %{package_version} | cut -d'.' -f1-2 )
|
||||||
|
|
||||||
# Set if this package will be the default one in distribution
|
# Set if this package will be the default one in distribution
|
||||||
%{!?mariadb_default:%global mariadb_default 1}
|
%{!?mariadb_default:%global mariadb_default 0}
|
||||||
|
|
||||||
# Regression tests may take a long time (many cores recommended), skip them by
|
# Regression tests may take a long time (many cores recommended), skip them by
|
||||||
%{!?runselftest:%global runselftest 0}
|
%{!?runselftest:%global runselftest 0}
|
||||||
@ -15,7 +15,7 @@
|
|||||||
# The last version on which the full testsuite has been run
|
# The last version on which the full testsuite has been run
|
||||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||||
# run only "main" suite
|
# run only "main" suite
|
||||||
%global last_tested_version 10.11.6
|
%global last_tested_version 11.2.2
|
||||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||||
%global force_run_testsuite 0
|
%global force_run_testsuite 0
|
||||||
|
|
||||||
@ -1179,7 +1179,7 @@ rm %{buildroot}%{_datadir}/%{majorname}/errmsg-utf8.txt
|
|||||||
rm -r %{buildroot}%{_datadir}/%{majorname}/{english,czech,danish,dutch,estonian,\
|
rm -r %{buildroot}%{_datadir}/%{majorname}/{english,czech,danish,dutch,estonian,\
|
||||||
french,german,greek,hungarian,italian,japanese,korean,norwegian,norwegian-ny,\
|
french,german,greek,hungarian,italian,japanese,korean,norwegian,norwegian-ny,\
|
||||||
polish,portuguese,romanian,russian,serbian,slovak,spanish,swedish,ukrainian,hindi,\
|
polish,portuguese,romanian,russian,serbian,slovak,spanish,swedish,ukrainian,hindi,\
|
||||||
bulgarian,chinese,georgian}
|
bulgarian,chinese,georgian,swahili}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{without test}
|
%if %{without test}
|
||||||
@ -1419,6 +1419,7 @@ fi
|
|||||||
%lang(bg) %{_datadir}/%{majorname}/bulgarian
|
%lang(bg) %{_datadir}/%{majorname}/bulgarian
|
||||||
%lang(zh) %{_datadir}/%{majorname}/chinese
|
%lang(zh) %{_datadir}/%{majorname}/chinese
|
||||||
%lang(ka) %{_datadir}/%{majorname}/georgian
|
%lang(ka) %{_datadir}/%{majorname}/georgian
|
||||||
|
%lang(sw) %{_datadir}/%{majorname}/swahili
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with galera}
|
%if %{with galera}
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.11.6.tar.gz) = 3d77f7be4a26d5a36af56150a5f8ed5e21adeed9bc8ea1bd694e47a25a571bd73468eada7c96e0dfe5a6c81bef625abf71a56d228cf43a738e555e3c0d824a6a
|
SHA512 (mariadb-11.2.2.tar.gz) = be0c4574954551c04b39eeefdc756f8dd67562dfdfe3c34c0546f6e0c340439326e42743400d15c2931802d91296f1aceeb060c7982412b44b2ea1f6dbf284f6
|
||||||
|
Loading…
Reference in New Issue
Block a user