JdbcMariaDB.jar test removed
- PCRE version check added - Resolves: #1382988 - Related: #1396945, #1096787
This commit is contained in:
parent
14c6fb26f0
commit
684ad9995a
21
mariadb-ssl-cypher.patch
Normal file
21
mariadb-ssl-cypher.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up mariadb-10.1.19/mysql-test/r/ssl_8k_key.result.sslbak mariadb-10.1.19/mysql-test/r/ssl_8k_key.result
|
||||
--- mariadb-10.1.19/mysql-test/r/ssl_8k_key.result.sslbak 2016-11-24 08:55:21.637000000 -0500
|
||||
+++ mariadb-10.1.19/mysql-test/r/ssl_8k_key.result 2016-11-24 08:55:55.853000000 -0500
|
||||
@@ -1,2 +1,2 @@
|
||||
-Variable_name Value
|
||||
-Ssl_cipher DHE-RSA-AES256-SHA
|
||||
+have_ssl
|
||||
+1
|
||||
diff -up mariadb-10.1.19/mysql-test/t/ssl_8k_key.test.sslbak mariadb-10.1.19/mysql-test/t/ssl_8k_key.test
|
||||
--- mariadb-10.1.19/mysql-test/t/ssl_8k_key.test.sslbak 2016-11-24 08:54:10.485000000 -0500
|
||||
+++ mariadb-10.1.19/mysql-test/t/ssl_8k_key.test 2016-11-24 08:54:35.724000000 -0500
|
||||
@@ -5,7 +5,7 @@
|
||||
#
|
||||
# Bug#29784 YaSSL assertion failure when reading 8k key.
|
||||
#
|
||||
---exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
|
||||
+--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SELECT (VARIABLE_VALUE <> '') AS have_ssl FROM INFORMATION_SCHEMA.SESSION_STATUS WHERE VARIABLE_NAME='Ssl_cipher'" 2>&1
|
||||
|
||||
## This test file is for testing encrypted communication only, not other
|
||||
## encryption routines that the SSL library happens to provide!
|
||||
|
10
mariadb.spec
10
mariadb.spec
@ -7,8 +7,8 @@
|
||||
# --nocheck is not possible (e.g. in koji build)
|
||||
%{!?runselftest:%global runselftest 1}
|
||||
|
||||
# Set this to 1 to see which tests fail
|
||||
%global check_testsuite 0
|
||||
# Set this to 1 to see which tests fail, but 0 on production ready build
|
||||
%global ignore_testsuite_result 0
|
||||
|
||||
# In f20+ use unversioned docdirs, otherwise the old versioned one
|
||||
%global _pkgdocdirname %{pkg_name}%{!?_pkgdocdir:-%{version}}
|
||||
@ -169,6 +169,7 @@ Patch7: %{pkgnamepatch}-scripts.patch
|
||||
Patch8: %{pkgnamepatch}-install-db-sharedir.patch
|
||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||
Patch12: %{pkgnamepatch}-admincrash.patch
|
||||
Patch13: %{pkgnamepatch}-ssl-cypher.patch
|
||||
|
||||
# Patches specific for this mysql package
|
||||
Patch30: %{pkgnamepatch}-errno.patch
|
||||
@ -573,6 +574,7 @@ MariaDB is a community developed branch of MySQL.
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch30 -p1
|
||||
%patch31 -p1
|
||||
%patch32 -p1
|
||||
@ -966,7 +968,7 @@ export MTR_BUILD_THREAD=%{__isa_bits}
|
||||
--suite-timeout=720 --testcase-timeout=30 --skip-rpl \
|
||||
--mysqld=--binlog-format=mixed --force-restart \
|
||||
--shutdown-timeout=60 --max-test-fail=0 \
|
||||
%if %{check_testsuite}
|
||||
%if %{ignore_testsuite_result}
|
||||
|| :
|
||||
%else
|
||||
--skip-test-list=rh-skipped-tests.list
|
||||
@ -1334,7 +1336,7 @@ fi
|
||||
- JdbcMariaDB.jar test removed
|
||||
- PCRE version check added
|
||||
- Resolves: #1382988
|
||||
- Related: #1396945
|
||||
- Related: #1396945, #1096787
|
||||
|
||||
* Wed Nov 16 2016 Michal Schorm <mschorm@redhat.com> - 3:10.1.19-4
|
||||
- test suite ENABLED, consensus was made it still should be run every build
|
||||
|
@ -1,13 +1,12 @@
|
||||
# These tests fail with MariaDB 10:
|
||||
|
||||
main.userstat : rhbz#1096787
|
||||
main.multi_update : rhbz#1096787
|
||||
main.set_statement_notembedded_binlog : rhbz#1096787
|
||||
main.ssl_cert_verify : rhbz#1096787
|
||||
main.ssl_crl_clients : rhbz#1096787
|
||||
main.ssl_7937 : rhbz#1096787
|
||||
main.ssl_8k_key : rhbz#1096787
|
||||
main.userstat : rhbz#1096787
|
||||
main.ssl_crl_clients : rhbz#1096787
|
||||
main.ssl_cert_verify : rhbz#1096787
|
||||
perfschema.nesting : rhbz#1096787
|
||||
perfschema.socket_summary_by_event_name_func : rhbz#1096787
|
||||
perfschema.socket_summary_by_instance_func : rhbz#1096787
|
||||
sys_vars.wsrep_provider_options_basic : rhbz#1096787
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user