Rebase to 10.4.12
This commit is contained in:
parent
ced66e28de
commit
55406c8293
@ -5,11 +5,11 @@ Thus "chown 0" will always fail
|
||||
Never parse 'ls' output!
|
||||
http://mywiki.wooledge.org/BashFAQ/087
|
||||
|
||||
--- mariadb-10.4.7/scripts/mysql_install_db.sh 2019-07-30 13:32:16.000000000 +0200
|
||||
+++ mariadb-10.4.7/scripts/mysql_install_db.sh_patched 2019-08-22 16:29:28.341484925 +0200
|
||||
@@ -490,13 +490,16 @@ then
|
||||
fi
|
||||
if test -z "$srcdir"
|
||||
--- mariadb-10.4.12/scripts/mysql_install_db.sh 2020-01-26 21:43:53.000000000 +0100
|
||||
+++ mariadb-10.4.12/scripts/mysql_install_db.sh_patched 2020-01-29 11:11:09.448812331 +0100
|
||||
@@ -482,13 +482,16 @@ if test -n "$user"
|
||||
then
|
||||
if test -z "$srcdir" -a "$in_rpm" -eq 0
|
||||
then
|
||||
- chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" && \
|
||||
- chmod 04755 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
|
||||
@ -21,9 +21,9 @@ http://mywiki.wooledge.org/BashFAQ/087
|
||||
+ if test $? -ne 0
|
||||
+ then
|
||||
echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
|
||||
echo " It must be root, the PAM authentication plugin doesn't work otherwise.."
|
||||
echo "It must be root, the PAM authentication plugin doesn't work otherwise.."
|
||||
echo
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
args="$args --user=$user"
|
||||
chown $user "$pamtooldir/auth_pam_tool_dir" && \
|
||||
chmod 0700 "$pamtooldir/auth_pam_tool_dir"
|
||||
|
11
mariadb.spec
11
mariadb.spec
@ -146,8 +146,8 @@
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
|
||||
Name: mariadb
|
||||
Version: 10.4.11
|
||||
Release: 2%{?with_debug:.debug}%{?dist}
|
||||
Version: 10.4.12
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A very fast and robust SQL database server
|
||||
@ -993,6 +993,8 @@ rm %{buildroot}%{logrotateddir}/mysql
|
||||
# Remove AppArmor files
|
||||
rm -r %{buildroot}%{_datadir}/%{pkg_name}/policy/apparmor
|
||||
|
||||
mv %{buildroot}/lib/security %{buildroot}%{_libdir}
|
||||
|
||||
# Disable plugins
|
||||
%if %{with gssapi}
|
||||
sed -i 's/^plugin-load-add/#plugin-load-add/' %{buildroot}%{_sysconfdir}/my.cnf.d/auth_gssapi.cnf
|
||||
@ -1343,6 +1345,8 @@ fi
|
||||
%dir %{_libdir}/%{pkg_name}/plugin
|
||||
# Change from root:root to mysql:mysql, so it can be accessed by the server
|
||||
%attr(0755,mysql,mysql) %dir %{_libdir}/%{pkg_name}/plugin/auth_pam_tool_dir
|
||||
%{_libdir}/security/pam_user_map.so
|
||||
%{_sysconfdir}/security/user_map.conf
|
||||
%{_libdir}/%{pkg_name}/plugin/*
|
||||
%{?with_oqgraph:%exclude %{_libdir}/%{pkg_name}/plugin/ha_oqgraph.so}
|
||||
%{?with_connect:%exclude %{_libdir}/%{pkg_name}/plugin/ha_connect.so}
|
||||
@ -1555,6 +1559,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Feb 06 2020 Michal Schorm <mschorm@redhat.com> - 10.4.12-1
|
||||
- Rebase to 10.4.12
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3:10.4.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
@ -0,0 +1,2 @@
|
||||
# Fails on ppc64le since 10.4.12
|
||||
oqgraph.social :
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mariadb-10.4.11.tar.gz) = 2a1a8d90e326530b41a8a7d6889325cefcba5914451a48c6a20d5d5cd68004835e76e6ecac628554167a014f9c0b1487c15f37151afd771ea0166a4c40afd7d2
|
||||
SHA512 (mariadb-10.4.12.tar.gz) = 518dae18c04a1f7fcc6fd4d2dfbfbfbdf5e83e72ca41e66e1074328df8d92ab41b458e6a9973771419ac09a7348f264f158916cd198c335085d6e823e707bbc6
|
||||
|
Loading…
Reference in New Issue
Block a user