Rebase to 10.4.13
Patch mariadb-pythonver upstreamed (upstream now use only python 3)
This commit is contained in:
parent
e0f7005539
commit
383e14b547
@ -1,17 +1,19 @@
|
|||||||
diff -up mariadb-10.1.8/support-files/CMakeLists.txt.p9 mariadb-10.1.8/support-files/CMakeLists.txt
|
diff -up mariadb-10.1.8/support-files/CMakeLists.txt.p9 mariadb-10.1.8/support-files/CMakeLists.txt
|
||||||
--- mariadb-10.1.8/support-files/CMakeLists.txt.p9 2015-11-03 11:38:46.029139464 +0100
|
--- mariadb-10.2.32/support-files/CMakeLists.txt 2020-05-08 13:45:27.000000000 +0200
|
||||||
+++ mariadb-10.1.8/support-files/CMakeLists.txt 2015-11-03 11:41:07.107605055 +0100
|
+++ mariadb-10.2.32/support-files/CMakeLists.txt_pacthed 2020-05-13 10:11:30.884190396 +0200
|
||||||
@@ -62,6 +62,7 @@ IF(UNIX)
|
@@ -100,7 +100,8 @@ IF(UNIX)
|
||||||
ENDIF()
|
ENDIF()
|
||||||
|
|
||||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||||
|
- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
||||||
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
||||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
||||||
|
|
||||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||||
diff -up mariadb-10.1.8/support-files/rpm/server.cnf.p9 mariadb-10.1.8/support-files/rpm/server.cnf
|
|
||||||
--- mariadb-10.1.8/support-files/rpm/server.cnf.p9 2015-10-15 17:44:19.000000000 +0200
|
diff -up mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup mariadb-10.0.15/support-files/rpm/server.cnf
|
||||||
+++ mariadb-10.1.8/support-files/rpm/server.cnf 2015-11-03 11:38:25.228070808 +0100
|
--- mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup 2015-01-24 23:55:55.110063592 +0100
|
||||||
|
+++ mariadb-10.0.15/support-files/rpm/server.cnf 2015-01-24 23:57:42.308114387 +0100
|
||||||
@@ -9,7 +9,16 @@
|
@@ -9,7 +9,16 @@
|
||||||
[server]
|
[server]
|
||||||
|
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
Upstream PR: https://github.com/MariaDB/server/pull/1081
|
|
||||||
|
|
||||||
From d2cbf56d36e422802aa7e53ec0f4e6be8fd53cf5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Honza Horak <hhorak@redhat.com>
|
|
||||||
Date: Wed, 9 Jan 2019 20:17:29 +0100
|
|
||||||
Subject: [PATCH] Make the PYTHON_SHEBANG value configurable
|
|
||||||
|
|
||||||
In Fedora 30 it is required to specify either /usr/bin/python2 or /usr/bin/python3 in the shebang, so we need a way to say explicit shebang, ideally in the cmake call.
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index a139c9e5fa4..ccccb08bef1 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -342,7 +342,9 @@ MYSQL_CHECK_SSL()
|
|
||||||
MYSQL_CHECK_READLINE()
|
|
||||||
|
|
||||||
SET(MALLOC_LIBRARY "system")
|
|
||||||
-SET(PYTHON_SHEBANG "/usr/bin/env python" CACHE STRING "python shebang")
|
|
||||||
+IF(NOT DEFINED PYTHON_SHEBANG)
|
|
||||||
+ SET(PYTHON_SHEBANG "/usr/bin/env python")
|
|
||||||
+ENDIF()
|
|
||||||
MARK_AS_ADVANCED(PYTHON_SHEBANG)
|
|
||||||
|
|
||||||
CHECK_PCRE()
|
|
23
mariadb.spec
23
mariadb.spec
@ -146,8 +146,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.4.12
|
Version: 10.4.13
|
||||||
Release: 6%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -180,8 +180,6 @@ Source71: LICENSE.clustercheck
|
|||||||
# https://jira.mariadb.org/browse/MDEV-12646
|
# https://jira.mariadb.org/browse/MDEV-12646
|
||||||
Source72: mariadb-server-galera.te
|
Source72: mariadb-server-galera.te
|
||||||
|
|
||||||
# Patch2: Make the python interpretter be configurable
|
|
||||||
Patch2: %{pkgnamepatch}-pythonver.patch
|
|
||||||
# Patch4: Red Hat distributions specific logrotate fix
|
# Patch4: Red Hat distributions specific logrotate fix
|
||||||
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
# it would be big unexpected change, if we start shipping it now. Better wait for MariaDB 10.2
|
||||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||||
@ -697,7 +695,6 @@ find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
|||||||
|
|
||||||
rm -rf libmariadb/unittest
|
rm -rf libmariadb/unittest
|
||||||
|
|
||||||
%patch2 -p1
|
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
@ -939,16 +936,13 @@ rm scripts/my.cnf
|
|||||||
# use different config file name for each variant of server (mariadb / mysql)
|
# use different config file name for each variant of server (mariadb / mysql)
|
||||||
mv %{buildroot}%{_sysconfdir}/my.cnf.d/server.cnf %{buildroot}%{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf
|
mv %{buildroot}%{_sysconfdir}/my.cnf.d/server.cnf %{buildroot}%{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf
|
||||||
|
|
||||||
# Rename sysusers and tmpfiles config files, they should be named after the software they belong to
|
|
||||||
mv %{buildroot}%{_sysusersdir}/sysusers.conf %{buildroot}%{_sysusersdir}/%{name}.conf
|
|
||||||
|
|
||||||
# remove SysV init script and a symlink to that, we use systemd
|
# remove SysV init script and a symlink to that, we use systemd
|
||||||
rm %{buildroot}%{_libexecdir}/rcmysql
|
rm %{buildroot}%{_libexecdir}/rcmysql
|
||||||
# install systemd unit files and scripts for handling server startup
|
# install systemd unit files and scripts for handling server startup
|
||||||
install -D -p -m 644 scripts/mysql.service %{buildroot}%{_unitdir}/%{daemon_name}.service
|
install -D -p -m 644 scripts/mysql.service %{buildroot}%{_unitdir}/%{daemon_name}.service
|
||||||
install -D -p -m 644 scripts/mysql@.service %{buildroot}%{_unitdir}/%{daemon_name}@.service
|
install -D -p -m 644 scripts/mysql@.service %{buildroot}%{_unitdir}/%{daemon_name}@.service
|
||||||
# Remove the upstream version
|
# Remove the upstream version
|
||||||
rm %{buildroot}%{_tmpfilesdir}/tmpfiles.conf
|
rm %{buildroot}%{_tmpfilesdir}/mariadb.conf
|
||||||
# Install downstream version
|
# Install downstream version
|
||||||
install -D -p -m 0644 scripts/mysql.tmpfiles.d %{buildroot}%{_tmpfilesdir}/%{name}.conf
|
install -D -p -m 0644 scripts/mysql.tmpfiles.d %{buildroot}%{_tmpfilesdir}/%{name}.conf
|
||||||
%if 0%{?mysqld_pid_dir:1}
|
%if 0%{?mysqld_pid_dir:1}
|
||||||
@ -1026,7 +1020,7 @@ rm %{buildroot}%{logrotateddir}/mysql
|
|||||||
# Remove AppArmor files
|
# Remove AppArmor files
|
||||||
rm -r %{buildroot}%{_datadir}/%{pkg_name}/policy/apparmor
|
rm -r %{buildroot}%{_datadir}/%{pkg_name}/policy/apparmor
|
||||||
|
|
||||||
mv %{buildroot}/lib/security %{buildroot}%{_libdir}
|
mv %{buildroot}/%{_lib}/security %{buildroot}%{_libdir}
|
||||||
|
|
||||||
# Disable plugins
|
# Disable plugins
|
||||||
%if %{with gssapi}
|
%if %{with gssapi}
|
||||||
@ -1101,11 +1095,7 @@ rm %{buildroot}%{_mandir}/man1/mysql{access,admin,binlog,check,dump,_find_rows,i
|
|||||||
rm %{buildroot}%{_mandir}/man1/mariadb-{access,admin,binlog,check,dump,find-rows,import,plugin,show,slap,waitpid}.1*
|
rm %{buildroot}%{_mandir}/man1/mariadb-{access,admin,binlog,check,dump,find-rows,import,plugin,show,slap,waitpid}.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{without tokudb}
|
%if %{with tokudb}
|
||||||
# because upstream ships manpages for tokudb even on architectures that tokudb doesn't support
|
|
||||||
rm %{buildroot}%{_mandir}/man1/tokuftdump.1*
|
|
||||||
rm %{buildroot}%{_mandir}/man1/tokuft_logprint.1*
|
|
||||||
%else
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
# Move the upstream file to the correct location
|
# Move the upstream file to the correct location
|
||||||
mkdir -p %{buildroot}%{_unitdir}/mariadb.service.d
|
mkdir -p %{buildroot}%{_unitdir}/mariadb.service.d
|
||||||
@ -1592,6 +1582,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 05 2020 Michal Schorm <mschorm@redhat.com> - 10.4.13-1
|
||||||
|
- Rebase to 10.4.13
|
||||||
|
|
||||||
* Sun May 24 2020 Lukas Javorsky <ljavorsk@redhat.com> - 3:10.4.12-6
|
* Sun May 24 2020 Lukas Javorsky <ljavorsk@redhat.com> - 3:10.4.12-6
|
||||||
- Remove mariadb_rpl.h from includedir to prevent conflict with connector-c's libraries
|
- Remove mariadb_rpl.h from includedir to prevent conflict with connector-c's libraries
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.4.12.tar.gz) = f26c45bbab765c979bbdb748da10ee314c1494e2ad7df7523bf4020b5f5036c06242739c1877fa0a21defcdd27f498cfff730289486ce9ced09d5740f3594657
|
SHA512 (mariadb-10.4.13.tar.gz) = 68919ceffb3d4afdd0d94daa77439a954c82ce4e08fbe06044fc397940eeb88a39ec75932cbd08ff26ef3cf7636fdb779947cda5b2764aa1fd888be19c44b566
|
||||||
|
Loading…
Reference in New Issue
Block a user