parent
6c7d4da4c2
commit
9f841d9d76
@ -1,14 +1,3 @@
|
||||
--- make-3.80/configure.in
|
||||
+++ make-3.80/configure.in
|
||||
@@ -91,7 +91,7 @@
|
||||
if test "$make_cv_file_timestamp_hi_res" = yes; then
|
||||
# Solaris 2.5.1 needs -lposix4 to get the clock_gettime function.
|
||||
# Solaris 7 prefers the library name -lrt to the obsolescent name -lposix4.
|
||||
- AC_SEARCH_LIBS(clock_gettime, [rt posix4])
|
||||
+ AC_SEARCH_LIBS(clock_gettime, [posix4])
|
||||
if test "$ac_cv_search_clock_gettime" != no; then
|
||||
AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
|
||||
[Define if you have the clock_gettime function.])
|
||||
--- make-3.80/configure
|
||||
+++ make-3.80/configure
|
||||
@@ -6794,7 +6794,7 @@
|
||||
|
@ -1,36 +0,0 @@
|
||||
--- make-3.79.1/configure.in.sopwith 2002-12-03 09:51:07.000000000 -0500
|
||||
+++ make-3.79.1/configure.in 2002-12-03 09:51:07.000000000 -0500
|
||||
@@ -32,7 +32,7 @@
|
||||
AC_TYPE_PID_T
|
||||
AC_TYPE_SIGNAL
|
||||
AC_CHECK_HEADERS(stdlib.h unistd.h limits.h sys/param.h fcntl.h string.h \
|
||||
- memory.h sys/time.h sys/timeb.h)
|
||||
+ memory.h sys/time.h sys/timeb.h signal.h)
|
||||
AC_PROG_CC_C_O
|
||||
AM_PROG_CC_STDC
|
||||
AC_C_CONST dnl getopt needs this.
|
||||
@@ -144,7 +144,12 @@
|
||||
fi
|
||||
AC_MSG_RESULT($make_cv_union_wait)
|
||||
|
||||
-AC_DECL_SYS_SIGLIST
|
||||
+ac_includes_default="$ac_includes_default
|
||||
+#ifdef HAVE_SIGNAL_H
|
||||
+#include <signal.h>
|
||||
+#endif
|
||||
+"
|
||||
+AC_SYS_SIGLIST_DECLARED
|
||||
|
||||
# The presence of the following is not meant to imply
|
||||
# that make necessarily works on those systems.
|
||||
--- make-3.79.1/signame.c.sopwith 2002-12-03 09:53:15.000000000 -0500
|
||||
+++ make-3.79.1/signame.c 2002-12-03 09:54:28.000000000 -0500
|
||||
@@ -47,7 +47,7 @@
|
||||
|
||||
#else /* HAVE_SYS_SIGLIST. */
|
||||
|
||||
-#ifndef SYS_SIGLIST_DECLARED
|
||||
+#if !defined(SYS_SIGLIST_DECLARED) && !defined(HAVE_DECL_SYS_SIGLIST)
|
||||
extern char *sys_siglist[];
|
||||
#endif /* Not SYS_SIGLIST_DECLARED. */
|
||||
|
15
make.spec
15
make.spec
@ -3,7 +3,7 @@ Summary: A GNU tool which simplifies the build process for users
|
||||
Name: make
|
||||
Epoch: 1
|
||||
Version: 3.81
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/make/
|
||||
@ -27,9 +27,6 @@ knowledge about the details of the build process. The details about
|
||||
how the program should be built are provided for make in the program's
|
||||
makefile.
|
||||
|
||||
The GNU make tool should be installed on your system because it is
|
||||
commonly used to simplify the process of installing programs.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1
|
||||
@ -41,9 +38,6 @@ commonly used to simplify the process of installing programs.
|
||||
%patch9 -p1
|
||||
|
||||
%build
|
||||
config/missing --run aclocal -I config
|
||||
config/missing --run automake --gnu Makefile
|
||||
config/missing --run autoconf
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -51,6 +45,7 @@ make %{?_smp_mflags}
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
|
||||
ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
|
||||
rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
|
||||
|
||||
%find_lang %name
|
||||
@ -73,12 +68,16 @@ fi
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%doc NEWS README
|
||||
%doc NEWS README COPYING AUTHORS
|
||||
%{_bindir}/*
|
||||
%{_mandir}/man*/*
|
||||
%{_infodir}/*.info*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 4 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-8
|
||||
- Cleaned up per merge review.
|
||||
- Related: #226120
|
||||
|
||||
* Thu Aug 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-7
|
||||
- Fix licensing tag.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user