Fix wrong assumptions of glibc's glob internals
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
9c4a278bbd
commit
3ffc99baef
67
make-4.2.1-glob-fix-2.patch
Normal file
67
make-4.2.1-glob-fix-2.patch
Normal file
@ -0,0 +1,67 @@
|
||||
From 193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4 Mon Sep 17 00:00:00 2001
|
||||
From: Paul Eggert <eggert@cs.ucla.edu>
|
||||
Date: Sun, 24 Sep 2017 09:12:58 -0400
|
||||
Subject: glob: Do not assume glibc glob internals.
|
||||
|
||||
It has been proposed that glibc glob start using gl_lstat,
|
||||
which the API allows it to do. GNU 'make' should not get in
|
||||
the way of this. See:
|
||||
https://sourceware.org/ml/libc-alpha/2017-09/msg00409.html
|
||||
|
||||
* dir.c (local_lstat): New function, like local_stat.
|
||||
(dir_setup_glob): Use it to initialize gl_lstat too, as the API
|
||||
requires.
|
||||
---
|
||||
dir.c | 29 +++++++++++++++++++++++++++--
|
||||
1 file changed, 27 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dir.c b/dir.c
|
||||
index adbb8a9..c343e4c 100644
|
||||
--- a/dir.c
|
||||
+++ b/dir.c
|
||||
@@ -1299,15 +1299,40 @@ local_stat (const char *path, struct stat *buf)
|
||||
}
|
||||
#endif
|
||||
|
||||
+/* Similarly for lstat. */
|
||||
+#if !defined(lstat) && !defined(WINDOWS32) || defined(VMS)
|
||||
+# ifndef VMS
|
||||
+# ifndef HAVE_SYS_STAT_H
|
||||
+int lstat (const char *path, struct stat *sbuf);
|
||||
+# endif
|
||||
+# else
|
||||
+ /* We are done with the fake lstat. Go back to the real lstat */
|
||||
+# ifdef lstat
|
||||
+# undef lstat
|
||||
+# endif
|
||||
+# endif
|
||||
+# define local_lstat lstat
|
||||
+#elif defined(WINDOWS32)
|
||||
+/* Windows doesn't support lstat(). */
|
||||
+# define local_lstat local_stat
|
||||
+#else
|
||||
+static int
|
||||
+local_lstat (const char *path, struct stat *buf)
|
||||
+{
|
||||
+ int e;
|
||||
+ EINTRLOOP (e, lstat (path, buf));
|
||||
+ return e;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
void
|
||||
dir_setup_glob (glob_t *gl)
|
||||
{
|
||||
gl->gl_opendir = open_dirstream;
|
||||
gl->gl_readdir = read_dirstream;
|
||||
gl->gl_closedir = free;
|
||||
+ gl->gl_lstat = local_lstat;
|
||||
gl->gl_stat = local_stat;
|
||||
- /* We don't bother setting gl_lstat, since glob never calls it.
|
||||
- The slot is only there for compatibility with 4.4 BSD. */
|
||||
}
|
||||
|
||||
void
|
||||
--
|
||||
cgit v1.0-41-gc330
|
||||
|
20
make.spec
20
make.spec
@ -3,7 +3,7 @@ Summary: A GNU tool which simplifies the build process for users
|
||||
Name: make
|
||||
Epoch: 1
|
||||
Version: 4.2.1
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/make/
|
||||
@ -24,9 +24,12 @@ Patch3: make-4.2-j8k.patch
|
||||
# The default value of .SHELL_FLAGS is -c.
|
||||
Patch4: make-4.0-weird-shell.patch
|
||||
|
||||
# Upstream patch: http://git.savannah.gnu.org/cgit/make.git/patch/?id=48c8a116a914a325a0497721f5d8b58d5bba34d4
|
||||
# Upstream patch: https://git.savannah.gnu.org/cgit/make.git/patch/?id=193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4
|
||||
# Fixes wrong assumptions of glibc's glob internals.
|
||||
Patch5: make-4.2.1-glob-fix-2.patch
|
||||
# Upstream patch: https://git.savannah.gnu.org/cgit/make.git/patch/?id=48c8a116a914a325a0497721f5d8b58d5bba34d4
|
||||
# Fixes incorrect use of glibc 2.27 glob internals.
|
||||
Patch5: make-4.2.1-glob-fix.patch
|
||||
Patch6: make-4.2.1-glob-fix.patch
|
||||
# Unfortunately the above patches configure.ac, so:
|
||||
BuildRequires: autoconf, automake
|
||||
|
||||
@ -53,13 +56,7 @@ Group: Development/Libraries
|
||||
The make-devel package contains gnumake.h.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%autosetup -p1
|
||||
|
||||
rm -f tests/scripts/features/parallelism.orig
|
||||
|
||||
@ -110,6 +107,9 @@ fi
|
||||
%{_includedir}/gnumake.h
|
||||
|
||||
%changelog
|
||||
* Fri Feb 02 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1:4.2.1-6
|
||||
- Fix wrong assumptions of glibc's glob internals
|
||||
|
||||
* Thu Feb 01 2018 Richard W.M. Jones <rjones@redhat.com> - 1:4.2.1-5
|
||||
- Add upstream patch to fix incorrect use of glibc 2.27 glob internals.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user