Add another fix for upstream bug 30612
This commit is contained in:
parent
c2611a71f6
commit
201e8d2a73
52
make-3.82-empty-members.patch
Normal file
52
make-3.82-empty-members.patch
Normal file
@ -0,0 +1,52 @@
|
||||
From b06b8c64a29a5ba3a8daecd829fa2f98d42cb285 Mon Sep 17 00:00:00 2001
|
||||
From: Paul Smith <psmith@gnu.org>
|
||||
Date: Sun, 12 Jun 2011 16:22:04 +0000
|
||||
Subject: Fix another error related to whitespace handling in archives.
|
||||
|
||||
Note that this is a stripped version of the patch--ChangeLogs and some
|
||||
VMS stuff were kept out.
|
||||
---
|
||||
diff --git a/read.c b/read.c
|
||||
index c87d4a7..b012094 100644
|
||||
--- a/read.c
|
||||
+++ b/read.c
|
||||
@@ -3044,16 +3044,16 @@ parse_file_seq (char **stringp, unsigned int size, int stopchar,
|
||||
nlen -= (n + 1) - tp;
|
||||
tp = n + 1;
|
||||
|
||||
- /* If we have just "lib(", part of something like
|
||||
- "lib( a b)", go to the next item. */
|
||||
- if (! nlen)
|
||||
- continue;
|
||||
-
|
||||
/* We can stop looking now. */
|
||||
break;
|
||||
}
|
||||
}
|
||||
while (*e != '\0');
|
||||
+
|
||||
+ /* If we have just "lib(", part of something like "lib( a b)",
|
||||
+ go to the next item. */
|
||||
+ if (! nlen)
|
||||
+ continue;
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/tests/scripts/features/archives b/tests/scripts/features/archives
|
||||
index 00aa1af..3fe46a0 100644
|
||||
--- a/tests/scripts/features/archives
|
||||
+++ b/tests/scripts/features/archives
|
||||
@@ -36,6 +36,11 @@ utouch(-50, 'a2.o');
|
||||
run_make_test('all: libxx.a(a3.o *.o)', '',
|
||||
"ar rv libxx.a a3.o\na - a3.o\nar rv libxx.a a2.o\nr - a2.o\n");
|
||||
|
||||
+# Check whitespace handling
|
||||
+utouch(-40, 'a2.o');
|
||||
+run_make_test('all: libxx.a( a3.o *.o )', '',
|
||||
+ "ar rv libxx.a a2.o\nr - a2.o\n");
|
||||
+
|
||||
rmfiles(qw(a1.o a2.o a3.o libxx.a));
|
||||
|
||||
# This tells the test driver that the perl test script executed properly.
|
||||
--
|
||||
cgit v0.9.0.2
|
13
make.spec
13
make.spec
@ -3,7 +3,7 @@ Summary: A GNU tool which simplifies the build process for users
|
||||
Name: make
|
||||
Epoch: 1
|
||||
Version: 3.82
|
||||
Release: 16%{?dist}
|
||||
Release: 17%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/make/
|
||||
@ -19,7 +19,11 @@ Patch6: make-3.82-weird-shell.patch
|
||||
|
||||
Patch7: make-3.82-newlines.patch
|
||||
Patch8: make-3.82-jobserver.patch
|
||||
|
||||
# Upstream: https://savannah.gnu.org/bugs/?30612
|
||||
# Upstream: https://savannah.gnu.org/bugs/?30723
|
||||
Patch9: make-3.82-bugfixes.patch
|
||||
|
||||
Patch10: make-3.82-sort-blank.patch
|
||||
Patch11: make-3.82-copy-on-expand.patch
|
||||
|
||||
@ -41,6 +45,9 @@ Patch16: make-3.82-dont-prune-intermediate.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=926115
|
||||
Patch17: make-3.82-aarch64.patch
|
||||
|
||||
# Additional fix for https://savannah.gnu.org/bugs/?30612
|
||||
Patch18: make-3.82-empty-members.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -72,6 +79,7 @@ makefile.
|
||||
%patch15 -p0
|
||||
%patch16 -p0
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
rm -f tests/scripts/features/parallelism.orig
|
||||
|
||||
%build
|
||||
@ -115,6 +123,9 @@ fi
|
||||
%{_infodir}/*.info*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 19 2013 Petr Machata <pmachata@redhat.com> - 1:3.82-17
|
||||
- Add another fix for upstream bug 30612
|
||||
|
||||
* Thu Apr 4 2013 Petr Machata <pmachata@redhat.com> - 1:3.82-16
|
||||
- Update config.sub and config.guess to support aarch64
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user